HD sata


I can’t install opensuse 11 because the suse don’t reconize the HD sata, my laptop is HP pavillon.

is anybody help me?


Is it a special sata HD ?
Standard sata is supported.


You need to post at the minimum the exact laptop model.

Same problem too, im using a desktop pc with a standard SATA hdd, same error
Error: No hard disk were found upon installation. Please check your hard disks!
I’m using 10.3 btw. Now, downloading suse11 hoping that its a suse problem. I can probe my hdd using other distros. Is there any fix for this?

Perhaps this info will be helpful to you or anyone else with a similar SATA “drive not found” problem . . .

Just to be clear, there is no such thing as “standard” SATA. When users think of SATA, they tend to think of the hard drive (although it can be a SATA optical drive, too, of course) itself. While obviously the drive must be SATA, what is important in this situation is the SATA disk controller on the motherboard. The controller may be in the motherboard chipset, or it may be a separate device on the board. (Often if the board supports both PATA/IDE and SATA, the former is handled by the chipset and the latter by an additional device.) The way that SATA is implemented on the device differs considerably one to the next. Some devices are true SATA, others are simply a modified PATA, and there are those that fall in-between.

To install to a SATA drive, the installer must detect the controller and load the necessary driver for it. If you have ever done a clean install of Windows XP or Vista you may have encountered a similar situation, where you must provide the SATA driver on separate media - the infamous F6 floppy requirement. With openSUSE, there is an excellent chance the installation media has the needed driver, although it may not have detected it. One reason for this (and the reason why one distro may load it but another does not) is that there may be more than one driver for the device, because of changes in versions of the device or changes in the kernel or both. The kernel may not be able to determine which version of the driver is necessary. Or, it may only know of one (depending on kernel version) which may or may not be the right one.

If you encounter a “drive not found” error, restart the installation and depress the Escape key to drop the graphical interface down to text (or just use the “text” install option from the menu, but it will be more readable if you do the former). After the kernel initializes the basic hardware (cpu, ram, pci) it will look for the disk controller(s) and try to load the driver(s). You may see your problem here.

You may need to research the hardware on your system to determine the disk controller device (see below). Once you know the device (and the motherboard, if at all possible), searching the internet for the linux driver/kernel module usually turns up the name quickly, plus any issues other users have encountered.

At the installation menu, there is an F key to indicate you want to install an additional driver. The installation will route you to a point where you can select from all the drivers on the media, organized by category. Find the section for disks, find the driver module you need from the list, and select it. SuSE will then load that driver, and chances are, you’re good to go.

Re finding what the disk controller is: You may find the information by searching on the make and model number of your computer. But, many manufacturers do not provide this information, or make it difficult to find. If you have Windows installed, try running msinfo32.exe. Under the System Summary, you may find the motherboard listed. And under Storage, there is a section for SCSI; this is where you may find the SATA controller. If none of this gets you the needed information, you can download and install a free hardware diagnostic program (SiSoftware Sandra is probably the most widely used, and it is perfectly safe) which will definitely give you the information.

Hope this helps. Good luck.

The second-to-last paragraph above needs to be clarified, and there is a very important addition that needs to be made.

The F6 option on the installation menu is very similar to how the Windows 2000/XP installation enables the user to add a SATA driver on a floppy disk, or how Vista does the same except from both floppy or CD/DVD. Except that openSUSE’s method is much more flexible: Under F6 there are three choices:

Yes - takes you to a menu where you can choose from any device attached to the system that can already be recognized. That is, a floppy, an optical drive, or any partition on any disk that is already seen (which obviously, in this case, would not include the SATA drives).

File - brings up a CD/DVD box where you can supply the name of a file on a readable optical disk. This will only work for drivers which do not have to match the version of the operating system kernel which is being installed.

URL - allows you to provide a web url pointing to a set of drivers newer than what is provided with the installation. This is useful for example if you are installing with media that is months old and since it was released, a new or updated driver you need has been released. The default is http://download.opensuse.org/update/11.0/driverupdate

In addition to the above methods, there is another way to load a driver which is not advertised but which is IMO better than any of the above, because it does not require the user to have obtained and put the driver on media, etc. Furthermore, this method may even enable the user to find the driver without knowing in advance specifically which one is required. Here is how it works:

Re-start the installation normally. At the first screen (the License Acceptance) click on Abort. You will be taken to another “an error occurred during the installation” screen, click OK, and you will be taken to the main menu of “linuxrc”, which is a shell which wraps the kernel inside the installation. On that menu is a selection “Kernel Modules (Hardware Drivers)”, choose that to go to a list of sub-menus. The first choice “IDE/RAID/SCSI” is for disk controllers (SATA is in the SCSI class). Select that and you will be presented with an extensive list of driver module names and the accompanying manufacturer/model number.

So for example, if your SATA drive is on a Silicon Image device on your motherboard which was not automatically detected, you will see it here. The same is true if your drive in on a SiS combined RAID/SATA, or it is on an add-on Promise PCI SATA card. Because the make/model is also often listed, you may be able to identify the driver even if you don’t know its specific name. In a few cases (via, for example) it can be difficult to know which one to choose; select one and try it, if it doesn’t work, repeat the process selecting another.

Important final note: There are other linuxrc sub-menus besides the one for disk controllers, which you may need to use. There is one for USB and another for Firewire; many external devices connected to these ports use a proprietary interface, you will find those drivers here. Or you may need one of these if installing to USB key or smart card storage. There are also additional drivers for PCMCIA cards and Network devices/cards. Finally, there is a selection to “Show Loaded Modules” which will display all the drivers which have been detected, useful for narrowing down what may need to be additionally loaded, or, in the very unusual occasion when one driver conflicts with another, here you can remove the driver that was automatically detected and replace it with one which you select.

All in all, driver selection is a very powerful feature of openSUSE.

If it is a older motherboard with SATA 1 jacks then u must link the two links at the back of the drive to force it to be slower (1.5Gbps) instead of the newer boards that can handle 3Gbps. I had the same problem so I found the solotion on the Seagate website with picture and all.


This depends entirely on the particular drive and motherboard. For example, some SATA II drives have “auto-sensing” which automatically will drop the drive settings to match the SATA controller on the board.

However, I have encountered another issue that should be added to this thread, which I’ll put in a separate post.

As discussed above, the bios setting for the disk controller is critical. With many bios’s, there are multiples choices, and there can even be different settings for a subset of the SATA ports. The choices are typically “SATA”, “RAID”, and “AHCI”. The “SATA” choice may be in reality mean “native standard SATA” or “IDE emulation” - with this configuration, openSUSE will chose a kernel module with “sata” in its name and possibly accompanying IDE modules (even though the drive is SATA). If the setting is AHCI or RAID, then the “ahci” kernel module must be used (AHCI is an Intel standard which adds certain features to SATA such as Native Command Queuing).

Some users, after changing the bios setting and installing openSUSE, have found that Windows cannot boot; this also often happens when installing in a new machine (or with a new motherboard) using a disk with Windows already installed from a previous system. What needs to be remembered is that at installation, Windows will install only its IDE/SATA driver if the bios is set to SATA; it will not install the AHCI driver. So if the bios is changed or the disk is swapped into another system configured for RAID or AHCI, Windows is now missing the necessary driver. Some quality motherboards have a built-in solution to this problem which is unfortunately little known: There will be one or two SATA ports which can be configured separately in the bios, i.e., the user can configure some ports as RAID/AHCI and others as SATA. With this solution, the user only needs to connect the Windows drive to a port separately configured as SATA (usually a port at the bottom of the chain), boot into Windows, and install the AHCI drive so Windows can see the RAID/AHCI ports. There are alternative solutions documented on Microsoft’s Knowledge Base, but they are typically unacceptable (varies by version of Windows, but will usually require working access to the Windows registry and/or access to Windows installation media and/or doing a slipstreamed reinstall).

Wow :slight_smile:

You considered putting that together into a howto?

Probably doesn’t even really need reformatting - just consolidating into a single post, with a few headings.

But that’s a lot of useful information to leave to the obscurity of a forum thread - and it fills a niche, in that there doesn’t seem to be a ‘general’ sata page on the wiki.

Thanks. Actually, Lee offered that I do the same and I said I would when I found time. But shame on me, I haven’t got to it yet (having trouble keeping my head above water with other things). It does need a bit of rework, though. Hopefully, soon. :embarrassed:

Very good info on this thread, thanks.

I once had the SATA jumper problem with an “old” 200 GB drive. Opensuse 10.2 wouldn’t recognize it unless it was jumpered to 1.5 GB, as the motherboard didn’t support 3.0 GB mode, IIRC. Or was it a bios setting?

It depends on the particulars of the motherboard, the drive, and the bios. First, it’s a matter of what the disk controller (typically in the Southbridge, but sometimes a separate discreet device) supports. Additionally, sometimes there is a bios setting required; but, sometimes not, i.e., the controller may rely on what it senses from the drive. With the drive itself, it is different between drive manufacturers and even from one generation of drive to the next. Generally, there is a jumper that may be required. But some drives have “auto-sensing” where the drive queries the controller and sets itself to what the controller supports. Western Digital drives have both auto-sensing plus a jumper as a backup if needed. Bottom line is that all three must be in sync, and the method of doing so varies somewhat.

This seems to be a SuSE issue – or at least an issue that it has with my motherboard, a Gigabyte GA-EP45-UD3P and the fact that my SATA drives are run from the Southbridge of that motherboard (ICH10R). None of the suggestions offered by Shaman Penguin have worked for me. And yet, Fedora 11.1, Mandriva 2009, and Ubuntu will all install without errors. Go figure.

I don’t believe it to be an SuSE issue as I recently had an issue with SATA in PCLOS however SuSE had no such issue. PCLOS is the only Linux OS my wife is comfortable with,so it was my only option.

The information on this thread would have saved me many hours and had my wifes laptop running in just a few attempts,instead of over a week.

On reading this thread I feel it would be difficult for most to not walk away without an increased knowledge of SATA or hardware detection in general.

I totally agree with a previous post suggesting this should become a how to.thanks mingus725 ,verry nice!