Hayulp!!! KDE/Firefox/chromium broken!

Hi guys, I was just starting to get settled with with 12.2/KDE 4.9.3 so I decided to personalise a bit. I installed some fonts from a old windows install…

I went to configure desktopand made some adjustments to the stock fonts, and also to GTK fonts. All seemed OK but then I tried to open a browser, and both FireFox and chromium were borked, with no readable text!! http://wstaw.org/m/2012/11/11/plasma-desktopV11179.png


Any ideas please? I have tried to downgrade the chromiuim, to see if it would overwrite whatever settings were there, I have re-set the KDE fonts via configure desktop to defaults, and reset GTK fonts to ‘Use KDE’ fonts, but still the browsers are in his sorry state… ANy tips welcome… I will also be lurking about on IRC, but have to go and prepare family dinner…

That happened to me and was fixed by reinstalling video driver. But I was using openSUSE Tumbleweed and Nvidia at the time. Which version of openSUSE are you running and what is your video situation? (/usr/sbin/hwinfo --gfxcard).

(of course, that might not be the problem at all)

BTW, it’s a good movie.

Thanks guys…After a lot of head scratching, and sleeping on the issue (and reinstalling nvidia drivers) (…and some more or less random deleting of probably unrelated files…) some googlery fond the answer… Dragging and dropping the fonts from a MSWin install does work, BUT their permissions must be changed…
So I:

sudo chmod -Rv 775 /usr/share/fonts/

And bingo! I can use my browsers again!

I wonder if this info should be put somewhere other idiots like me can find it easily, as my panicky title will not show up on google searches for fonts

No, this info should not be put somewhere, since changing default permissions on a system folder is not the way to go. If you want MS fonts, install the " fetchmsttffonts " package. Another option you may have, is to run SuSEconfig after copying the fonts. That will trigger /sbin/conf.d/SuSEconfig.fonts and rebuild the fonts database.

I did run the Suseconfig after copying the fonts…

Mmmm, I guess there should be better ways to import fonts, maybe at user level.