Having trouble installing an application + changing a command

Hello. I’m having newbie trouble with 2 things right now and was wondering if anyone could help me out.

  1. I’m trying to install ¨fairymax". I downloaded the package from here:

Fairy-Max (at the very top of the page)

I extracted the archive, then in terminal cd’ed over to the folder and tried the install. But it didn’t work:

steven@linux-3kv4:~/Fairy-Max> sudo make install
root's password:
cc -O2 -s -DINI_FILE=\"/usr/share/games/fairymax/fmax.ini\" fairymax.c -o fairymax
make: cc: Command not found
make: *** [fairymax] Error 127

steven@linux-3kv4:~/Fairy-Max> sudo makefile install
sudo: makefile: command not found

steven@linux-3kv4:~/Fairy-Max> sudo Makefile install
sudo: Makefile: command not found

steven@linux-3kv4:~/Fairy-Max> sudo apt-get install fairymax
sudo: apt-get: command not found

steven@linux-3kv4:~/Fairy-Max> sudo zypper in fairymax
Loading repository data...
Reading installed packages...
'fairymax' not found in package names. Trying capabilities.
No provider of 'fairymax' found.
Resolving package dependencies...

Nothing to do.
  1. In following the advice of answer D.6 here (I have GNUchess installed from a repo):


I tried to modify the icon of Xboard on my desktop folder. I right clicked the icon, clicked “properties” → “Application” … in the field “Command” I tried to change what was there “xboard” to "xboard -fcp “gnuchess xboard” but got an error along the lines of “Could not save properties. You do not have sufficient access to write to /home…/xboard.desktop” … I was logged in as sudo in terminal as well as logged in as admin to Yast when I tried this.

It’s asking you for gcc to be installled

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.9-1.4-desktop
up 7:35, 3 users, load average: 0.01, 0.03, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

You need compiling tools, what I did on my system Suse 12.1 (64) was, go into Yast, install/remove programs, changed filter on the left to patrones (patterns I suppouse in English) and then click on development in a box that says desarrollo base (basic development I suppouse), that will install neccesary tools for you to compile and that includes a gcc compiler.

Thanks guys. Both your suggestions worked :slight_smile: