Having difficulty with WEP connection

Hi everyone.

I am relatively new to Linux and OpenSuSE, but I have been using Ubuntu and some other distributions in the last 3 months or so. There seems to be an issue in this KDE 4.3 that is preventing me from connecting to my Linksys router whenever I enter my WEP passphrase. Is there a reason why it’s doing this? Basically what happens, is that it things for a while and then the network (secrets for connection) comes up but changes the key type to Hex or Ascii key (whatever this means)…

All I wish is to connect to the wireless network like all of the other distributions I have tried.

and yes, I have read things about ‘you need a WPA key’ or something and I only have a WEP key, so I’m afraid this isn’t acceptable as an answer.

Thanks in advance for your help.

Maybe you can consider to upgrade to latest KDE.

KDE4.4: Howto: Install KDE4.4 in openSUSE11.2 - openSUSE Forums
KDE4.3.5: Howto: Upgrade KDE4.3.1 to KDE4.3.4 in openSUSE 11.2 - openSUSE Forums

OR
Open YaST, goto Network Devices -> Network Settings -> Global options (Select ‘Traditional Method with ifup’), then click Overview tab and select your wireless device and click Edit button down. And follow the step by step procedure.

Hope, this help.

Edit: Welcome to openSUSE forum.

On 03/22/2010 06:36 AM, fatninja90 wrote:
>
> Hi everyone.
>
> I am relatively new to Linux and OpenSuSE, but I have been using Ubuntu
> and some other distributions in the last 3 months or so. There seems to
> be an issue in this KDE 4.3 that is preventing me from connecting to my
> Linksys router whenever I enter my WEP passphrase. Is there a reason why
> it’s doing this? Basically what happens, is that it things for a while
> and then the network (secrets for connection) comes up but changes the
> key type to Hex or Ascii key (whatever this means)…
>
> All I wish is to connect to the wireless network like all of the other
> distributions I have tried.
>
> and yes, I have read things about ‘you need a WPA key’ or something and
> I only have a WEP key, so I’m afraid this isn’t acceptable as an
> answer.

As has been discussed many times in this forum, the method used by Linux to
convert a WEP passphrase to a hex key is different than the one used by Windows.
This is OK as the “standard” allows BOTH methods; however as the
communications only use the key and not the phrase, the only sure way to use WEP
is to have the key. You should be able to log into your router and see that key

  • at least I can in mine. For WPA/WPA2, there is only one conversion method and
    the phrase can be entered.

would this work and how do I translate it to opensuse command line? I googled and found a bunch of things relating to my issue this seems promising.

First close down all NetworkManager stuff and associated services,
/etc/init.d/NetworkManager stop
/etc/init.d/wpa_supplicant stop
/sbin/dhclient -r

Then reloaded the kernel module with the option to disable n-type connections,
modprobe -r iwlagn
modprobe iwlagn 11n_disable=1

Then started wpa_supplicant from the command line (with all debugging)
/usr/sbin/wpa_supplicant -Dwext -dd -t -i wlan0 -c /etc/wpa_supplicant.conf

Then, in another terminal, I have run arping to see when the wireless card becomes ready to accept inward traffic,
arping 192.168.1.1 -I wlan0 -D

Other users in the bug report have mentioned that once this completes, you are ready to go. I’ve found I have to rerun arping until I got to the stage where I only needed one broadcast for one response. Anyway.

Then, run dhclient,

dhclient -v wlan0

This should associate and set up a new lease from the DHCP server.