Having a problem with the graphics driver on my Suse 12.1 installation

Hi there,

I’m having a problem with my graphics driver. It is for a Radeon HD 5670. I tried installing it last night but I didn’t do it correctly and now Suse won’t boot up in normal mode. How can I change the driver back to the previous default driver again?

I think it has something to do with there are packages missing so that’s why it’s not working.

I was having other problems before trying to install Suse because I was using a RAID setup alongside the drive I’ve installed Linux on.

If you look at this thread here you’ll see what was said:


It is my last post where I discuss the problems I’m having…

I just need to get it booting again, I can enter the failsafe mode OK.

The other problem is that since I’ve installed Suse 12.1 it’s not stable and it was crashing before and the mouse and keyboard would freeze so I was forced to do a hard reset to get my machine working again.

It’s the 64 bit version of Suse 12.1 that I’m using, do you think it could be because it’s 64 bit that it’s not stable?

How did you install the drivers? I have 64bit too and similar graphics card. What I did was the “Building FGLRX Manually” mentioned on here ----->


In one of the codes mentioned there

sh ./ati-driver-installer-11-4-x86.x86_64.run --buildpkg SuSE/SUSE-autodetection

Just substitute “ati-driver…” with what ever the name of the driver file you downloaded from there I’m guess the name now starts like “amd…” but whatever, just replace that, everything else should be self-explained I guess. Oh and also make sure the file you downloaded is in the pwd, if not, *cd *into that directory!

This is will be a good way to install it yourself. But to go uninstall your current troublesome driver, you might have to wait until someone replies with the method. I don’t want to tell something I haven’t tried :wink: There is a GUI way of doing this, but I wouldn’t recommend it, as it left me with some problems.