Having a Couple Problems on the Install of 13.2 and could use some help

Hey all,

This weekend I tried installing openSUSE 13.2 for the first time, I’ve never used openSUSE before and was previously running Ubuntu which I was overwriting. I went through the entire installation process from my Live USB and it appeared to install with no issues. However, when it reboots to open for the first time I get an error with grub2, “GRUB rescue - error: unknown filesystem”.

Apparently this error is not uncommon so I followed the advice from some previous threads and did an “ls” in this view to look for all the partitions: what returned was “(hd0,gpt1)” through “(hd0,gpt10)”. Following the advice of these threads I tried to list the contents of each partitions root. All of them came back “unknown filesystem” except for one, (hd0,gpt8) which returned the following:

./ ../ lost+found/ tom/

All of the previous suggestions were predicated on the idea that one of these partitions would have a “boot/” directory listed under the root of one of the partitions, but alas, mine did not.

Then I tried rebooting into the recovery mode of the Live USB. This is where I found something interesting. I was trying to look for clues as to what went wrong and when I did an “fdisk -l” I found that the 3 partitions in which openSUSE installed root, home, and swap (/dev/sda7, /dev/sda8, /dev/sda9, respectively) were listed by fdisk to contain “Windows Basic Data”. The machine that I am installing on does dual boot Windows 8.1 which worked alongside by Ubuntu previously. I’m at a loss as to what would cause this.

My present theory is that all the openSUSE data has been written onto these partitions but for whatever reason they are not being recognized as containing that data. I am by no means a Linux expert though so I would really appreciate any help that you guys and gals could give me in trying to set this up. Let me know if there’s any more information that I can provide to you.

Thanks in advance!

-Tom

Did you boot the installer with UEFI?

I’m guessing that Windows is UEFI. Mixing UEFI with legacy booting causes problems.

I guess I’m not sure? Is there a way I could check / remedy this?

did you do a UEFI install?

can you mount and open a terminal in /dev/sda7?

if so try the command

grub2-mkconfig -o /boot/grub2/grub.cfg

this should rebuild grub2

also you possibly need to select ‘search for foreign OS’
in -yast --boot loader

So I did previously try running

grub2-mkconfig -o /boot/grub2/grub.cfg

in /dev/sda7 but it wasn’t able to complete. I believe that the error it gave was “can’t find /proc/something”, although I had previously tried doing

mount /proc /mnt/proc

As for the UEFI install, I apologize but I’m not super familiar with the terminology so I can’t say definitively. I’m not sure how I would find out. Is that like a configurable option? What’s the alternative? I am installing from a Live USB which I am manually selecting from the boot menu

you need to look in the machine BIOS and see what is selected there

alternatively try cmd

chsh -R /dev/sda7

then

grub2-mkconfig -o /boot/grub2/grub.cfg

It was indeed a Legacy/UEFI boot problem. I just reinstalled with Legacy and now everything is working. Thanks for your help keellambert. Cheers!

MMM You should not mix EFI and MBR booting. So I guess your Windows was installed as MBR??

That is unusual for a machine that as EFI generally Windows is installed EFI mode and so you need to install openSUSE in EFI mode also. This is done by booting the install media in EFI mode. It should then use grub2-efi boot loader and should mount the boot EFI FAT partition as /boot/efi

Also secure boot may give you a problem if it is turned on in the BIOS and you did not check the secure boot box in the installer. MBR installs will ignore secure boot.

Yes, g, I think you should guide the OP to identify exactly if EFI is or is not present and hiding, or no mixup of the two is going on. Probably best to be certain, rather than just cross fingers … :wink: