Have I permanently damaged my computer?I think I may have broken /dv/ttyS0?

Ok. before I start, I’d just like to make it clear that I’m not another one of those idiots that’s complaining about how Linux is stupid and breaks computers. I’m confident that the problems I’m having are entirely of my own making, and I’m just one of those people that provr that a little knowledge is often a dangerous thing. I’ve been happily using Suse since version 9.0 and, as such, am fairly comfortable with the basics of cofiguration, compilation of software and things like that, but not so well versed that when I make a real mess of something that I am able to put it right. Combine that with the fact that I had a stroke a little less than a year ago and I can’t see very well any more and my memory is now rather hopeless and I guess it’s a recipe for disaster.

So with that out of the way, here’s what I think I’ve done. A little while ago I tried reconnecting my computer with my Cisco Catalyst 2950 switch. For many reasons which have nothing to do with the problem I’m having I needed to have it connected via a standard Ethernet cable for normal internet access, and another cable (Serial-to-RJ45 “rollover”) for administrative access. I did this without a problem on last year on whichever version of Suse was the latest one at the time, but since then I’ve had a stroke which damaged a lot of my ability to remember things and be able to see, and also upgraded to the current version (11.4) of Suse.

I thought Irembered using a combination of

setscreen /dev/ttyS0

or it might have been just S0 or ttys0, or s0. which I do remember was a one-off command that I never needed to enter again.


screen /dev/ttyS0

. Which I used any time I wanted to connect to the switch via the serial cable

As you can see, I couldn’t recall the exact grammar of the commands and when I tried to look them up with Google I just kept finding completely irrelevant pages. So I tried to figure it out by myself but I failed I kept getting messages about /dev/ttyS0 not being a pty or something like that…At the time I was doing this, I also had a few other CLIs open for other tasks and what I suspect I may have done, is thought that I had closed all the CLIs that I were using to try connecting to the switch, but instead of closing them, got them mixed up with the other ones and started writing into them gibberish about starting Apache or configuring bind.

Is it likely that I’ve messed something up quite badly? Iask because it takes a very long time to start Suse normally now and pressing escape on the splash screen to try and see what it is actually doing doesn’t work. The only way I can get to see what it is doing when it is actually booting is too boot using the failsafe mode option.When I use that option I see some rather unfamiliar output which I’m fairly sure mentions S0, but I can’t be sure because it scrolls off the screen too quickly and I can’t really see it very well anyway. I think it says something about being unable to find, configure, or bind to S0 or something like that.

Windows (7) also seems affected by it, but does its best to hide it. It might just be me, but it seems to spend longer on the black screen with the Windows logo and the lights flying around it with the “Windows is starting up”. And then when it gets to the login screen for password entry it seems to hang for about 10 to 15 seconds before my UsB mouse and keyboard start working.

Has anyone got any ideas about how I can find out what on earth I’ve done to my machine? I’m worried that I might have damaged a hardware setting and that’s why both Operating Systems seem to have problems starting.

Would it help to pos the boot meesage fie? Where is it?

Would it help to pos the boot meesage fie? Where is it?

I guess that could be useful (at least the last section as it is usually quite long as file). You find the log files in /var/log/
One is /var/log/messages the other I think you should have a look at is /var/log/warn. You have to be superuser to see them so either you open dolphin in su-mode or you use the terminal. Maybe the first option is the most comfortable one.

When you are looking after the name of the device special file, it is /dev/ttyS0.
That comes from tty = Teletype (an early type of terminal that usd ink and paper), S = Serial (port) and* 0* (the number) from being the lowest numbered one.

Thus the last character id a 0 (zero), not an O (capital letter) as you have.

You can see if this one (and his brothers/sisters) is available with

ls -l /dev/ttry*

Normaly eight of them (numbered 0 - 7) are created by udev.

It is possible to screw up the UART registers by writing “rubbish” to the serial port control channel. Reset by powering the machine down and disconnecting it from the mains supply for a few (~ 10) seconds.

The stty command is used to query/configure the serial ports. Make sure you are in the appropriate group (dialout) It might help if you could describe the hardware – hwinfo can assist.


sysman@alessia:~> l /dev/ttyS[01]
crw-rw---- 1 root dialout 4, 64 2011-10-26 17:50 /dev/ttyS0
crw-rw---- 1 root dialout 4, 65 2011-10-22 09:08 /dev/ttyS1

sysman@alessia:~> stty --all < /dev/ttyS0
speed 9600 baud; rows 0; columns 0; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>; start = ^Q; stop = ^S;
susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 hupcl -cstopb cread clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel -iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke

sysman@alessia:~> stty 19200 < /dev/ttyS0
sysman@alessia:~> stty  < /dev/ttyS0
speed 19200 baud; line = 0;
-brkint -imaxbel

sysman@alessia:~> sudo /usr/sbin/hwinfo |grep uart
  0: uart:16550A port:000003F8 irq:4 tx:313 rx:0 RTS|DTR
  1: uart:unknown port:000002F8 irq:3
  2: uart:unknown port:000003E8 irq:4
  3: uart:unknown port:000002E8 irq:3
  4: uart:unknown port:00000000 irq:0
  5: uart:unknown port:00000000 irq:0
  6: uart:unknown port:00000000 irq:0
  7: uart:unknown port:00000000 irq:0
  uart 16550A, line 0, port 0x3f8, irq 4, baud 0
  snd_mpu401_uart 14169 1 snd_mpu401, Live 0xffffffffa02e3000
  snd_rawmidi 34789 2 snd_seq_midi,snd_mpu401_uart, Live 0xffffffffa02f3000
  snd 86251 12 snd_pcm_oss,snd_mixer_oss,snd_seq_midi,snd_seq,snd_intel8x0,snd_ac97_codec,snd_mpu401,snd_pcm,snd_mpu401_uart,snd_rawmidi,snd_timer,snd_seq_device, Live 0xffffffffa030b000

On 2011-10-26 16:56, Stephen Philbin wrote:

> For many reasons which have nothing to do with the problem I’m
> having I needed to have it connected via a standard Ethernet cable for
> normal internet access, and another cable (Serial-to-RJ45 “rollover”)
> for administrative access.

The typical program to do this would be minicom.

And I doubt you could damage permanently the serial port. It is usually a
quite resistant piece of hardware.

> Would it help to pos the boot meesage fie? Where is it?


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Wow. Thanks for all the helpful replies everyone. I tried just disconnecting the computer from the mains supply and it worked! I just pulled the plug and went to bed. When I got up this morning I plugged it back in it worked fine. I thought the settings that I had messed up messed up may have had default settings in the BIOS or something that I might have to reload, but that probably wouldn’t have been an option because I assume that would have wiped my overclocking settings (which I did not set myself and would not really want to meddle with).

So a big thanks to everyone who offered advice. lol!

I’ll go and look up this Minicom thing now and hopefully avoid the need of using the methods I have been using so far.

Thanks X 1,000,000