Hauppauge WinTV-HVR-950 USB TV Tuner Problems

According to LinuxTV, this TV Tuner is supported by Linux.

I followed the directions on this webpage, but I was unable to use the TV Tuner.

dmesg | grep dvb 

“em28xx #0/2: dvb frontend not attached. Can’t attach xc3028”

What does this mean?

I used Google to search for remedies, but I was unable to find one.

Others posted on this forum that they were able to use the tuner, but there are no solutions to their issues. Does anyone have any solutions to my problem?

I have updated the HCL/TV Cards page to include a compatibility with the device.
Whenever you plug in the device for the first time, note what is stated in the kernel log. KSystemLog should make it easy to track the changes in the kernel log. As stated on the HCL/TV Cards page, the only problem experienced is audio capture.

I get this message:

Em28xx: Initialized (Em28xx dvb Extension) extension

I take it this is a good thing, but I do not know what to do from here. The Yast TV module does not seem to automatically recognize it, I can’t find the HVR 950 in the list of devices I can select manually, tvtime does not seem to pick up the device, and xawtv and motv don’t work at all (they need dga which nvidia no longer supports).

TvTime would not work for me automatically, because it uses /dev/video0 by default, which was assigned to my webcam.
I had to pass the arguments “-d /dev/video1” each time I started. However, I am sure one can make this change in the config file.
Make sure you use the video device that corresponds to your TV Tuner. Yes, unfortunately, this device is not supported by YaST.

TheBlackCat, what is “dga” by the way? I am using Intel’s 965GM Integrated video card.

I only have one video device. I am still getting “No signal” with tvtime. Tvtime doesn’t seem to have an option for DVB or ATSC. How do I set it up to use HD broadcasts?

Have you tried a scan? assuming you have the dvb tools installed;

scan /usr/share/dvb/atsc/us-ATSC-center-frequencies-8VSB -o zap | tee

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 17:49, 1 user, load average: 0.36, 0.65, 0.53
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

The scan failed to find any channels.

So it’s actually working as such, creating a /dev/dvb/adaptor0
directory. You get the correct output from dmesg when you plug the
device in? I’m also assuming you used the relevant scan file releated
to your location?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 1 day 7:42, 1 user, load average: 0.00, 0.39, 0.38
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

tvtime does not and never has worked with DVB tuners.

Also, remember that TvTime, although a wonderful TV viewing application, is unable to record television. TheBlackCat, you may have more success with MythTV, but be prepared to invest at least 3 hours configuring it.

It looks like I didn’t have the firmware installed. It’s working now it seems. Where do I put the atsc config file and ntsc config file so mythtv and other programs can find it?

Is there something special about the firmware downloaded from the links provided by the linuxtv.org website? Would it be better to use the latest firmware from the Hauppauge website? Might that fix the audio issue? The extract utility complains about the checksum if I try to use the latest firmware but I could edit it to remove that I suppose. If I do use the latest firmware, do I want to use the 32-bit version or the 64-bit version (I am using 64-bit opensuse 11.1).

Also, is there a way to make “scan” pick of analog channels?

Not sure about mythtv but for mplayer it’s /etc/mplayer/channels.conf
or in your ~/.mplayer directory. I’m guessing it would be the same sort
of place, just check the documentation.

I would try the latest, I’m guessing somewhere in the script the md5sum
may be hard coded?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 1:32, 1 user, load average: 0.17, 0.13, 0.10
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Forget the last bit, there aren’t going to be any analog channels in a couple of weeks so it is a waste of time trying to get them set up.

I would suggest the 64-bit version since you are working on a 64-bit operating system. Of course, you can experiment with both of them and see which works for you.

I would still desire an application that can easily record television. MythTV is not optimal, because it takes too much time to setup and did not work for me. Freevo also takes a lot of tweaking to function. Are there any other suggestions?

Does anyone know what card type I should use for the mythtv “capture card setup” to get HD broadcasts?

Do a search on the id you get from the lspci output (or lsusb). For
example here is mine (usb though);

Bus 005 Device 004: ID 05e1:0400 Syntek Semiconductor Co., Ltd

It has the ID of 05e1:0400 which after patching the au0828 module it
all kicked into life.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 1 day 3:41, 1 user, load average: 0.15, 0.14, 0.18
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

I figured it out, it is a “DVB DTV capture card”

Even though this is four years later, I can attest that the device works(at least with TvTime(no audio without fix)) after installing the 32-bit not 64-bit xc3028.fw driver. I emphasize 32-bit over 64-bit, because I have a 64-bit operating system on a 64-bit machine.

I have upgraded to openSUSE 11.4 and have the kernel.

Follow instructions here: “http://linuxtv.org/wiki/index.php/Hauppauge_WinTV-HVR-950” to get it to work.

Good on you for reporting that this hardware works in a currently supported openSUSE version. Maybe you could record this, along with any relevant comments in the HCL: Portal:Hardware - openSUSE

mplayer tv:// -tv driver=v4l2:norm=NTSC:input=0:device=/dev/video1:chanlist=us-cable:alsa:adevice=hw.1,0:amode=2:audiorate=32000:forceaudio:immediatemode=0


Play around with the settings for it to work optimally.