Has there been a change in broadcom wl drivers in kernel 11.1?

Please help me understand how the wifi works. When I did a clean install of TW with kernel 11.1, I cannot get TW to recognize my broadcom 4360 wifi chip. However, when I do a clean install of Leap 42.2, I download the wl driver from packman, (prior to, I do a package switch), reboot, and the software identifies the broadcom 4360 wifi as I normal. However, I do the same as I always have in the new install of TW, download the wl driver, reboot and nothing. I tried the workaround, nothing., I tried a couple of different drivers, nothing. However, my KDE connect works fine, and my bluetooth works fine. Does this mean that my driver is working although the broadcom chip is not identified? I know my AMD GPU drivers are automatically installed, I just wonder if there is a change in the wifi settings in the new kernel that automatically locates and installs. Thanks, I learn alot from just reading posts.

Did you try to build the initrd new after installing broadcom-wl-kmp-default and broadcom-wl by:

mkinitrd

no I didn’t. Never had to do that before. After I select the drivers, hit accept, then do I just open a terminal and do “mkinitrd”?

That worked! I never had to load it into the ram disk image before. Thanks so much!!! Learn something new everyday from you guys.

It worked on my end too. Similar problem definition, same resolution. Required a reboot before the wifi shows up. Thanks.

Lin