has anyone tried m2 yet?

has anyone tried m2 yet?

question 2 has anyone tried m2 yet using a uefi system?

I am currently downloading. I will be trying it on a UEFI box. I’ll post back when I get to that point.

I have installed M2 on a UEFI system. I had secure-boot enabled. The install went pretty well. The boot section of install default to installing secure-boot support.

I have not yet had much time to try things out. KDE seems to be at 4.10.4, and Gnome seems to be at 3.8.2.

Selecting “Gnome Classic” from the KDM menu still does not work. At some time I will switch to GDM, where it probably does work.

This time the repos are properly configured, except for then non-oss update repo. That’s pretty normal at this stage. I disabled that repo.

Installed M2 on a non-UEFI system (not an update from M1). 64 bit KDE desktop. No installation problems at all. Amarok still won’t run. Can confirm that the list of repos is now for 13.1, but the usual list of add>community repos is unavailable for some reason.

Updated to milestone3 via the factory repo all attemps to use the live iso 64 bit failed miserably both on a live install and virtual box. gnome and kde both I am currently installing gnome in virtual box with the net installation disk

I have not had much success - using a uefi system with secure boot switched off.

First try was using a kde live cd - no bootloader installed

2nd go was using the dvd - same problem

3rd attempt I tried to be clever I re-installed 12.3, then installed m2 thinking that if there was already an opensuse bootloader entry perhaps m2 would update this. Again no luck m2 removed the bootloader entry

My last try was enabling secure boot and using the dvd. Again no bootloader was installed

I have given up for now and re-installed 12.3 again

That sounds similar to the problem that I had with M1.

However, in spite of the message, the boot loader was mostly installed. What failed, was adding an entry to NVRAM. The boot files in the EFI partition were mostly there, but the “grub.cfg” had not been generated.

I was eventually able to add an NVRAM entry using “efibootmgr” from a rescue boot, with the 12.3 live rescue system.

Maybe look at the discussion in Bug 822770.

I did not run into that problem with M2. I was hoping that the related kernel bug had been fixed. But maybe it is still there.

What sort of hardware are you using? In particular, who made your BIOS (or UEFI firmware)?

Fresh eyes today and it worked. I tried again with secure boot enabled and it installed fine. I was at fault here I think when I enabled secure boot yesterday I had changed the type from standard to custom without realising. I uninstalled, disabled secure boot and tried again but no bootloader was installed. I then installed 12.3 again (leaving secure boot off) and this installed fine (with a bootlader entry. Wiped this and re-installed M2 - with secure boot enabled - and it worked fine.

M2 looks pretty good. I have only hit two problems - the amarok one - and libreoffice starts but just closes. On the 2nd problem I just cheated and installed the verion of libreoffice from the the M1 dvd. All the packman media stuff (from the 12.3 repo) works fine.

Is there a work round for amarok?

Install clementine. Amarok is broken too many times for my taste

Install clementine. Amarok is broken too many times for my taste

I have clementine already installed. I usually alternate between amarok, clementine & xmms

I am installing from upstream https://build.opensuse.org/package/show?project=KDE%3ADistro%3AFactory&package=amarok
will let you know soon

That didn’t work either


dale@linux-xggi:~> amarok -d
amarok: BEGIN: App::App() 
amarok:   BEGIN: void App::continueInit() 
amarok:     BEGIN: EngineController::EngineController() 
amarok:     END__: EngineController::EngineController() [Took: 0s] 
amarok:     BEGIN: void EngineController::initializePhonon() 

(amarok:6043): GLib-GObject-WARNING **: cannot register existing type `GstObject'

(amarok:6043): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(amarok:6043): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(amarok:6043): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(amarok:6043): GLib-GObject-CRITICAL **: g_object_newv: assertion `G_TYPE_IS_OBJECT (object_type)' failed

dale14846 wrote:

>
> Updated to milestone3 via the factory repo all attemps to use the live
> iso 64 bit failed miserably both on a live install and virtual box.
> gnome and kde both I am currently installing gnome in virtual box with
> the net installation disk
>
I loaded 13.1 M2 KDE-Live Build 504 yesterday, it installed and booted
fine. Only problem I saw was LibreOffice failed to start from the Icon
and when i attempted to load a document by clicking on it. Did not do
much else. Will try to load the DVD version to a spare disk today. Will
post results.

Russ

openSUSE 12.3(Linux 3.7.10-1.11-desktop x86_64)|KDE 4.10.4
“release 569”|Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce
8400GS(NVIDIA-Linux-x86_64-319.17)

Was your live disk a 64 or 32 bit?
I installed libre office from upstream and that fixed the libre office problem

http://forums.opensuse.org/english/get-technical-help-here/pre-release-beta/487174-amarok-does-not-work-latest-factory-release.html#post2559359

I tried phonon-vlc-backend it then boots up but I can’t play any sound.

 Originally Posted by dth2 Is there a work round for amarok?amarok does not work in latest factory release

How do you change phonon to use vlc as a backend? When I run phonon it doesn’t start?

Thanks Dale libreoffice is now working fine.

Either in “Configure Desktop”->“Multimedia”->Phonon or in Amarok’s menu: Settings->“Configure Amarok…”->Playback->“Configure Phonon”, see here: Amarok/Manual/ConfiguringAmarok - KDE UserBase Wiki
Edit: Sorry, the second option doesn’t work of course if you can’t start Amarok. Just set the backend in “Configure Desktop” then, or right-click on the KMix symbol in the systray and select “Audio Configuration” or similar.

But you have to install phonon-backend-vlc first, it is available on Packman f.e.

Thanks Wolf.

system settings / multimedia / phonon - wouldn’t start up

but right-clicking kmix and selecting audio setup gave me the option to pick vlc as the backend and amarok is working fine.

dale14846 wrote:

>
> upscope;2564960 Wrote:
>> dale14846 wrote:
>>
>> >
>> > Updated to milestone3 via the factory repo all attemps to use the
>> live
>> > iso 64 bit failed miserably both on a live install and virtual box.
>> > gnome and kde both I am currently installing gnome in virtual box
>> with
>> > the net installation disk
>> >
>> I loaded 13.1 M2 KDE-Live Build 504 yesterday, it installed and
>> booted fine. Only problem I saw was LibreOffice failed to start from
>> the Icon and when i attempted to load a document by clicking on it.
>> Did not do much else. Will try to load the DVD version to a spare
>> disk today. Will post results.
>>
>> Russ
>> –
>> openSUSE 12.3(Linux 3.7.10-1.11-desktop x86_64)|KDE 4.10.4
>> “release 569”|Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce
>> 8400GS(NVIDIA-Linux-x86_64-319.17)
> Was your live disk a 64 or 32 bit?
> I installed libre office from upstream and that fixed the libre office
> problem
>
It was 64-Bit, see signitaure below. I can try the upstream version
later today.

Thanks.

openSUSE 12.3(Linux 3.7.10-1.11-desktop x86_64)|KDE 4.10.4
“release 569”|Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce
8400GS(NVIDIA-Linux-x86_64-319.17)