Has anyone manage to access the 5GHz channels on the Linksys WMP600N card?

Hi everyone,
I installed the Linksys WMP600N dual band card on my OpenSuSE 11.2 box using the SuSE supplied rt2860 driver. With the 2.4GHz channels this works out of the box.
However, I am unable to access the 5GHz channels. iwlist says:

Leatherstocking:/home/bergue # iwlist wlan0 channel
wlan0 13 channels in total; available frequencies :
Channel 01 : 2.412 GHz
Channel 02 : 2.417 GHz
Channel 03 : 2.422 GHz
Channel 04 : 2.427 GHz
Channel 05 : 2.432 GHz
Channel 06 : 2.437 GHz
Channel 07 : 2.442 GHz
Channel 08 : 2.447 GHz
Channel 09 : 2.452 GHz
Channel 10 : 2.457 GHz
Channel 11 : 2.462 GHz
Channel 12 : 2.467 GHz
Channel 13 : 2.472 GHz
Current Frequency:2.432 GHz (Channel 5)

Setting a 5GH channle with iwconfig doesn’t work. iwpriv doesn’t work either:
iwpriv wlan0 set WirelessMode=6
wlan0 no private ioctls.

Chaning any settings in /etc/Wireless/RT2860STA/RT2860STA.dat doesn’t seem to have any effect at all.

The driver supplied by SuSE is of version 1.8. On the Ralink website a newer driver of version 2.3 is available; but so far I didn’t manage to install it because I am not a C expert.
However, the 5GHz channels should be accessible by the older 1.8 version driver. Somehow I suspect that in the SuSE distribution some dynamic parameters are hardcoded and therefore the whole thing fails.

I’d be grateful for any hints!

Please look at the dmesg output, find, and post the table that looks like


[49330.821758] cfg80211: Calling CRDA to update world regulatory domain
[49330.842347] cfg80211: World regulatory domain updated:
[49330.842361]     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[49330.842370]     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[49330.842378]     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[49330.842387]     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[49330.842394]     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[49330.842402]     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

It will tell what channels the regulatory code is allowing. I suspect that you have the
wrong country code being supplied to mac80211. In addition, please state your country.

Hi,
thanks for your reply. There is no cfg80211 call. The closest I can find in dmesg output is given below. My country is Germany.

However, meanwhile I did some more research on the question. I managed to compile the ralink code and found that I can change the accessible channels with “iwpriv ra0 set WirelessMode=8”. I couldn’t manage that with the SuSE supplied driver. One of the problems seems to be that the ralink driver insists on the driver names ra0, ra1 etc, whereas SuSE insists on wlan0, wlan1 etc.
I have no idea where I would have to insert the iwpriv command in the SuSE startup scripts, of the configuration option. (I wouldn’t want to experiment with the ralink driver either, because I would be afraid to mess up my SuSE firewall).

9.011251] rt2860sta: module is from the staging directory, the quality is unknown, you have been warned.
9.021931] rt2860sta: module is from the staging directory, the quality is unknown, you have been warned.
9.023533] ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 16
9.023546]   alloc irq_desc for 16 on node 0
9.023550]   alloc kstat_irqs on node 0
9.023569] rt2860 0000:02:07.0: PCI INT A -> Link[LNKB] -> GSI 16 (level, low) -> IRQ 16
9.024255] === pAd = ffffc90001e32000, size = 525936 ===
9.024260] <-- RTMPAllocAdapterBlock, Status=0
9.024263] pAd->CSRBaseAddress =0xffffc90001e20000, csr_addr=0xffffc90001e20000!
9.034069] rt2860 0000:02:09.0: PCI INT A -> Link[LNKD] -> GSI 17 (level, low) -> IRQ 17
9.034753] === pAd = ffffc90001ed2000, size = 525936 ===
9.034758] <-- RTMPAllocAdapterBlock, Status=0
9.034762] pAd->CSRBaseAddress =0xffffc90001ec0000, csr_addr=0xffffc90001ec0000!

37.422160] RX DESC ffff8800bc573000 size = 2048
37.423594] ← RTMPAllocTxRxRingMemory, Status=0
37.426275] 1. Phy Mode = 0
37.426281] 2. Phy Mode = 0
37.440692] RTMPSetPhyMode: channel is out of range, use first channel=1
37.444488] 3. Phy Mode = 0
37.447230] MCS Set = 00 00 00 00 00
37.448941] <==== rt28xx_init, Status=0
37.449146] 0x1300 = 00073200
41.158205] ===>rt_ioctl_giwscan. 4(4) BSS returned, data->length = 794
41.158616] ==>rt_ioctl_siwfreq::SIOCSIWFREQ[cmd=0x8b04] (Channel=1)
43.563117] ===>rt_ioctl_giwscan. 5(5) BSS returned, data->length = 1017
43.563543] ==>rt_ioctl_siwfreq::SIOCSIWFREQ[cmd=0x8b04] (Channel=1)
45.526026] wlan0: no IPv6 routers present
48.446026] wlan1: no IPv6 routers present

There is some driver problem. Couldn’t get the 5GHz channel to work using the SuSE supplied driver. Some partial success with the driver from the ralink website.
However, since the update to OpenSuSE 11.3 the cards stopped working altogether (nl80211 generic netlink not found), and I got tired of it and replaced them.