Has anyone installed rc1 dvd as a fresh install?

Just wondering if it installs OK?

I used the Gnome live CD
I’ll not be downloading a DVD again until release

On Fri, 21 Oct 2011 18:36:03 +0000, dth2 wrote:

> Just wondering if it installs OK?

See “RC1 is a wreck!” for various ideas on that.

I think the short answer may be that it depends on whether you make any
changes to the defaults. If you have to alter the partitioning then you
could well be unlucky. Also, there were errors on the x64 DVD - some
items have checksum errors so these have to be skipped.

Graham Davis, Bracknell, Berks.
openSUSE 11.4 (64-bit); KDE 4.7.2; AMD Phenom II X2 550 Processor;
Video: nVidia GeForce 210 (using nVidia driver);
Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

My experience wasn’t that good but after 3 attempts I realised that it was down to a problem with my dvd drive!

Replaced this and it installed OK although it stalled after the initial install part with a frozen graphic. I had to switch off and back on - and the install completed without any problems. It may well be due to me selecting the momodeset option - as I have a nvidia card.

After 2 attempts with the broken gui. I switched to text mode and it was successful.

Yes, to a real partition, too! Used the x64 DVD. Unlike others, I modified partition setup (completely custom) and the bootloader location, etc. These changes were apparently OK, but when I attempted to change the software selected (to add mc and nano) I got a red error box immediately upon hitting the “Software” category link, saying “… couldn’t load plug-in qt_pkg …”, and it hung/stalled after closing the box. Hard reset/power off is only solution at that point. No terminal/console available either to look at the log file.

When I did all the other changes, but left the Software Selection (for stock KDE) unchanged, installation went through to it’s normal conclusion. I have written a Bugzilla entry for this.

That said, my RTL8111E on-board LAN chip was recognized but (I guess) not configured properly since Firefox pooped out. Simple matter of going ino Yast > Network Devices and configuring a static connection, etc., for my wired ethernet cable, and everything worked once that change was made.

Minor nits: Although “Automatic Configuration” was selected during installation, neither my Lexmark E250dn laser printer, nor my Epson 3490 Perfection scanner was configured or even recognized. Standard practice, and I’m getting very good at configuring those two and putting in the right/elusive drivers.

Postscript: I see the above poster had to revert to text mode install. I had to do that on 12.1 Beta, but this time it was graphical all the way. YMMV, obviously.

I installed (fresh install) RC1 this morning on my “mediabox” which I currently use as my “sand-box”.

I did get the msg “couldn’t load plug-in qt_pkg”…when trying to add additional SW.

So I tried again without adding additional sw … worked perfectly !

Then I added the SW (via yast) I wanted including the default kernel …worked !!!

Sofar so good…no further problems.

I let you know when I experience issues…early days to tell !



That QT UI bug was in the Factory updates during beta1
It was supposed to fixed for RC1

Yes, it installed ok. But that was after several attempts where it didn’t install ok.

I had to completely skip the software selection part to have it work. If you have the option, install from the live CD.

I’ve had 2 successful DVD installs , but not without some hiccups … One was a 32-bit LXDE install (using 32-bit DVD) and one was a 64-ibt KDE install (using 64-bit DVD)

In both cases it is essential one does NOT click on the link to modify the software, as that crashes the YaST installer. After the install is complete one can then add any extra software (or remove any software) that one may wish to do.

The 64-bit install had an additional failure, where after the software install was complete, and grub re-written, the PC screen was corrupted and the installer/desktop unresponsive … A hardware reboot was needed, but fortunately after the reboot, choosing 12.1 RC1 from the grub menu allowed the install to continue.

I’m currently testing 12.1 RC1 . I want to check things like vnc, ssh, etc …

On Fri, 21 Oct 2011 19:38:14 +0000, Cloddy wrote:

> On Fri, 21 Oct 2011 18:36:03 +0000, dth2 wrote:
>> Just wondering if it installs OK?
> See “RC1 is a wreck!” for various ideas on that.
> I think the short answer may be that it depends on whether you make any
> changes to the defaults. If you have to alter the partitioning then you
> could well be unlucky. Also, there were errors on the x64 DVD - some
> items have checksum errors so these have to be skipped.

Problems seem to have been due to dodgy Metalink download - or several as
same problems occurred in beta. A new download from a mirror produced
something I could install successfully, albeit with a hiccup on the mid-
install reboot.

Graham Davis, Bracknell, Berks.
openSUSE 12.1 RC1 (64-bit); KDE 4.7.2; AMD Phenom II X2 550 Processor;
Video: nVidia GeForce 210 (using nouveau driver);
Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

I used the x64 DVD to do a fresh install on a test laptop this morning. Like
many, I ran into the same error when I selected the Software link [couldn’t
load plug-in qt_pkg]. Looks like this bug has since been fixed, though that
doesn’t help with the current RC1 ISOs. None the less, by allowing the
installation to complete without modifying the software selection I was
fine – at least, the installation finished but not without other problems.

Now, the laptop will not boot (no graphics) unless I use nomodeset. I have
no idea why. This is a first for me with this laptop. I have never had to use
nomodeset before with this machine.

Wireless does not work, at all. I cannot get the system to recognize the
wireless NIC at all, though it has worked right-out-of-the-box for every
other version of openSUSE, Slackware and Arch Linux that I have tried.
03:00:0 Network controller: Intel Corporation Ultimate N WiFi Link 5300



What graphic hardware do you have?

I have a Dell Studio 1537 laptop with an Intel WiFi Link 5300 and it worked quite easily with the 64-bit openSUSE-12.1 RC1 liveCD. From ’ lspci -nnk ’ :

04:00.0 Network controller [0280]: Intel Corporation Ultimate N WiFi Link 5300 [8086:4235]
	Subsystem: Intel Corporation Device [8086:1121]
	Kernel driver in use: iwlagn

I reported on it functioning here in post#7 Opensuse 12.1 - post#7 w/Intel-WiFi-Link-5300

For my Intel WiFi 5300, I followed the same method that I reported in post #3 here (with an Intel 6205) : Opensuse 12.1 - post#3 - method to connect wireless

… My experience is kwallet is a bit tricky and if one tries to ignore it by not setting it up by putting in a password the first time it shows up, one can run into trouble setting up the wireless.

On 10/21/2011 11:36 AM, dth2 wrote:
> Just wondering if it installs OK?
I downloaded x64 DVD overnight (torrent). As I read about not touching
“Software Selection” from another thread, I did not.

  • a fresh install on a removable disk, overwriting Mageia.

  • partitioning: a bit messy, since I had the removable disk turned on
    and the harddisk with openSUSE 11.4, updated openSUSE 12.1, two Mepis
    installations. I shut down, pulled out the wire to this disk, began all
    over, letting the installer configure the removable disk (making sure
    that ‘/home’ partition got formatted, too).

  • Without having encountered any issue, I logged into KDE. Installed an
    icon for ‘UXTerm’ (xterm unicode): as before, the default path is
    ‘~/Documents’ - fixed to ‘/home/taki’, through ‘property’; strangely,
    ‘Konsole’ does not have this issue.

  • ‘Personal Settings’: Changing settings causes a blank window/frame to
    briefly flash full-screen. Nothing untoward happens, I think.

  • Firefox and zypper (to set up repos) tell me that my machine is not
    connected to the Internet. I have encountered this - immediately after
    switching from Mepis or Mageia (and 12.1 beta). Before the latest stable
    Mepis, there was never such a problem. Something has changed with Linux?
    Anyway, I shutdown completely and go out for a few hours.

  • Boot up and set up repos: oss factory, non-oss factory, Packman
    (Mozilla repo from ‘Community’ repos fails to load), mozilla, M17N, X11:
    windowmanagers. switch repos, add a few packages (ibus, anthy,
    Thunderbird, Leafpad, vlc, MPlayer, Opera, Fluxbox, etc.)

  • copy a few configs from a thumb drive: .vimrc, gvimrc, .vim/, .Xdefaults

  • “# shutdown -r now” from within KDE, since KDE seems to have the
    shutdown problem.

  • Reboot into KDE, again. I have not tested window managers or
    ‘ibus-anthy’ Japanese IME. Have not set up the Brother HL-2040 printer.

  • Oh, yes, my motherboad is a low-spec K8Upgrade-VW800, with the
    problematic SiS (unichrome?) chipset. All in all, the installation
    itself was smooth (I skipped “Software Selection” fiddling). I’ll see
    how parts fit.

I confess the explanation for the bug fix is not intuitively obvious to me, so I hope they have their assessment correct.

The openSUSE packagers claim Bug 725874 is a duplicate of bug 725722. The similarity is not obvious. bug 725722 notes a libzypp changed binary is incompatible and all the required parts were not rebuilt (so that the package manager will crash when opening it). Yet they don’t say in THAT bug report what the specific package manager error is.

Bug 725874 reports a “YaST2 - UI Syntax Error - Couldn’t load plug-in qt_pkg - Check the log file!” error:
[click on image above for larger view]

How is loading of plug-in qt_pkg is related to a libzypp binary ? … I guess it is part of the old proverb For the want of a nail.

From the x64 DVD, installation on a laptop (Acer Extensa 5230) went right. (This is a “productive system” for web, text processing etc. when in hurry, and also for testing new OpenSuses… The version there before 12.1RC1 was 11.4 with heavy updates from the Tumbleweed repository, nearly a 12.1 version.) Because there’s a home partition on the disk, I could continue to work on this machine as usually, but…

  • wlan did not work, no connections; but the wlan chip (RT 2860) was recognized. Solution was simply: the package “kernel-firmware” had to be installed. It’s hard for a new or inexperienced user to find this solution. The installer should do this.

  • I tested MIDI, because I use this file format sometimes. KMid did not work; while starting, it said something of wrong permissions. I found, the file /dev/snd/seq was not accessible for users. This happened always after booting; setting permissons manually did only help for the moment. I found in the Web, files in /dev/snd/ get their permissions from an acl (access control list). These can be overwritten with the facl command. I put this in /etc/init.d/boot.local, and it worked.

  • Bluetooth seemed to work, the adapter (Hama) was found and the connection with a nokia phone was successful, but while accessing the phone with dolphin, kded crashed with a segfault. No file transfer was possible.

No other bugs or strange behaviour… okay. The bluetooth problem may be a kde bug. The old opensuse 11.4 with KDE 4.7.2 from the tumbleweed repository didn’t have it.

Here’s my fresh install experience,

Did my homework right, dl DVD 64bit with metalink, md5 checked it, burned, check installation media all good.
Started installation and checked the UI Syntax Error bug, its nice, adds a little red color to the green distro :slight_smile:
From the second attempt it was just next, next, next for me, KDE of course…
Did not encounter graphics problems like mentioned in this post but there was a little flickering from time to time. Internet wasnt working so a trip to yast enabled network connection so Im able to write this post. Im not dual booting and afraid to try it out on a media machine yet with win7. Have to read about grub2…
Got my usual selection of non-OSS done, 64bit flash player works good, skype is running with some 32bit libs that had to be added
If Im not back complaining then the nvidia driver the hard way was a success

Overall from my non so technical point of view its all good.

I note on the openSUSE KDE mailing list there is an post about bluetooth being broken in 12.1 : Bluetooth infrastructure broken in 12.1, possible fix from upstream.

Subject: Bluetooth infrastructure broken in 12.1, possible fix from upstream.

All is explained in Novell Bugzilla Bug 725962: https://bugzilla.novell.com/show_bug.cgi?id=725962 but I will make a summary:

Bluetooth infrastructure is broken for many people in OpenSUSE 12.1 RC1, some people are having kded or plasma crashes, and other haven’t crashes, but Bluetooth is neither working properly. I think a working Bluetooth is important nowadays, due to the big amount of mobile devices and wireless bluetooth-based devices like earphones… The problems seems to be curiously in networkmanager applet according to upstream, it causes a crash due to a pointer which is not tested before using it (as explained in the commit).

This upstream commit could fix this issue then: http://commits.kde.org/networkmanagement/ff842ef744465d704ff609dbdbccff72c05e0535

Please watch if someone could backport this commit to OpenSUSE 12.1 in order to have a release with a working Bluetooth.

I’m not a bluetooth user myself, so I can’t add any more to this.

I just cant blacklist nouveau and nvidia driver wont install.
I now have 50-blacklist.conf, nvidia-installer-disable-nouveau.conf, 50-nvidia-installer-disable-nouveau.conf, nvidia.conf all with “blacklist nouveau” line in them it still runs. Even removed xorg-x11-driver-video-nouveau and its still listed in lsmod. WTF?

Just tried out my Integrated System Solution Corp KY-BT100 Bluetooth Adapter with an Android phone and pin, paring, sending and receiving worked fine.
That crappy bluetooth adapter never woked on windoze without its drivers and there was a problem of falling back to trial version for some stupid reason, on linux its great