Has anyone installed openSUSE 11.2 from hard disk?

Has anyone installed openSUSE 11.2 from hard disk?

If you have installed it from hard disk,please post the method.

Assuming you mean to install from hard drive directly from the iso image, here is a method:

Installing openSUSE from Hard Drive

A separate partition is required that will not be formatted during installation, and is large enough to hold the DVD image. Download the ISO image (or copy the installation DVD) to that partition.

Extracting the system files
The kernel (linux) and the installation system loader (initrd) must be copied from /boot/…/loader on the installation media, to the hard disk (e.g. place in directory /boot, or the /boot partition).
From the downloaded iso image, extract linux and initrd:

# mkdir -vp /mnt/iso
# mount -v -t iso9660 -o loop openSUSE-11.1-DVD-i586.iso /mnt/iso
# pushd /mnt/iso/boot/i386/loader
# cp -v linux /boot/inst-linux
# cp -v initrd /boot/inst-initrd
# popd
# umount -v /mnt/iso

That creates a mount point, mounts the ISO image using the loop device, extracts kernel and initrd, and unmounts the ISO image.

Starting the installation system

1. Prepare the grub boot loader to begin the installation, by using method (a) or (b).
Replace (hd0,0) as appropriate.

(a) Add the following lines to /boot/grub/menu.lst

title Install SUSE
root (hd0,0)
kernel /boot/inst-linux
initrd /boot/inst-initrd

Reboot, selecting “Install SUSE” to start the installation.

(b) Boot to the normal grub menu.
At the Grub Menu (graphic), press “ESC”; then at the text menu, select an entry, and use “e” to edit each line for root, kernel, and initrd, as above.

Press “b” to boot

2. Once the system starts, follow the prompts:
At the first message “Make sure that CD number 1 …”, press “Back”.
Select the Language; the Keyboard map; Start installation (twice); and Hard Drive (or Network).
If Hard Drive was selected, specify the partition and directory. For the ISO image file, its directory and complete filename is required. For example (substitute your own):

  • for the partition: /sda9
  • for the directory: /path/openSUSE-11.2-DVD-i586.iso

(Alternatively, if Network was selected, choose the server and directory for the distribution repo.)

Finally, when the openSUSE Installer appears, follow the normal installation sequence.

Please note, I haven’t tried this method with openSUSE liveCD’s.

Do query anything that isn’t clear in the above, and let us know how you get on with it (or not).

Thanks very much for your reply.
But actually i have the openSUSE-kde.iso cd not dvd.

Has anyone installed openSUSE from hard disk using openSUSE-kde.iso cd?

You could try that same method on your liveCD iso. I have 11.2 64bit KDE4 openSUSE liveCD and the two system files (linux and initrd) needed for the step “Extracting the system files”, are to found in /boot/x86_64/loader. For 32bit cd iso, it will be in /boot/ … /loader, where … will be i386 or similar.

You will need to substitute your exact iso name in the mount command (e.g. mount -v -t iso9660 -o loop openSUSE-11.2-KDE4-LiveCD-i686.iso /mnt/iso). Commands must be entered as the superuser (root). You will need to substitute the exact path for /boot/ … /loader (from the iso image) in the pushd command.

The procedure is easier than it looks, but you must follow the instructions precisely.

It’s not getting the cd.iso.

After booting:

Waiting for USB device...
Waiting for cd-dvd device...
Waiting for live media device...
Will reboot after 120 seconds.

I doubt a live CD would work - it might not have the text based initial installer application. I’m sure the DVD version would work - I install it all the time using this method.

I have also spent quite some time on this since I posted, trying to get it to work for a downloaded liveCD .iso file, but ended in failure. :frowning: I successfully used the loop device mount to access the iso’s LIVECD contents, and copied the contents to a separate partition for inspection and further experiment. I could access the file system, but unfortunately the iso image contains another image which I assume is only usable with some KIWI tool. KIWI is used by openSUSE to produce the LiveCD image. Anyway I couldn’t mount that embedded image by using the loop device, and I am not yet familiar with KIWI.

I also tried a similar technique on a PCLinuxOS 2010 LiveCD, but that similarly failed to install from its iso image file. The problem I saw in both cases, was that the loaded linux and initrd that provides the installer system only wanted the CD device and could not find one.

I know that solution I posted has worked well for 11.2 DVD. I have also successfully used it on one of the earlier 11.3 milestones where I had to download the DVD iso, to have a clean install and test of LXDE (no liveCD available). :slight_smile:

Forgive my incomprehension but what is the motivation for installing from a hard disk? I can only think it is either:

  1. Your system does not have a CD/DVD drive or it is broken
  2. Your USB ports do not work or
  3. Your USB ports do work but you cannot afford a USB stick (you can DD the cd iso image to a USB stick, you realise?)

However, maybe you only have a spare HDD from which to do the installation but you have the CD iso. So can you install from that?

From inspection of the first 512 bytes of the iso image, Suse 11.2 CD is a sort of hard disk image. It has a quasi standard MBR with a partition table although the partitioning is non standard. There is only one partition and that begins on sector 0 so includes the MBR. However, it appears to be bootable as a normal hard disk. So testing under qemu (version 9.2),

qemu -m 512 <name of suse 11.2 cd>.iso

will boot, treating the image as a hard disk, and so will

qemu -m 512 -cdrom <name of suse 11.2 cd>.iso -boot d

treating the image as a CD.

Hence, I suspect all you have to do is DD the CD iso to a spare IDE HDD and boot from that. Then install to your other final HDD. You can then remove the spare drive later if you wish of course.

Sorry if the above is irrelevant but, as I said, I could not quite understand the logic of the original question.



The OP’s question was clear, IMO and as far as i can see, it was looking for tried and tested solutions. Both Qemu and VirtualBox are capable of treating the iso image as a CD. Unless I have misunderstood your proposal, why would it then work without qemu present and what happens when the installer system (linux + initrd) looks for a cd to get the embedded openSUSE system image?

The KIWI produced liveCD installer is very different from the DVD installer that offers a choice of image sources (CD, HD, network).

AFAIK, the BIOS of older PC’s (around 4 years old?) may be incapable of booting from a USB stick. You will find forums littered with problems and doubts about burning iso’s to CD/DVD, and reburning at slower speeds etc., involving CD/DVD installs. Although personally speaking, I never had CD burning problems. However, as far as motivation goes, do we really need to produce all these surplus plastic coasters (but don’t lets go there here) – some just prefer to avoid creating that rubbish.

Both Qemu and VirtualBox are capable of treating the iso image as a CD. Unless I have misunderstood your proposal, why would it then work without qemu present and what happens when the installer system (linux + initrd) looks for a cd to get the embedded openSUSE system image?

Yes, I know that both qemu and virtualbox can treat the iso as a CD. However, they cannot treat the iso as an HDD, unless the iso image is set up to allow you to do that. What I was explaining was that you can use qemu to test the theory that DDing the Suse 11.2 iso image to a spare HDD would allow you to boot the HDD directly. Hence, you can install Suse without recourse to a CD drive or a USB stick.

As you say, some older boxes cannot boot from a USB stick and some that do have difficulty during and after installation because the kernel cannot quickly discover the USB hardware for itself (after booting from grub), but that is a subject that is best discussed elsewhere).

The format of the installation CD for Suse 11.2 is different from that for 11.1. You could not DD the 11.1 image to a USB stick or to an HDD.

If the OP feels that my proposal is of interest I don’t mind testing it out on a spare drive I have here but it would be easy for him/her to do that directly.

Is this an adequate response to your criticism or do you wish for me to go into more detail?

Hope that helps.

Also obvious to me that you knew that, but it was less obvious as to its relevance within your proposal.

Yes, treatment of the iso as an HD is the key to your proposal as you say, with qemu just to check the DD theory for 11.2 iso image. I’m sure others (with spare drive) could be interested in this solution, including myself (with an old spare 4GB drive) which is why I asked the question. There is probably a bit more interest in its potential for booting from 11.3 liveCD iso right now.

I will give it a try and come back with any comments.

I shouldn’t waste your time. I have tried on real hardware over here and it simply doesn’t work.

It fails with the message “Operating system load error.”

It rather begs the question why it works OK on simulated hardware but not on physical hardware.

I thought at first it might be something to do with disk geometry. If you run PartedMagic CD under qemu with the Suse 11.2 CD iso as a hard disk image then it considers the later to have 64 heads, 32 sectors per track and 512 bytes per sector. However, the Fujitsu 4.3 GB HDD I DD ed the image to has 15 heads, 63 sectors per track, 512 bytes per sector and 8940 cylinders. After you DD and then do an fdisk -l on the HDD, it turns out Parted Magic now thinks it also has 64 heads, 32 sectors per track, 512 bytes per sector and 4125 cylinders etc. Hence, the HDD now has a fractional number of cylinders for its maximum capacity, although this is now restricted to the next lowest number of integer cylinders.

Thinking it doesn’t like the fact that the HDD is bigger than the CD image, I added 97 cylinders (64 H, 32 S, 512 B) of zero padding to the back end of the CD image and then tried to boot that under qemu. No problem.

Thinking it might be the fractional number of cylinders for the total size of the disk drive, I added 14, 825,472 bytes of zero padding to the back end of the CD image, which made the overall size applicable to a hard disk image with 15 H, 63 S, 512 B. Attempted to boot the modified image under qemu. No problem.

So I don’t think it is anything to do with disk geometry. What the problem is I have no idea.

Sorry. :frowning:

I was about to congratulate you on a promising solution when I saw your post. Lucky I didn’t see it before I made the trial. I managed to DD the 11.3 RC1 iso for KDE LiveCD (as already had it saved) onto the spare 4GB IDE pata drive (hd1 or sdb), changed my BIOS to give that spare drive boot priority over the main sata drive, rebooted (noisier old disk identified the spare HD in use) to grub menu, and selected to load the LiveCD as a test.

I am posting this from that LiveCD’s KDE desktop (albeit 11.3). I would expect the Install to work from here including targetting my sata HD, but I don’t need another 11.3 as I have an RC2 partition already. I therefore regard this as a successful solution, but for the OP it needs testing with an 11.2 iso file.

This was my DD statement:

dd if=/path ... to/openSUSE-11.3 ... x86_64.iso of=/dev/sdb bs=4M

That worked giving a partition at /sdb1 containing the image which was obviously less than 1GB of the HD’s 4GB.

Well done plodder, another successful solution for my h/w anyway. Let me know if you need any more detail on my HD config/geometry. :slight_smile:

Well I’ll be ‘you know what’ (no naughty words allowed on this forum!).

The only mistake I can see is that I used ‘bs=512’ whereas you used ‘bs=4M’ (actually did you mean 4k?). Could that be it? If so why?

I definitely used 4M. I seem to remember reading that “bs” defaults to 512, but the copy takes a shorter time if you can increase that significantly. So I don’t see why your bs=512 would be the problem, since it’s only a performance thing. Unless it needs to be 4096 or higher - guessing though? However I did use 4M because I saw it used in this recent Howto for copying dvd/net iso (11.3 and 11.2) to a flash drive - thanks to user dale14846.

I expect you set “of” to the start of the spare hd e.g. of=/sdb, and not to the partition e.g. /sdb1. I assumed that could cause a problem, so I used of=/sdb.

In case of geometry, here is the output of fdisk -l for my spare HD:

Disk /dev/sdb: 4335 MB, 4335206400 bytes
64 heads, 32 sectors/track, 4134 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Disk identifier: 0x2d4e2dc9

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1         693      709632   83  Linux

Disk /dev/sdb1: 726 MB, 726663168 bytes
64 heads, 32 sectors/track, 693 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Disk identifier: 0x2d4e2dc9

     Device Boot      Start         End      Blocks   Id  System
/dev/sdb1p1   *           1         693      709632   83  Linux

Do you notice anything interesting or significant compared to yours? :\

Wasn’t quick enough to achieve an edit to my post, so here is further confirmation that it will install using this solution.

I did another test before switching back to my normal HD. This time I selected to install from the 11.3 liveCD menu. I didn’t complete the install, but it worked fine including selection of my main HD for the partitioning proposal, so I know it will work for a full installation process.

I have just tested plodder’s “spare disk” proposal with an 11.2 KDE LiveCD image, and that also worked. I didn’t have my originally downloaded 11.2 iso file, but I had originally burned it to cd for installing my working 11.2 system. To save time, I just copied the whole cd’s image to the spare drive (hd1 or sdb) using DD and hence overwriting the previous 11.3 image. I used this DD statement:

dd if=/sr0 of=/dev/sdb bs=4M

That worked giving a partition at /sdb1 containing the 11.2 liveCD image. As before, after changing the disk priority to favour the spare drive, I rebooted to it and selected the KDE liveCD system from which I am posting this result.

Here is the report of fdisk -l on the 4GB drive now at /sda on the liveCD system:

Disk /dev/sda: 4335 MB, 4335206400 bytes
64 heads, 32 sectors/track, 4134 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Disk identifier: 0x8c71ad6e

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1         689      705536   83  Linux

Disk /dev/sda1: 722 MB, 722468864 bytes
64 heads, 32 sectors/track, 689 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Disk identifier: 0x8c71ad6e

     Device Boot      Start         End      Blocks   Id  System
/dev/sda1p1   *           1         689      705536   83  Linux

For me these tests verify that using DD to copy the liveCD iso file for 11.2 or 11,3 onto a spare HD does enable installation of openSUSE without a CD or a much longer DVD download. :slight_smile:

Ironically the person who cannot get ‘plodder’s method’ to work is plodder himself!

I do exactly the same as consused and get the same target disk layout but to no avail. The only difference is that, by changing from bs=512 to bs=4M in the DD statement, I no longer get the “Operating system load error.” message. However, the BIOS then appears to take over and requests a valid boot device.

I will plod on with this later and experiment when I have some more time. At the moment I am trying to boot a 64bit system with a 32bit CD image. I cannot see why that would be a problem since I have another 64bit system up and running 32bit 11.2.


Ah but if I then transfer the drive to a 32bit system it works!!!

Plodder exonerated!!!


Relief all round. It would be useful to know if your 32bit system still works if you use bs=512 for the DD step.

I was about to reply to your previous post to say that all my CD images were 64bit and obviously my system is 64bit. I have used 32bit livecd on it before, but never via a DD copy to an old HD.