Has anyone gotten Discord to work?

Hi. My son relies on Discord to chat with his friends while playing games. The previous version, 0.0.1, worked fine. However the recently released version (0.0.2) simply opens goes through some initial introductory screens and then settles on an empty grey box. I initially figured this was the result of some leftover files from the prior install that I couldn’t find, but after installing it on my own laptop, I have the same result. Both his and my computers are relatively vanilla 42.3 installs using Plasma.

The installation process is pretty straightforward as well. I’ve been downloading the tar.gz file from the Discord web site, extracting the directory, and placing ~/bin. As I said, this worked for the previous version. If anyone has any ideas for getting version 0.0.2 to work, it would be most appreciated.

Tried with this https://software.opensuse.org/package/discord

Hi. Thanks for that. I forgot to mention that I’ve tried installing the package from Miuku, and it fails to install with a “nothing provides libc++1” message. The package from SocMinarch wasn’t there last night, so I tried that. It installs, but doesn’t run:

john@linux-5vqd:~> discord
[22350:0814/175834.619610:FATAL:content_main_runner.cc(680)] Check failed: base::i18n::InitializeICU(). 
#0 0x000001e004ce <unknown>
#1 0x000001de5d9b <unknown>
#2 0x000000789562 <unknown>
#3 0x000000789d4a <unknown>
#4 0x000003b836f3 main
#5 0x7f7bf55806e5 __libc_start_main
#6 0x00000059a779 <unknown>

/usr/bin/discord: line 3: 22350 Aborted                 (core dumped) LD_LIBRARY_PATH=/usr/lib64/discord/ /usr/share/discord/discord

Trying to delete any configuration files in the hidden home file?
Or you can try version 01 of the last repository

In Thumbleweed libc ++ 1 is provided by llvm4

zypper if --requires libc++1
Il repository 'packman' non è aggiornato. È possibile eseguire 'zypper refresh' da root per aggiornarlo.
Caricamento dati del repository in corso...
Lettura dei pacchetti installati in corso...

Informazioni per pacchetto libc++1:
Repository            : openSUSE-20170724-0                
Nome                  : libc++1                            
Versione              : 4.0.1-2.3                          
Arch.                 : x86_64                             
Fornitore             : openSUSE                           
Dimensione installata : 749,3 KiB                          
installato            : No                                 
Stato                 : non installato                     
Pacchetto sorgente    : llvm4-4.0.1-2.3.src                
Sommario              : C++ standard library implementation
Descrizione           :                                    
    This package contains libc++, a new implementation of the C++
    standard library, targeting C++11.
Richiede              : [17]                               
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(PayloadIsLzma) <= 4.4.6-1
    libc++abi1 = 4.0.1

So I imagine that even in leap42.3 is the same https://software.opensuse.org/package/llvm4

Hi - repo owner here :stuck_out_tongue:

The discord package in my repo for non-TW systems was there by accident (and OBS hasn’t cleaned it despite me removing the 42.x) - it indeed does require libc++1 which is available for TW but not for 42.3 in the base repositories.

I was going to compile llvm4 in my home repo to provide the lib for 42.2/42.3 but OBS stuck on compiling it for some reason. If you want, you can grab it temporarily by adding:


I’ll see if OBS wants to co-operate with me and compile llvm4 in my own home repo - this is a requirement by Discord developers who dynamically linked it vs libc++1 by the way.

Thanks, Miuku. I really appreciate the help. I pulled libc++1 from the repository above, but it requires libc++abi1. Yast throws an error on that rpm:

 Error: INVALID:libc++abi1-4.0.1-34.3.x86_64 (Local RPMs): Signature verification failed [4-Signatures public key is not available]
     Header V3 RSA/SHA256 Signature, key ID 498d5a23: NOKEY
     Header SHA1 digest: OK (f940632886f821ccaaa6a885c0dd6b02af2bc76f)
     V3 RSA/SHA256 Signature, key ID 498d5a23: NOKEY
     MD5 digest: OK (a1ef86d9fedd250adf6ff6db3fd7fdd5)

Now granted, I didn’t add the repository (since it was temporary), but just pulled the rpms and added them to my local repository, but it seems a problem remains.

You need to add the repository for it to download the signing key for the RPMs.

Don’t worry - it won’t install anything else from there and once you’re done installing you can remove the repository.

OK, then. I can report some level of success. :slight_smile: Discord is installed and takes me to the login screen, which is a very good outcome. Alas, I do not have an account, so I’ll need to install on my son’s computer this evening and ask him to test it. I’ll report back, but I see no likely issues at this point.

LLVM4 is compiling in my home repo and this may take a while (like until tomorrow) - after that it should be possible to get new versions from my home repo without adding anything extra.

Just to close off this thread, I can confirm that I was able to install Discord from Miuku’s repository last night. I was able to just use the one-click install, and it pulled everything from that repository, with nothing else required. My son has reported this morning that it is functioning as expected. I’d like to thank everyone for their support, and in particular I’d like to thank Miuku for the rather extraordinary effort of building the libraries needed to get it to work. :slight_smile:

You could also try using the Flatpak version.