Has Anyone Got Multiple Large Monitors to Work with LEAP & Plasma?

I’ve been trying to get two monitors to work stably with the Plasma DE without success. Less graphics-intensive DEs work fine. I’ve currently got Xfce going. However, I’d like to get Plasma or one of the other graphics-intensive DEs working, preferably Plasma though.

Here’s what I have:

1 x Dell 30" @ 2560 x 1600
1 x Asus 32" @ 3840 x 2160
2 x Asus Nvidia 770 GTXs

Per this thread, I’ve gotten lots of help from wolfi323 but haven’t been able to get Plasma running. When I have one monitor running or I don’t have Xinerama turned on, everything runs fine. As soon as I get the second monitor setup and Xinerama running, I get blank screens with a mouse pointer and nothing else. Thankfully, I’m at least able to log out and back into an Xfce session. This is with the correct Nvidia drivers running the monitors.

I’ve tried updating to the latest-greatest version of Plasma (5.5) and also tried to get Qt 5.5.1 installed. I got Plasma 5.5 installed but that didn’t help anything. Trying to get Qt 5.5.1 installed was a challenge, as there were dozens of conflicts to deal with and resolving one seemed to trigger other conflicts. I supposed Qt 5.5.1 will have to wait until it’s available through one of the standard repositories.

The first time I had openSUSE and Plasma running, it worked–sorta. I had the native drivers going but it was buggy-as-heck. I couldn’t get anything done because the system would constantly crash without warning. Everything would freeze solid, no mouse movement, no keyboard, nothing. I had to reset the computer to get out.

As an aside, has anyone gotten any Linux distro to work with a graphics-intensive DE and multiple monitors? I ask because previously I tried Ubuntu (Unity by default, but tried Plasma and a couple of others as well) and Mint. Both of those were unstable for me as well.

How do you configure your monitors?
Is it configured thru systemsettings5 or with the nvidia-setings?
I have an nvidia graphic card but not as powerful as yours
and it works on 3-monitors, though my monitors are only 23", 22" and 18"
but maybe the config should be the same as in bigger monitors.

I’ve been using the Nvidia settings to control the monitors.

Glad to hear it! It gives me hope!

Where did you got your nvidia driver?
Is it from the .run installer or from an rpm package?
Is it the latest driver that you are using?

Right now I am in tumbleweed plasma5
This morning I did a zyyper dup from xfce
When I login to plasma 5 it crashed after the zypper dup
When I reinstalled the .run nvidia driver I was able to get to plasma 5 again.
I am telling you this so you might want to reinstall the nvidia driver you’ve got there.

You can try this also if you can use xfce, in xfce if you open the settings-manager of xfce
you will see the kde systemsettings and you can open it by clicking it twice. Just be sure that
the systemsettings for kde is the systemsettings5 not the one for kde4.

When you are in systemsettings5, check the display if it showing your monitors, if it is showing your monitors
it is okay but if not, you will need to reinstall the nvidia driver. Now since that you said you are using the nvidia-settings
to configure your monitors, go to the systemsettings5 startup and shutdown-background services and under the startup services
disable kscreen2.

While in xfce as su run nvidia-settings from the terminal.
In the xserver display configuration under the selection, choose x screen 0
Click apply and save it to xconfiguration file.
Here I enable base mosaic for my 3 monitors to have the compositing works.
Log out to xfce and try logging in to plasma5.

Try going to the nvidia site also, there two different driver there for x_32 and x_64 and read which one has a good support for your card.

I got the driver by first, adding the Nvidia repository, then adding the driver through Yast.

The version Yast grabbed from the repository is 340. I know there’s a newer driver, 352, something.

Okay. First, I’ll revert to the native driver, then add the newer Nvidia driver.

Hmmm… Not sure how to check the version. I searched for “system settings” in Yast and it brought up KDE-user-manager, which it says is version 5.5.1…

I’m assuming that’s the same systems settings I can access via the settings–>settings manager–>KDE System Settings–>Display Configuration

It does not show my monitors. I looked previously and had assumed that was simply because of the fact I’m using proprietary drivers, not the native ones.

Okay, I’ll disable kscreen2.

Okay, I’ll give that a try.

This is frustrating.

I reverted back to the native drivers, installed newer x64 Nvidia drivers (v 358.16), and it all works fine as before–as long as Xinerama isn’t enabled. I disable Xinerama and I can use Plasma. I enable Xinerama and I get black screens and a mouse pointer, nothing else.

I then re-installed the Nvidia drivers and, again, the same thing happens.

I followed your directions as best I could. When I went to disable Kscreen2, it wasn’t one of the applications set to launch at startup. So, I couldn’t disable it.

This has happened now on three installations of openSUSE. Each time I’ve tried different options. Each time I get the same results.

This could be a graphic card not fully supported or might be a bug with the GTX770.
I am using the .run installer here in all of my machines and two of them each has two monitors and all works.
Did you try to enable base mosaic? Did you use su when you run nvidia-settings? Did you logout and login after you save the configuration?

If by “base mosaic” you mean I set one monitor up with an absolute position and the other to the right of it, yes.

Yes, I used “su” when I ran nvidia-settings. I also logged out and logged back in after I saved the configuration.

I’m stumped.

When you click advance in the nvidia-settings you will see it just below the screen layout window.
Something strange here happened too a complete opposite to your problem when I tried reconfiguring my desktop
a while ago, if I try separate x screens one monitor doesn’t work in plasma, but if I configured both monitor as screen0 it works.:slight_smile:

Can you please run

lspci -v

and see if nvidia gtx770 is there

Well, I set things up as you’ve suggested and…

WOW, pretty much there! It’s working! Only one problem now. When I try to setup my secondary screen on the left of the one I want to use as my primary, there is no way for the settings to stick. I save the configuration to file but every time I log back into Plasma, it reverts to having the secondary screen on the right instead.

Well, if all else fails, I’ll just move my monitors around. Otherwise, I can play around to see if there’s a way to get the screens to switch positions.

Thanks so much! After spending a couple of days on this, I was ready to give up. It’s not crashing on me either, like it did with the native drivers.

Good to know it is working now.
To set your monitor position and to set as primary.
First as su run nvidia-settings and do what is necessary.
Log out and log in to plasma and run the systemsettings5
and set your display accordingly. When in the systemsettings5
display configuration, grab the monitor image to any position you want and
set the primary display and click apply. If still doesn’t work you may log out and log in
but before logging out be sure to go to your systemsetting5 startup and shutdown and under
desktop session under login set it to “start with an empty session”.

When it’s finally working as you wanted, you can try clicking my star below. Just kidding;)

Actually, I played around with the system settings as you suggested and it’s working exactly the way I need. Thanks so much.

Heh, don’t worry I’d already given you a “star” after I simply got Plasma working. :slight_smile:

Can you share your xorg.conf? I am having the same problem. I do not understand how to configure both monitors with screen0.