Hardware problem during startup and shutdown


Solve a problem. The machine “HP Pavilion 15- ab218nc” to the system W10 Home added yet Leap openSUSE 42.1 with one small problem:

When you start to see the problem:

ACPI MSFT0101: 00: platform device creation failed: 16

and shutdown:

platform MSFT0101: 00: failed to Claim 1 resource
ACPI MSFT0101: 00: platform device creation failed: 16
tmp_crb MSFT0101: 00: ioremap of the command buffer failed
iwlwifi 0000: 03: 00.0: Unsupported splx structure

System after the update, kernel 4.1.20-11-default, NVIDIA graphics drivers (proprietary).

I would also like to ask if the system is turned off within openSUSE and battery from 100% falls into the second day morning to 71% - 72%.

For information, the system actually gives off and not hibernating although if openSUSE’m not sure how this will be a real turn off even if the NTB seems off.

If you turn off the system via the W10 has no problem keeping the battery charged between 98% - 100% within the same time frame.

To verify the battery using HP Support Assistant, also performed a test battery to about 60% - 70% and made her storage for 24 hours if the battery has not dropped off NTB which is unimpaired.

Thank you for any advice. I apologize for the mistakes eventually. English is not my native language.

Hello, does anyone know of any solutions or at least please directions to be able to successfully solve the problem?

I also tried installing openSUSE Tumbleweed and the problem is the same.

Installation was Tumbleweed, including updates of the latest version of the core to build openSUSE Tumbleweed 20160503

It’s a little hard for me to read slovak or chek, but it’s very likely that this is an Optimus system. Please post the otput of the following command.

/sbin/lspci | grep -E "VGA|3D"


command line listed as follows:
00: 02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 07)
01: 00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940m] (rev a2)

Thank you.

Am Sat, 07 May 2016 14:26:01 GMT
schrieb hank se <hank_se@no-mx.forums.microfocus.com>:

> It’s a little hard for me to read slovak or chek,

Additional hint:

A generic and simple way to generate non-localized output, instead of running

somecommand --some-parameter – some-other-parameter


LANG= somecommand --some-parameter --some-other-parameter

As this has to be done for every command, it might be easier to run

unset LANG

and then

somecommand --some-parameter – some-other-parameter

someothercommand --paramter1 --parameter2 …

Even the latter will only reset language to default locale (POSIX) in the
running terminal, so it will not perform any persistent changes.


Never attribute to malice that which can be adequately explained by stupidity.
(R.J. Hanlon)

So it’s an Optimus. I’m not very up to date on those systems, but here’s a late guide on Prime for Optimus systems, there’s also another approach called Bumblebee, but let’s start with Prime.

I tried to make adjustments according to the instructions NVIDIA Optimus vs Bumblebee and yet I can not say that I was greatly successful: // about the problem between keyboard and chair.

Thank you for any help. I appreciate that.

You may want to investigate further the Skylake aspect of this.
Someone suggested to me, when I was chasing a Sleep issue with Leap 42-1, that Skylake was not well supported in kernel 4.1.20.
My platform is not Skylake, so I did not pursue it further.

Good luck with your problem

My experience with an HP laptop and an HP netbook running openSUSE is that battery goes down, fast, even with the system shut down. In the older laptop it takes about three days, in the netbook, about two weeks or less. If I remove the batteries they last much longer, with almost no discharge after weeks of being removed. I could never fix this, so I got used to removing the batteries…