Hardware detection failed during installation of opensuse leap 42.3 on old PC with amd dual graphics

Hi I am Rupesh from India and I have an old PC with amd fx 4100 CPU, 8 GB ram, amd dual graphics and I want to install opensuse leap 42.3 on this PC but can’t.

Previously I have installed opensuse leap 42.2 and it worked fine. During the installation I have selected no kms and after installation I have disabled it. Unfortunately leap 42.2 installation media was lost.

At present when I boot into leap 42.3 installation media there is no option called “no kms” so when I press install button after sometime the message something like “1024 * 768”, 60 kHz is displayed on monitor without any content.

Previously I have said there is no proper support for graphics in Linux but I have not guessed that installation program itself is unable to detect hardware properly.

As I want to use my PC for basic tasks such as files transfer, running console programs like ls,find etc., please suggest how to install opensuse leap 42.3 properly.

Depends on how installer is booted. If install is to be EFI then you don’t see the option if install is to be MBR then you will. If you boot the install media in MBR mode the installer default to a MBR install if booted in EFI mode it defaults to EFI mode. In EFI mode you do not have options at the bottom of the screen. You can however press e find the line starting linux or linuxefi go to the complete end of that line (it wraps) add a space and nomodeset press F10 to continue the install. You may have to do this at boot until you straighten up your driver problems.

It is MBR not efi.

After a number of retries I found no kms option in the menu of opensuse leap 42.3 installer. As I have created USB installation media first I have booted it as harddisk and not found option no kms and after that I booted it as USB HDD and so I found no kms option somewhere.

The installation was succeeded and this time I have installed all the packages containing words drm,amd,video except nvida. Upon first boot the screen resolution was very low may be 630*360. I have seen error “no ums support for radeon”. I have tried a number of ways to change resolution but failed and finally I have removed the word nomodset in boot loader section in yast.

Upon reboot everything is working fine. I don’t what’s done properly in order to succeed.

It should be in F3 (If I remember right) when you boot the installer in legacy (MBR) mode

May I know how to boot into MBR mode and how to boot into efi mode. My system doesn’t have efi support because it was brought six years back then why the installer boot automatically into MBR mode.

If it is BIOS not UEFI it will not boot into EFI mode.You will then do a MBR boot install you have no choice. You should see options along bottom of screen. If you look at the associated menus it should be clear which changes the video setting

You can also still use the e and edit the kernel option as I indicated above

May I know how to boot the installation media into MBR mode on an efi computer.

Have to do it by the UEFI boot menu from a hot key (check machine docs to which one) sometimes shown on the machine boot screen