hardware clock

hardware clock always gives wrong value (2 hours lag) , set up the time by

hwclock --set --date="----"
hwclock --systohc

works well but upon restarting the pc hardware clock reads wrong value again. also system clock has always 1 hour lagging to hardware clock.(time zone is correct)
i also tried to adjust the time from the BIOS option menu but when loading Linux kernel the clock reads again a wrong value.
i am trying to synchronize with ntp server “pool.nto.org” but i cant change the file ntp.drift to add server information.
i will apreciate if somebody could help me.


Do this through Yast - System - Date and Time:

set Region to ‘Europe’, timezone to ‘Netherlands’
check ‘Set hardware time to UTC’
Now change the time to correct value.

Works on my laptop. On my server I use NTP, will get back here with settings.

BTW, do you dual boot with a Redmond system?

Here’s about NTP:

Get into Yast - System - Date & Time
click “Wijzigen”
tick 'Met NTP server synchroniseren"
enter ‘nl.pool.ntp.org’ as the ntp-server
click ‘Nu synchroniseren’
tick ‘NTP configuratie opslaan’

Thanks alot Knurpht :slight_smile: hardware clock is adjusted and locked with ntp server correctly.
but i still have small problem with system clock , it reads incorrect value after restarting. each time i have to adjust it from the time panel.
do you have any suggestions ?


My clock is also wrong at every boot, 1 hour less all the time, really annoying. I’ve tried with both setting HW clock to UTC and not. I do remember to have seen a patch beeing installed for the clock problem not long ago but it doesn’t seem to have helped. If anyone has a solution to this I’m very interested.

SDB:Your Computer Clock Shows the Wrong Time

There’s a link, “There is also a helpful article in the Unofficial SuSEFAQ [1]”](http://susefaq.sourceforge.net/howto/time.html), that contains some interesting stuff.