Harddisk decryption at boot needs installation USB-stick

Hi,
Last week I installed the latest TW on a HP Spectre as dual boot system to Win 11. In principle it worked and I have a running dual boot system now, with encrypted boot loader and encrypted separate home partition (same passphrase because only one could be entered during installation). However, I must have chosen some wrong option in the installer because the decryption of the boot loader only works if the installation medium (TW USB-stick) is available. That is: I have to boot from the USB-stick, then choose “boot from harddisk”, then I can enter the passphrase for the boot loader decryption.
If I boot “normal”, i.e. without the usb stick, nothing happens after the question for the passphrase. I see two possibilities:

  1. The keyboard driver is not loaded without the usb stick, because I see no cursor sign after the question for the passphrase and nothing happens when I type in the passphrase and press enter, even several times (as opposed to: when using the usb stick I see a thick _ as a cursor sign, which moves one line below when I press enter).
  2. A public key is necessary for encrypting the entered passphrase before comparing it with the expected one - and this key has been placed onto the installation usb-stick. In fact, there are sitting two .pub files on the installation usb-stick now and the decryption of the boot loader takes unexpectedly long (about 10-20 s).
    Can someone please help me to fix the problem, so I can boot without the usb-stick?
    Kind regards,
    Flo

Oh sorry, there are not two .pub files on the usb-stick, but two gpg-pubkey*.asc files.
(I memorized it wrong and couldn’t look it up on Windows).

It’s hard to know what you might have done wrongly during installation, when you haven’t told us what you did.

As for the keyboard driver – it should be the same one, coming from your UEFI BIOS, whether you boot directly or via the USB.

I’ll suggest another possibility. Maybe your BIOS is set for fast booting by not initializing any devices. But when you boot with the USB, it has to initialize devices. Maybe look into BIOS settings to see if there is anything that could be relevant.

Thank you,
I couldn’t find anything in the BIOS related to fast boot but following your suggesting I dived deeper into the path with the keyboard driver. Finally, it turned out, the problem occurs, if I have the logitech bluetooth receiver for my external keyboard plugged in. In this case, neither the internal nor the external keyboard are working at the first password prompt. So now, I boot without the bluetooth receiver, then enter the first passphrase (there is still no cursor to be seen and it still takes 15 s of no reaction after typing it in). Then, I can plug-in the bluetooth receiver for choosing TW in the boot menu and typing in the passphrase the 2nd time.
I consider the problem solved because I want to switch to an external keyboard without separate receiver anyway (that isn’t connecting in TW yet, but that’s the topic for another thread).
Thanks again for your hint nrickert! Every few years I have to install openSUSE new and run into problems and every few years you are helping me. I vote for a lifetime support award for you! :wink:

I’m glad you were able to track it down.