Hard Drve unbootable after SUSE - Ent

I have several hard drives that are now unusable as boot devices after trying SUSE eneterprise on them. This has happened of five drives with four different machines. The SUSE install smees to run but when I have tried to change back to other OS the drives will no longer boot. The new OS are loaded but the drive just wont boot. I get “error loading OS” or “grub error” when trying to boot. However i am able to make the sysems boot by starting from the SUSE CD and then selecting “boot from hard drive”

I have tried the trick of loading windows 98 Cd and thern using Fdisk /MBR and had no sucess. I have used the manual partition option from SUSE, Fedora, and Ubuntu to completely remove all partitions and then reboot followed by a “use entire disk” option but the drive will still not boot by itself.

Using the Segate and WD hard drive tools to completely re-initialize has not solved the problem either.

Is there any hard drive tool that can really reach deep into my HD and undo whatever SUSE Enterprize is doing to it?


In YaST|Boot Loader|Boot Loader Options try checking the ‘Write generic boot
code to MBR’ option.

Niclas Ekstedt, CNA/CNE/CNS/CLS
Systems Engineer/NSC Sysop
Telindus Sweden AB

I tried the “generic Grub” option several different ways and am getting “error 23”

I also tried installing LILO

sometimes the error I get when trying to boot is “NTLDR is missing” Sometimes it’s “missing OS”

If you have Ubuntu check the value of the boot flag it should be on , if you delete the first primary partition it can on off now ,than no os will boot may be gparted can do the test to

all the best

Gparted running from Ubuntu CD shows:

partition, filesystem, label, size, used, unused, flags
dev/sdd1 Ext3 /boot 196.08 Mib 18.32 MiB 177.75MiB boot
/dev/sdd2 unknown 57.08 GiB … … … … lvm

There is a triangular yellow sign with a “!” on it after the sdd2

This doesn’t (to me) sound like a drives problem, but rather boot loader and/or partition table.

What are the OS’s you have installed on the various drives?

If Linux, how are you installing the boot loader? And how are you controlling from where to boot from (bios menu, single boot partition, chainloading to boot sectors, etc.)?

Have you made changes to the partition table(s) with both Linux and Windows?

I just found a way to make the drives boot again. Using Maxtor Maxblast I cloned the boot drive of a working Win XP system and now the drive boots. This also worked on a separate system with a WD drive using Data Lifeguard to set up the drive as the new boot device.