Hard disk problem

Hi there,

I have openSUSE 11.2 x64 running on a Dell Inspiron 1720. I have a primary disk (160GB, contains Win Vista & openSUSE system), and a secondary disk (250GB, contains /home).

Yesterday when I try to boot openSUSE it got to the login screen in X, but despite looking normal the keyboard & mouse do not respond, so I cannot login to KDE. So I booted Windows to google about the problem, and notice that ext2IFS could not read the /home disk/partition. I have tried several times to boot Linux, but always the same symptom occurs. 2 times when I booted Windows the disk can be seen, but other times it cannot.

Then I booted rescue system to see what boot.msg, messages, Xorg.0.log, and other logs say. Xorg.0.log is zero bytes. None of the other logs are saying anything that indicates any real problem. I can mount the disk from rescue system, so luckily was able to do a backup before attempting to analyse the problem.

I guess I should check the hard disk first to see if it will fail. My BIOS has no tools for SMART monitoring, but Speedfan in Windows tells me the disk is in good condition. Is there any other tool I could use from rescue system to check the disk?

The empty Xorg.0.log file seems unusual, and also strange that no keyboard/mouse respond. I wonder if X has broken itself, and somehow locks the disk. Is that possible? :\

If anyone has any suggestions for a course of action to analyse then fix this problem I would be very grateful.

Kind regards,

Chris Wilkinson, Brisbane Australia.

Did you try Failsafe boot?

Try one of the disk analysis tools such as seatools from seagate. I think that WD, Hitachi etc. have their own versions

Yes. It loaded X, then had the same problem - gets to the graphical login screen but no response from mouse or keyboard.

When I ran speedfan in Windows last night the disk could be read by ext2ifs in Windows, but right now it cannot, so I ran Speedfan again just now. The status has changed from ‘OK’ to ‘interrupted by reset’, but apart from that it still says the disk is a good one. As per another users suggestion I will download a more in-depth analysis tool.

Kind regards,

Chris Wilkinson, Brisbane Australia.

OK, have run seatools, tried every available test, and the drive passes all of them. After passing all tests the status reverts to OK, instead of ‘interrupted by reset’, but still Windows cannot read the disk, and when trying to reboot to openSUSE I get no further than before.

I’m starting to get a picture of Xorg causing trouble, because if I check Xorg.0.log after each attempt to boot openSUSE that file is freshly written, but zero bytes. Then also it should be possible to mount the disk from Windows, but I cannot do that, only check to see that it reports it is OK.

Where to from here I wonder? Is it possible X is unstable, causing the hard disk to lock somehow?


Chris Wilkinson, Brisbane Australia.

11.2 uses ext4 so I doubt if ext2ifs can read it. So not being able to read the disk from Windows is a red herring. The repair system reported the disk is ok, so the problem would be with your X setup.

Can you create another account to login to? This may involve logging as root which is not to be done as normal practice but this is a different situation.

Another possibility is your X setup is messed up. You would fix this by running sax2. Sorry I don’t remember the command off the top of my head, but one of the others will tell you for sure.

Boot and at the grub menu and stop the timer by moving the selection to failsafe. But now move back to default.
Now press backspace to clear all text in the section lower down and then just type the number: 3
Hit enter

At the prompt, login with your username and password.



Now become su

Now type:

**sax2 -r

**When done type: **reboot

I logged in at runlevel 3, did an ‘su’, then ran sax2 -r. Sax2 fails, saying ‘your current config will not be read in’, then ‘cannot locate lib.pm in @INC (@INC contains /usr/lib/perl5/5.10.0/x86_64-linux-thread-multi…’ and more. Out of curiosity when I logged in I got a bunch of warnings about setlocale and en_US.UTF-8 no such file or directory. I also ran startx - KDE4 loads, but of course there is no keyboard or mouse - of note is that the system tray battery monitor cannot get battery info - perhaps HAL is also broken?

So yes it is looking like somehow X (and maybe other software) has corrupted itself. With sax2 -r failing what else can I do to reset X to factory settings?

Kind regards,

Chris Wilkinson, Brisbane Australia.

Try booting the install CD or DVD and running the repair system to check all packages.

My primary drive containing the OS’s has ext4 on the openSUSE 11.2 partn, but the other drive has ext3, and normally can be read fine by ext2ifs. :\

As per your next suggestion I’ll try running a repair on the install, but maybe tomorrow - its late and my tired head is looking forward to resting on my nice soft pillow. I’ll report back on how the repair goes when its done.

Kind regards,

Chris Wilkinson, Brisbane Australia.

There was also a inode size change in ext3 from 128 to 256 bytes some time ago. In any case if the repair system says the filesystem is fine, it is to be trusted more than any Windows software.