Hard Disk and Linux

Hello
I have a dualboot installation of Linux and its commercial rivals.I noticed that Linux makes great hard disk noise that I was not able to hear while using Windows.Is it due to filesystem?
I hava a recent configuration.

Hello
I have a dualboot installation of Linux and its commercial rivals.I noticed that Linux makes great hard disk noise that I was not able to hear while using Windows.Is it due to filesystem?
I hava a recent configuration.
Hello Aatish910 and welcome to the openSUSE forums. I must admit that I have never noticed any sort of issue with hard drive noise created by openSUSE loading. I do not claim to have the best hearing however. None the less, is it possible that you have loaded openSUSE onto a portion of your hard drive that is going bad? Does openSUSE load without any errors? Does it take a long time for openSUSE to load? Can you tell us any more about your computer or hard drive than it makes noise?

Thank You,

Is it musical? Maybe you have the next Internet hit. :wink:

But seriously I haven’t noticed that Linux is noisier than other OSes. You’ll have to describe the nature of the noise: disk drive? fan?

If you have file indexing enabled that will use a lot of harddisk activity and thusly, possible more noise. But I would also want to suspect either a fan or harddisk going towards failure. Linux does a lot more disk accesses during start-up when you have more features turned on but in general handles file access in a more responsible way than say Windows 7.

OK
I have a good hard disk and my pc is fine.I hear a clicking sound which is similar to old hard disks writing noise.But the hard disk itself is in good condition.
I have also noticed this kind of noise in other pc using Linux which donot make sound when using Windows.
The sound comes from hard disk.Its 100% sure and it only sounds using LInux.
I respect the Linux community and hope that this problem will be solved.
Among 10 pcs I could heard tha type of sound except that pc using solid state hard disk.

On 03/02/2011 08:36 AM, Aatish910 wrote:
>
> The sound comes from hard disk.Its 100% sure and it only sounds using
> LInux.

are we talking about multiple disks? all internal? some in and some
out? which make noise? which don’t?

what Linux file system is in use on the disks? are they set up as any
level of RAID or LVM?

you say you dual boot: do you hear the noise only when Linux is
accessing only the Linux partitions, or do you hear the noise only
when Linux is accessing the non-Linux partitions…

have you installed SMART? what does it say about the condition of your
drive(s)…

are you hearing a ‘click’ or more of a ‘grind’…does it begin about
15 minutes after start up and continue for (say) ten minutes or 15
minutes and then slowly become less and less noticeable…


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

I’m experiencing the same noise here. I’m dual booting with W7. the computer is a laptop and I installed Suse 2 days after purchasing it. the noise is on any partition and on both EXT4 and NTFS…
it has been like this for 8 months now and I never had a problem with the hard drive apart from the extra noise.

not sure what is causing it…

The filesystem in use is ext4.Smart is enabled.It doesnt report any bad symptoms.It occurs upon accessing any partition right from when Linux is booting.
The hard disk is internal SATA (WDC WD5000AADS-00S9B0).

On 2011-03-02 11:36, Aatish910 wrote:
>
> The filesystem in use is ext4.Smart is enabled.It doesnt report any bad
> symptoms.It occurs upon accessing any partition right from when Linux is
> booting.

Laptop?


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Check for any processes that are using up resources by using top


top

Also check you I/O statistics with iostat


/usr/bin/iostat

Please post your findings.

Hiatt

Hello jthiatt08. I had never even herd of the program top before and its output appears to be very interesting. As for iostat, seems like you must install the application set called sysstat in order to get the file /usr/bin/iostat installed which was not installed by default in my copy of openSUSE 11.4 RC2 anyway. Again, very interesting programs to run.

Thank You,

This is not a problem of operating systems, that means that your HDD operates. Anyway if you want a HDD without this sound buy a ssd. Also my Hdd has this sound when operates. Also maybe you have not enough ram, so operating system uses Hdd as auxiliary memory. Check your ram.

I have 4 gb ddr3 ram. If i disable swap,will any bad thing occur?

I have 4 gb ddr3 ram. If i disable swap,will any bad thing occur?
While the SWAP hard disk partition is not used if you have enough RAM memory, how much RAM is enough and do you know you will not run out due to loading a bunch of programs? What if one of the programs has a memory leak? They are not supposed to have such a problem, but if you run into this and you run out of RAM, your Linux OS could be dead or near death all of a sudden if there is no SWAP to fall back on. And, if you use the Hibernate function, the SWAP is said to be where this information is saved. As most Linux OS systems think there is a SWAP somewhere, unless you are running out of disk space, leave that SWAP partition there and do not remove it. As long as you are not swapping programs in to it, it is not slowing you down. And if you find you are using it, it is keeping your system running.

Thank You,

On 03/04/2011 04:36 AM, Aatish910 wrote:
>
> I have 4 gb ddr3 ram. If i disable swap,will any bad thing occur?

sure might…if you fill your RAM do want the machine to lock up, or
keep going?

what might you expect to gain by disabling swap?


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

Thanks for the suggestion.
Opensuse community is a great community.

On 03/04/2011 05:36 AM, Aatish910 wrote:
>
> Thanks for the suggestion.
> Opensuse community is a great community.

Just for the record - If you have a lot of RAM, then you do not need swap;
however, not only do you risk the possibility of a system lockup if a process
leaks memory or runs away, but more importantly, you rob the kernel of an
important tool it uses in managing memory. Are you smarter than Linus Torvalds??

I have the same problem and i’ve been running linux since 1999, so is this not a normal thing. i thought it might be the drives indexing. i did an updatedb and it made no difference.

for some reason i put my ear on my pc’s chassis last night. much like a car mechanic uses their ear to hear timing or valves. one drive sort of sounds like a coffee maker, but i’ve have heard that in hard drives before. it’s a brand new seagate 1TB. my seagate 500 is as quiet as they come, but i was shocked to hear what the heck was going on. the actuator arm simply never stops moving. it almost sounds like the thing is going rip out of the chassis. but if i boot into windows nothing, it’s quiet. i do hear the drives, but it’s the normal sound of an actuator arm moving over the surface. i did a large file copy from one drive to the other and while it did make noise as it should it is nothing like the noise it makes while running linux or gnu/linux whatever. i thought of using different linux distributions and disconnecting each drive. these are “new” sata drives configured in ahci (one is one year and the other 2 months). i can’t see how they would last a day running like i heard them in linux. i just had one fail and wonders if it simply was worked to death from bad controller code.

  • gnu/linux #231826
  • x58/ich10r | i7-950| 3@2GB 1600 3x channel | geforce gt240 1GB [19" 16:10, 19" 4:3] | 500GB / 1TB / dvd±rw [sata ahci] | 600W

I have the same problem and i’ve been running linux since 1999, so is this not a normal thing. i thought it might be the drives indexing. i did an updatedb and it made no difference.

for some reason i put my ear on my pc’s chassis last night. much like a car mechanic uses their ear to hear timing or valves. one drive sort of sounds like a coffee maker, but i’ve have heard that in hard drives before. it’s a brand new seagate 1TB. my seagate 500 is as quiet as they come, but i was shocked to hear what the heck was going on. the actuator arm simply never stops moving. it almost sounds like the thing is going rip out of the chassis. but if i boot into windows nothing, it’s quiet. i do hear the drives, but it’s the normal sound of an actuator arm moving over the surface. i did a large file copy from one drive to the other and while it did make noise as it should it is nothing like the noise it makes while running linux or gnu/linux whatever. i thought of using different linux distributions and disconnecting each drive. these are “new” sata drives configured in ahci (one is one year and the other 2 months). i can’t see how they would last a day running like i heard them in linux. i just had one fail and wonders if it simply was worked to death from bad controller code.

Constant disk activity might be the fault of an application. Once such application is Tracker. If you open up YaST / Software / Software Management, search for tracker and then uninstall the four applications (which you could always reinstall if you wanted to later) and see if the crazy disk activity goes away.

Thank You,

Hi James, you don’t need to uninstall tracker (although I agree that it is annoying). It can be enabled or disabled in the session properties. To disable it

  • under KDE:
    Personal Settings -> Startup and Shutdown -> Autostart
    Uncheck Tracker File System Miner and Tracker Store

If these entries are missing, copy the two files from /etc/xdg/autostart in ~/.config/autostart:

cp {/etc/xdg,~/.config}/autostart/tracker-miner-fs.desktop
cp {/etc/xdg,~/.config}/autostart/tracker-store.desktop

You can then uncheck them.

  • Under Gnome:
    System → Preferences → Startup Applications.
    Uncheck Tracker File System Miner and Tracker Store

  • Under XFCE:
    Settings → Preferences → Settings Manager → Session and Startup → Application Autostart
    Uncheck Tracker File System Miner and Tracker Store

  • Under LXDE (should be disabled by default):
    Session Settings
    Uncheck Tracker File System Miner and Tracker Store

When you disable these services under Gnome, the following key/value is set in tracker-miner-fs.desktop and tracker-store.desktop located in ~/.config/autostart:

X-GNOME-Autostart-enabled=false

When you disable them in KDE and XFCE, the following key/value is set:

Hidden=true