Hanging after boot

I’ve installed openSUSE Leap 15.0 with GNOME on my new ASUS notebook. After installation process I updated the system. When I switch on the notebook it always hangs. Sometimes a login form appears, sometimes only black screen is displayed. Even if the login form allows me to type a user password then the system hangs after enter clicking. I read that it may be caused by the integrated graphic cards. Unfortunately, I don’t know how to configure the system correctly.


00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:591b] (rev 04)
    Subsystem: ASUSTeK Computer Inc. Device [1043:1a10]
    Kernel driver in use: i915
    Kernel modules: i915

01:00.0 3D controller [0302]: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] [10de:1c8d] (rev a1)
    Subsystem: ASUSTeK Computer Inc. Device [1043:1a10]
    Kernel driver in use: nouveau
    Kernel modules: nouveau

When I reboot (using the power bottom) the system 3-5 times it finally starts correctly. I read that the GeForce card can consume more battery power, so I can use the Intel card. In another words, it’s not necessary to install Nvidia drivers if are not really needed.

Well not quite right

Hybrid graphics like this are called optimus and you should install bumblebee

https://en.opensuse.org/SDB:NVIDIA_Bumblebee

Bumblebee is not mandatory with Leap 15, especially if you need little or no use of discrete graphics.
A default install should boot using the integrated graphics chip, switch off discrete graphics and allow some use of it via DRI_PRIME with the nouveau driver when needed.
But the nouveau driver is known to have some problems with some cards (see https://doc.opensuse.org/release-notes/x86_64/openSUSE/Leap/15.0/#sec.driver ) although those should have been fixed if you fully updated your system.
Anyway, try booting with the nouveau.modeset=0 option added to the boot line:

1- at the boot screen press “E” to edit the boot line;
2- look for a line beginning with “linuxefi”;
3- append “nouveau.modeset=0” (without quotes) to that line.

If that works, you can make this change permanent editing the bootloader options with the YaST Bootloader app.
You might also try the “nomodeset” option which switches off kernel modesetting also for integrated graphics, and/or try uninstalling the Mesa-dri-nouveau package which is known to have problems with some graphics cards.

(Writing this from an ASUS N551 with default install, no bumblebee)

Thanks for your replies. I installed Bumblebee as gogalthorp suggested me and I’ve tested it for a few days. There is no more any hangs.
OrsoBruno, can I still use your method? During Bumblebee installation I read that I’ll not be able to revert this operation without snaphots. I couldn’t do a snap because I set Ext4 file system (not Btrfs) while I made partition tables. I’m not sure it is worth to change now anything at all.

If bumblebee works keep using It, there is nothing to be gained from DRI_PRIME. You can revert your changes by uninstalling bumblebee and related packages and undoing any manual configs, but you risk breaking your system again If you are not sure about what you are doing.