Hang during boot (kernel 5.18.15-1)

Most recent update to Tumbleweed (kernel 5.18.15-1) just updated this afternoon results in a hang during boot (KVM guest installation). Screenshot attached. Booting to 5.18.11-1 works just fine.

Image URL: https://drive.proton.me/urls/FWVY8R0ADM#g8BUS1QYh9U7

It should be noted that the most recent update to MicroOS resulted in the same messages/hang during boot.

boot messages end with:
T100] input: ImExPS/2 Generic Explorer Mouse as /devices/platform/i8042/serio1/input/input2
https://drive.proton.me/urls/FWVY8R0ADM#g8BUS1QYh9U7

To further clarify, this was installed as a KVM guest (Manjaro host) over a month ago and updated daily up to 5.18.11 without any issues. I then went on a two week vacation and returned today. I updated today when I returned and on reboot, it hung. The exact same thing occurred on my MicroOS KVM guest after it was updated. The Leap KVM guest had no issues after its update.

Some of us don’t open URIs to screenshot sites that require JS, or won’t allow opening directly in the browser, including me. TW includes susepaste for free and easy uploading of text and images.

I’ve installed 5.18.15 on 3 PCs so far with no issues:

# inxi -CS --vs
inxi 3.3.20-00 (2022-07-27)
System:
  Host: gx78b Kernel: 5.18.15-1-default arch: x86_64 bits: 64
    Console: pty pts/1 Distro: openSUSE Tumbleweed 20220805
CPU:
  Info: dual core model: Intel Core2 Duo E8400 bits: 64 type: MCP cache:
    L2: 6 MiB
  Speed (MHz): avg: 2493 min/max: N/A cores: 1: 2992 2: 1995

I have TW installed on my system and have the same issue that the kernel is not loading with the snapshot released today. My boot process stops at:

    1.491455] tsc: Refined TSC clocksource calibration: 3099.998 MHz 
    1.491467] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x2caf45e6a57, max_idle_ns: 440795365367 ns 
    1.491486] clocksource: Switched to clocksource tsc

As if the next step switching to systemd is not working.

Rollback saved the day. :slight_smile:

Same issue here. Rolled back to 5.18.11. It’s an AMD Ryzen 2200G CPU if that’s relevant

This answer solved the issue for me: https://forums.opensuse.org/showthread.php/573527-TW-hangs-during-boot?p=3148133#post3148133

https://paste.opensuse.org/68209861

Image URL: https://paste.opensuse.org/68209861

This also occurs on a fresh creation/installation of a KVM guest.

Host OS: Manjaro (fully patched/current - no AUR usage)
Host CPU: AMD Threadripper 1950X

This still occurs with the most recent Tumbleweed ISO/updates (20220807)

Based on a repy to this thread, I tried adding the spectre_v2=off kernel parameter which solved the issue for my existing guest VM, but did not help with creating a new VM.

# inxi -C
CPU:
  Info: quad core model: AMD A10-7850K Radeon R7 12 Compute Cores 4C+8G
    bits: 64 type: MT MCP cache: L2: 4 MiB

This with 5.18.15 needs spectre_v2=off to be able to boot. I’ve removed it, keeping 5.18.12 until 5.18.16 or 5.19.x arrives to not need it. I also tried instead mitigations=none, but it didn’t have any apparent effect.