Halt after several second before wake up after sleep

Hello forum users!
Just installed openSUSE 12.3 on my ASUS X55VD.
Everything works fine, except sleep. After i close lid, notebook puts into sleep mode.
But after wake up (opening lid) it works only several seconds (usually up to 2 min) and then power off with “tick” sound from speakers.
I tried Arch Linux but they have same issue. Can someone help me?

/proc/cmdline

BOOT_IMAGE=/vmlinuz-3.7.10-1.16-desktop root=UUID=4b90e1ed-c9c1-4b62-ac6a-6859c7219e4d ro quiet splash=silent "acpi_osi=!Windows 2012"

try to update to a new kernel

add this repository
Index of /repositories/Kernel:/stable/standard

Didn’t help.
After wake up in dmesg:


 9287.695300] ------------ cut here ]------------
 9287.695349] WARNING: at  /home/abuild/rpmbuild/BUILD/kernel-desktop-3.7.10/linux-3.7/drivers/net/wireless/ath/ath9k/hw.c:794  ar9003_get_pll_sqsum_dvc+0xad/0xc0 [ath9k_hw]()
 9287.695444] Hardware name: X55VD
 9287.695467] Modules linked in: fuse xt_tcpudp  xt_pkttype xt_LOG xt_limit af_packet rfcomm bnep ip6t_REJECT  nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_raw ipt_REJECT iptable_raw  xt_CT iptable_filter ip6table_mangle nf_conntrack_netbios_ns  nf_conntrack_broadcast nf_conntrack_ipv4 nf_defrag_ipv4 ip_tables  xt_conntrack nf_conntrack ip6table_filter ip6_tables x_tables  bbswitch(O) reiserfs nls_iso8859_1 nls_cp437 vfat fat snd_hda_codec_hdmi  snd_hda_codec_via arc4 ath9k mac80211 ath9k_common snd_hda_intel  ath9k_hw snd_hda_codec ath snd_hwdep cfg80211 snd_pcm asus_nb_wmi  asus_wmi sparse_keymap pci_hotplug snd_seq snd_timer snd_seq_device snd  iTCO_wdt iTCO_vendor_support lpc_ich uvcvideo videobuf2_core videodev  videobuf2_vmalloc videobuf2_memops mei mxm_wmi sr_mod ath3k btusb  bluetooth acpi_cpufreq mperf mfd_core wmi soundcore sg rfkill serio_raw  snd_page_alloc coretemp kvm_intel kvm crc32c_intel ghash_clmulni_intel  cryptd pcspkr joydev cdrom microcode i2c_i801 battery ac autofs4 i915  drm_kms_helper drm i2c_algo_bit xhci_hcd thermal button video processor  thermal_sys scsi_dh_emc scsi_dh_rdac scsi_dh_alua scsi_dh_hp_sw scsi_dh  [last unloaded: nvidia]
 9287.696389] Pid: 4847, comm: kworker/u:21 Tainted: P           O 3.7.10-1.16-desktop #1
 9287.696431] Call Trace:
 9287.696458]  <ffffffff81004818>] dump_trace+0x88/0x300
 9287.696494]  <ffffffff8158af33>] dump_stack+0x69/0x6f
 9287.696531]  <ffffffff81045249>] warn_slowpath_common+0x79/0xc0
 9287.696578]  <ffffffffa0d6b80d>] ar9003_get_pll_sqsum_dvc+0xad/0xc0 [ath9k_hw]
 9287.696636]  <ffffffffa0eae4e3>] ath_hw_pll_work+0x53/0xd0 [ath9k]
 9287.696693]  <ffffffff810616ab>] process_one_work+0x12b/0x4d0
 9287.696732]  <ffffffff81062f1d>] worker_thread+0x15d/0x460
 9287.696768]  <ffffffff810681c3>] kthread+0xb3/0xc0
 9287.696801]  <ffffffff8159e9fc>] ret_from_fork+0x7c/0xb0
 9287.696835] --- end trace 405abd151e26d5af ]---

Here the dmesg after wake up.
0.000000] Initializing cgroup subsys cpuset 0.000000] Initializing c - Pastebin.com](http://pastebin.com/u016UdVS)

Remove " before "acpi_osi and use this line:

acpi_osi="!Windows 2012"

This only works for kernel 3.7x

Doesn’t help, because in grub.cfg it written correctly.

Do you have pm-utils installed? If not, please install.

Sorry, i was out of town.
pm-utils installed.

Please look at:

Navigate to Configure Desktop → Hardware → Power Settings → Energy Savings

Experiment with settings.

Also, I would look further into using pm-utils.

Does it turn off if you have your AC adapter plugged in or when it’s using batteries or both?

Update

Please enter **UEFI ** during start up of your laptop and check if there is a setting that turns off the laptop after sleep mode.

Tried experimenting with Energy saving settings - no result.
UEFI doesn’t contain power configuration options.
I’m googl’ing for my issue and find people with same issue (but not resolved).

Now i compile custom kernel 3.9.4 with kernel-gcc, tux-on-ice, and uksm.

After booting into custom kernel issue has gone, but nvidia module failed to compile (headers installed).

I guess you’re running bumblebee on this hardware, do you install it from Overman’s repo? Have a look here, Oopepe post #27.
https://forums.opensuse.org/english/get-technical-help-here/tumbleweed/486597-nvidia-bumblebee-kernel-3-9-issue-3.html