HAL does not mount removables anymore

I had some nasty remarks about what (not only) I see as deficiences of HAL.

And now HAL strikes back!

openSUSE 10.3 and KDE 3.5 (two systems doing the same).

Inserting a removable (CD, DVD, USB stick) lets pop-up the window with “what do you want to do with it”. Choosing “open in a window” opens a Konqueror window (nothing in it) and an error window with the text:

hal-storage-mount-removable no ← (action, result)

Not a very illuminating error message (like old and dark Unix days >:( )

The device is not mounted. Mounting from the CLI (as root) works fine.

This behaviour is rather recent, possibly introduced by some update. Anybody having the same? Anybody having some solution?

11.1
No issue here.

Check your history
Not sure if it’s in this location for you
/var/log/zypp

see if you have had hal update

No issue here with openSUSE 11.0 and KDE3.5.10 or KDE4.2.4. Must be specific to your 10.3 update. A PolicyKit issue?

Using grep hal /var/log/zypper.log I think the following might be of interest:

 2009-06-26 13:28:12 <1> boven(15355) [zypp] Downloader.cc(patches_Callback):49 hal-4963 : [1]./repodata/patch-hal-4963.xml{0 B|sha1-1a4e2b9c995c7ed555214794b
7c449f9fb38ec97}
2009-06-26 13:28:12 <1> boven(15355) [zypp] Downloader.cc(patches_Callback):49 hal-6037 : [1]./repodata/patch-hal-6037.xml{0 B|sha1-4873c38702853458422aa6850
f2f6d452eb40394}
2009-06-26 13:28:12 <1> boven(15355) [zypp] Downloader.cc(patches_Callback):49 hal-6085 : [1]./repodata/patch-hal-6085.xml{0 B|sha1-d74627a25910c2ed734db937e
c7873b45ba1e3ec}
2009-06-26 13:28:12 <1> boven(15355) [zypp] Downloader.cc(patches_Callback):49 hal-6098 : [1]./repodata/patch-hal-6098.xml{0 B|sha1-c06fff8b0dc9024a7c7218e5e
9a27d4926f66887}

There seem to be installed four hal patches if I interprete this correct. After a month holiday I updated, so it is understandable that there were more then one patch.

Now how do I get more info about those four patches, or more simply, how do I revert them (preferable starting with the most recent, testing after each removal).

Hm, did a Google on patch-hal-6098. Found The XML. And this contains:

The dbus package used a too permissive configuration. Therefore intended access control for some services was not applied (CVE-2008-4311). The new configuration denies access by default. Some dbus services may break due to this setting and need an updated configuration as well.

Could be an explanation, but why does nobody else report this?

Search software management for HAL
http://thumbnails10.imagebam.com/4055/ec5dd940541681.gif](http://www.imagebam.com/image/ec5dd940541681/)

See the versions tab and the radio buttons
go back one - you may have to do the same for hal-palm too to keep them in sync
If one roll back doesn’t do it, go back again.

Thanks caf4926.

There are four in thelist, the original OSS one and three updates. When I choose one update backwards, the dependancy check gives me:

#### YaST2 conflicts list - generated 2009-06-29 14:04:47 ####

Dit zou atom:hal-0.5.9_git20070831-13.7.i586 ongeldig maken.
    er is niet voldaan aan de vereisten voor atom:hal-0.5.9_git20070831-13.7.i586
    === atom:hal-0.5.9_git20070831-13.7.i586 ===
        hal-0.5.9_git20070831-13.7.i586 levert hal == 0.5.9_git20070831-13.7, maar is aangemerkt voor de�nstallatie.
        hal-0.5.9_git20070831-13.7.i586[openSUSE-10.3-Updates] levert hal == 0.5.9_git20070831-13.7, maar een andere versie van pakket is al ge�nstalleerd.
        Aan de vereiste hal >= 0.5.9_git20070831-13.7 voor atom:hal-0.5.9_git20070831-13.7.i586 kan niet worden voldaan
        atom:hal-0.5.9_git20070831-13.7.i586 zal opnieuw worden ge�valueerd voor installatie door hal-0.5.9_git20070831-13.5.i586[openSUSE-10.3-Updates] (hal == 0.5.9_git20070831-13.5)
    (null)
    Conflictoplossing:
        ( ) hal verwijderen

#### YaST2 conflicts list END ###

which is not in english, but I think you get the message. There is no Ignore button here, only Try again and Annull.

I’m having difficulty deciphering that even with Google translate. There must be a way to roll back. Really, you are in the best position to see how to resolve the conflict.
I can’t even guarantee that will resolve the issue.

hcvv wrote:

> Hm, did a Google on patch-hal-6098. Found The XML. And this contains:
>> The dbus package used a too permissive configuration. Therefore intended
>> access control for some services was not applied (CVE-2008-4311). The
>> new configuration denies access by default. Some dbus services may break
>> due to this setting and need an updated configuration as well.
>
> Could be an explanation, but why does nobody else report this?

I’m on opensuse 10.3 also, but have no issues with that patch applied :-?

Better open a bug report to manage this more accurately.

Greetings,


Camaleón

Great. Someone else with 10.3
Yes a bug report might be a good idea. Hang on with the roll back if you like.

Unfortunatly the KDE Bug Tracking System will not let me enter a new bug for older then 4.0.0. :frowning:

YaST2 conflicts list - generated 2009-06-29 14:04:47

This would make atom:hal-0.5.9_git20070831-13.7.i586 illegal.
dependancies for atom:hal-0.5.9_git20070831-13.7.i586 are not fullfilled
=== atom:hal-0.5.9_git20070831-13.7.i586 ===
hal-0.5.9_git20070831-13.7.i586 supplies hal == 0.5.9_git20070831-13.7, but is marked for deinstallation.
hal-0.5.9_git20070831-13.7.i586[openSUSE-10.3-Updates] supplies hal == 0.5.9_git20070831-13.7, but another version of the packet is allready installed.
The dependancy hal >= 0.5.9_git20070831-13.7 for atom:hal-0.5.9_git20070831-13.7.i586 can not be fullfilled
atom:hal-0.5.9_git20070831-13.7.i586 will be evaluated anew for installation by hal-0.5.9_git20070831-13.5.i586[openSUSE-10.3-Updates] (hal == 0.5.9_git20070831-13.5)
(null)
Conflict solution:
( ) remove hal

YaST2 conflicts list END

I tried a (sort of) tranlation.

hcvv wrote:

> Unfortunatly the KDE Bug Tracking System will not let me enter a new bug
> for older then 4.0.0. :frowning:

This is probably an opensuse bug, not a kde bug so you should move to
novell’s bugzilla, instead.

BTW, I’m also using kde 3.5.x :slight_smile:

Greetings,


Camaleón

hcvv wrote:

> I tried a (sort of) tranlation.

No need to do that :slight_smile:

Just run (as root from konsole):


LANG=en_EN.UTF-8 yast2


That way you will see English messages.

Greetings,


Camaleón

Then I may anounce the one and only englisg text of what YaST tells us:

YaST2 conflicts list - generated 2009-06-29 15:45:20

This would invalidate atom:hal-0.5.9_git20070831-13.7.i586.
atom:hal-0.5.9_git20070831-13.7.i586 has unfulfilled requirements
=== atom:hal-0.5.9_git20070831-13.7.i586 ===
hal-0.5.9_git20070831-13.7.i586 provides hal == 0.5.9_git20070831-13.7, but is scheduled to be uninstalled.
hal-0.5.9_git20070831-13.7.i586[openSUSE-10.3-Updates] provides hal == 0.5.9_git20070831-13.7, but another version of that package is already installed.
Can’t satisfy requirement hal >= 0.5.9_git20070831-13.7 for atom:hal-0.5.9_git20070831-13.7.i586
atom:hal-0.5.9_git20070831-13.7.i586 will be evaluated for installation (freshened) by hal-0.5.9_git20070831-13.5.i586[openSUSE-10.3-Updates] (hal == 0.5.9_git20070831-13.5)
(null)
Conflict Resolution:
( ) delete hal

YaST2 conflicts list END

And only the buttons:
OK – Try Again
Expert (submenu has only one option available for the occasional expert: Save this List to a File, and that is what I did, it is so easy to become an expert without any knowledge)
Cancel

And here he is: https://bugzilla.novell.com/show_bug.cgi?id=517389

Any chance you can do a screen like the one I posted of search for : hal
in software management?

hcvv wrote:

> Then I may anounce the one and only englisg text of what YaST tells us:
>> #### YaST2 conflicts list - generated 2009-06-29 15:45:20 ####
>>
>> This would invalidate atom:hal-0.5.9_git20070831-13.7.i586.
>> atom:hal-0.5.9_git20070831-13.7.i586 has unfulfilled requirements
>> === atom:hal-0.5.9_git20070831-13.7.i586 ===
>> hal-0.5.9_git20070831-13.7.i586 provides hal ==
>> 0.5.9_git20070831-13.7, but is scheduled to be uninstalled.
>> hal-0.5.9_git20070831-13.7.i586[openSUSE-10.3-Updates] provides
>> hal == 0.5.9_git20070831-13.7, but another version of that package is
>> already installed.
>> Can’t satisfy requirement hal >= 0.5.9_git20070831-13.7 for
>> atom:hal-0.5.9_git20070831-13.7.i586
>> atom:hal-0.5.9_git20070831-13.7.i586 will be evaluated for
>> installation (freshened) by
>> hal-0.5.9_git20070831-13.5.i586[openSUSE-10.3-Updates] (hal ==
>> 0.5.9_git20070831-13.5)
>> (null)
>> Conflict Resolution:
>> ( ) delete hal
>>
>> #### YaST2 conflicts list END ###
>>
> And only the buttons:
> OK – Try Again
> Expert (submenu has only one option available for the occasional
> expert: Save this List to a File, and that is what I did, it is so easy
> to become an expert without any knowledge)
> Cancel

Hal is one of the “core” components of the distribution. Many other packages
depend on it (dbus, policykit…) so I would not revert-back the version
of hal.

If you are experiencing any problem with the patch, open a bug report in
Novell bugzilla. I know it’s a bit hard to do this way but it’s also safest
way :slight_smile:

Please, keep in mind we are talking about “security” patch that was apply to
hal for many reasons, so using the older version could be risky.

Greetings,


Camaleón

HAL (hardware abstraction layer)
In Layman’s terms: Basically everything between Mobo and Hardware is managed by HAL.

Bugzilla: https://bugzilla.novell.com/index.cgi

I am aware of the implications of reverting a security patch. I will not do anything now, but wait for Bugzilla reactions.

My wife will not like this. I can do the mounts from the CLI, but she not (no root passwd).

@caf4926, you mean this one: http://www.xs4all.nl/~hcvv/HAL.jpg