Had full connectivity, now I don't - V12.1

I had full connectivity via eth0 until this afternoon, when the net connection failed outright. I can’t ping out of the machine and, of course, I can’t ping into the machine. I can ping internally. The machine uses static IP’s - and 155. I can ping between them from within the machine. But no other machine, including the FiOS router, sees them. The heartbeat on the Cat5 seems to be dead, regardless of the cable used.

Although this is a desktop box, it has WiFi capability, too. Using Yast, I set up wlan0 with the static IP eth0 used to be .152, and is now 155 - I used its information in the Yast tables to set up wlan0. I don’t see any status LED’s for the WiFi setup. Using a sniffer app, I see both AP’s here but not the desktop box.

At this point I’d ordinarily say the box has died and needs some new bits and pieces. But… I wonder if something has broken the net setup. I’ve been working on problems with updating this machine (see this thread: LINK) and may have toasted something in the process. I really doubt I have messed anything up, but it’d be silly not to look into the possibility.

What I’d like to do is completely reset this part of the system and build the needed tables, etc. from scratch. Or… did adding the definition for wlan0 and changing the IP for eth0, all with Yast, do that job? If this is a hardware problem, sobeit. But before I spend money on a new box, it’d be nice to be sure it’s not just a boogered Linux setup.

With a known good ethernet cable attached between router and NIC, do you get a valid link light? What is reported by the following

/usr/sbin/ethtool eth0
sudo /usr/sbin/ethtool -t eth0

Assuming those check out ok, you should then be able to verify the network config with

ip address
ip route

Regarding your wireless, did you manage to connect to your AP or not? (You might want to start a separate thread for help with that.)

I was getting a blinking light at the desktop socket only if a (known good) cable was plugged in, but either Link/Act lit up or, later, nothing lit up on the switch between all the ethernet wiring and the router. I pulled the power plug while trying to see if I could spot anything obvious (no joy), plugged the power supply back in and… lo and behold! eth0 woke up. After I got good light on the switch, I still couldn’t connect to the interweb. It took me a bit to realize that I’d lost the gateway definition (remember this is a static IP - DHCP isn’t going to fill in the gaps) but once I put that in, all is good. I’m posting from the desk top right now.

So… I think this, as I feared, a hardware issue. Pulling the plug (not just powering down) revived the ports. After that, it was just working in the right places with YaST. But that the physical ports tanked without much help worries me.

wlan0 doesn’t seem to be awake (turns out there’s a LED in the tip of the antenna), but that’s not mission critical. I did some searching but haven’t found much, under later revs, about waking wlan0 up. I found some information under 10.x, but most of what I found involved PCMCIA cards - yeah, real high tech… Any I’ll dig in the 12.x info. NTL, any links will be welcome.

It’s not clear as what the problem was IMHO. As a network engineer, I haven’t ever experienced anything like what you describe. Anyway, it sounds the wired network is working now.

You haven’t supplied any details about your wireless chipset, so difficult to advise anything useful. If you do decide to pursue setting that up, you should start by reading the wireless stickies at the top of this forum


All I can say is nothing worked on the ethernet side until I yanked the power plug out. Before that, all the powering down and booting up did nothing useful for the net connection. I just finished watching about 40 minutes of video courtesy of YouTube, and I can access the desktop from a laptop, using ssh. In short, I’m back to full functionality with the original cable, switch, etc. This box has supplied a host of other surprises on occasion, so I’m not entirely surprised. The box is about two years old and generally has done its job, although I’ve seen some outages of late. But that may just as well have been because the UPS battery was due for replacement (no real protection from brown-outs or drop-outs). ¿Quien sabe? [/shrug]

The chipset for wlan0 is unclear. YaST reports it as RT3090. This is an “everything on one board” mother board. It’s hard to sort out what chipset is really on the board. At any rate, it seems to be working, albeit not well. The big problem is during boot up ntpd is unhappy because it can’t find any of the TOD sources (from USNO, MIT, etc.) even though wlan0 knows the gateway address, etc. My guess is it’s a timing error (no pun intended), with wlan0 not fully up to speed when ntpd looks for its TOD sources. I also have a problem with ssh coming via wlan0. I can ping the host, but can’t reach sshd. With eth0 ntpd is happy, ditto for sshd. BTW, once the system is fully booted up, I have a solid connection with the AP’s. Security isn’t the problem. I’ll stop mucking about with wlan0 for now.

The chipset for wlan0 is unclear. YaST reports it as RT3090. This is an “everything on one board” mother board. It’s hard to sort out what chipset is really on the board.

The CLI is your friend :slight_smile:

On-board PCI-connected hardware chipset info can be got via

/sbin/lspci -nnk

To refine the search, something like

/sbin/lspci -nnk| grep Net -A3


/usr/sbin/hwinfo --wlan

For usb-connected hardware (internal hardware included)



  • The usbutils package must be installed first.

Thanks! I’ll try that and see what happens. It’ll probably be a day or two before I run this down, but I do want an alternative link “just in case”.

If you get stuck, I suggest you start a new thread (with a suitable title) in the wireless forum. Good luck. :slight_smile:

That was easy… As I thought, the chip is a Ralink RT3090 using the driver rt2800pci

Agreed. The question seems to have become “Why does ssh work with eth0 but not with wlan0”. Since I can get a wireless connection working otherwise, the focus, I think, shifts to ssh.