h264enc on opensuse 12.2 missing gpac


Recently I updated to opensuse 12.2 (coming from 11.3). All went fine except for my favorite encoder “h264enc”.
It is available in the repositories from packman and from microchip8 himself.

Problem is that it depends on “gpac” witch is not available in opensuse 12.2. I tried to contact the developer, without luck.

Did anyone run into this issue and if yes, is there a solution without messing up my fresh OS?
I know some of the mods use (or did use) this encoder.

Greets and thanks in advance,



If I do a

zypper se gpac

zypper returns

S | Naam             | Samenvatting                                             | Type      
  | gpac             | A multimedia framework covering MPEG-4, VRML/X3D and SVG | pakket    
  | gpac             | A multimedia framework covering MPEG-4, VRML/X3D and SVG | bronpakket
  | gpac-debuginfo   | Debug information for package gpac                       | pakket    
  | gpac-debugsource | Debug sources for package gpac                           | pakket    
  | libgpac-devel    | Development files for gpac                               | pakket    
  | libgpac0         | Shared libraries for gpac                                | pakket    

So, the package is available, from Packman. Now I enter Softwaremanagement, and select h264enc for install. I get a message that h264enc need gpac >= 0.4.5. Version available is 4.5 … So, I try installing gpac first, just to see what’s happening. Here it comes: gpac needs libjs.so.1 to be installed, and this one is not available. Somehow I get the feeling that the package is not maintained, since I don’t have any libjs.so (i.e. not in version 1, but none at all)

What are you using h264enc for? There might be (better) alternatives

Seems it’s not building;

To get traction you would need to raise a bug at packman:

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 1 day 6:12, 4 users, load average: 0.27, 0.24, 0.17
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Malcolm, could it be that libjs has moved to libplibjs ?

Well, I will place a bug. Let’s see if they can get gpac sorted. Building the missing packages is not my favorite waist of time.
Something seems wrong with the websites certificate… hmmm, I try again tomorrow.

I use it to re-encode movies or clips. It is an interactive shell script for mencoder.
Perhaps I should move on to something new but I really like to pull all the strings…

Many thanks so far!


Hi Guys,

I added the bug >click<](https://bugs.links2linux.org/browse/PM-56) successfully.
Sad thing is that no one seems to maintain the bug tracker website.
I added the bug last week and no new bugs are added in the meantime.
There is no activity at all.

Is this a dead end? Always believed that the packman repository was alive and kicking…


Very few bugs reported :wink: plus there are only a few people maintaining
packman so it can take some time.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 5:47, 5 users, load average: 1.02, 0.39, 0.28
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Ah, then we give them more time :quiet:

Hi, a quick update.

Marguerite from PM has picked up the issue but no solution yet.

We have to be patience.

Yep, gpac 0.5.0 svn4192-1.1 is online from now, this enables to install h246enc again!
All credits go to Marguerite, it took almost a month to solve it.

There might be some issues left see details in: https://bugs.links2linux.org/browse/PM-56
Those details are high-tech for me :frowning:

But it looks like it does not have any negative effect on h246enc.

So I guess your problem with libjs is also solved with the new version. I had no problem installing this package but I do work with OpenSuse Factory build and I already had libjs installed.

Hi mgrep,

It is always nice to welcome a new member to the forum.
To answer your question, yes. It was not possible to build gpac for opensuse in general. Member Marguerite from packman-team found a solution with the developer and build new packages for the repositories. As far as my knowledge goes, the new release does not depend on libjs. If you are interested in details follow the link above to read the bugtracker.

I never tried to build the gpac package myself, I leave that to the experts, and hopefully made opensuse a little better for all of us. :wink:

I’m the Marguerite you’ve mentioned.

Here’s the update.

Packman split x264 to libx264(for ffmpeg) and x264(containing x264enc) to avoid the situation that ffmpeg build needs x264, and x264 builds needs ffmpeg.

So it may take some time. So far as I see, my two new requests:

  1. fix gpac with 11.4 and sles.
  2. make the new split x264 to build with gpac.

have not been accepted yet. (as a rule…ping yoloki on #packman can make it faster…)

These two commits fix everything around gpac and x264.

and as a kind reminder, do not use the Osmo4 and browser-plugin packages.

I used hard hacks to make them built, but apparently they can’t be used and upsteam seemed to have plans to drop desktop player and browser plugin support while focusing on the command line tool MP4Box and android. (it’s nothing with x264enc…just to remind those who would like to keep everything installed)


and about libjs1:

a simple answer: openSUSE never have had this package.

it should be mozilla-js (12.1 and above), mozilla-js192, and mozilla-xulrunner191 (< 11.4, js function is included in this package)

so actually libjs is a package Packman maintainer created a long time ago to make < 11.4 have a solo js package (or they didn’t even know js was provided in mozilla-xulrunner191).

since < 11.4 is now considered obsolete, and gpac is the only one uses this package (for its browser-plugin subpackage, as I said, it’s just a skeleton that never works), I deleted it from Packman.

Hi Marguerite,

To prevent h264enc to break again in the near future we need your suggested requests implemented.

I like to know how to do that to help, perhaps you can PM me on this forum?


it’s done. (the gpac fix against < 11.4 and sles is still not implemented. but it has nothing to do with 12.2)

I like to know how to do that to help, perhaps you can PM me on this forum?

oh…there’s an IM named IRC, and you can find many clients support it like pidgin or konversation. then join Channel #packman…and see if yoloki is online…then tell him some SRs need to be accepted…(Chinese seldomly use IRC as IM…we have gtalk and twitter…so…)

Do you mean yaloki? yoloki is not in the member list, yaloki is. Perhaps yoloki is offline…

I did send a ping to yaloki followed by a message to accept your SR and close the thread on packman. His PC is on but there is no alive response from the person that owns it. :\ Must be the time difference. Hopefully he does see it somehow.

SR is accepted and thread https://bugs.links2linux.org/browse/PM-56 has status resolved.