Gwenview browsing in image archives

Hi everybody,

I know I kind of posted about this problem already, but it really bugs me.
So the thing is that in other distributions, when I open in krusader a picture from an archive with gwenview, it is possible to browse through all the pictures in that archive. This is not working in openSUSE because, I don’t know why, krusader copies the opened image to /var/tmp/kdecache-username/krun and opens it from there.
I really like this feature in krusader because I keep all my pictures in rar archives on ntfs drives an without the above mentioned feature, I need to unpack them if I have to search something.
There is a BUG report about this, posted on 2010 december, but it is not corrected yet.
So the thing is that I use KDE, I like openSUSE, but I also want to browse my picture archive too. I understand that this BUG is not a high priority one for the distribution itself, and I kind of see that it won’t be fixed anytime soon.
That’s why I’m asking help from here. I think it is a dependency/packaging problem, but I have no time to start to dig around and search for the fix (I have a thesis to finish by june). I’m a software developer and I use linux for my home desktop for a long time, so I can handle if I need to recompile some packages, but I don’t know what is the exact problem.
So if somebody already dealt with this problem, or tried to, please share the knowledge with me.
Thank you!

I’m sorry, I forgot to mention that I use openSUSE 12.1 with KDE 4.8.1 and OBS built krusader 2.4.0-beta1. But this BUG is present from openSUSE 11.4 onwards, with every KDE and Krusader version I tried. And this means almost every KDE version and every Krusader version.