Guild Wars and Wine

When i try to run Guild Wars in Wine 1.1.8 in openSUSE 11.0 KDE 4.0, a rong message comes up and telling me:

Unable to initialize 3D output. Please verify that you have DirectX 8 installed and an updated video driver.

Then i click OK and it fails to start. I have installed Directx9 through: DirectX 9.0c March 2008 redistributable on Linux with Wine | Wine Reviews and added the registry keys for Guild Wars in Wines “regedit” but it doesnt help.

But i could run it with no problems 2 days ago (sunday).
I have try to disable Compiz, but it didnt help at all and when i ran it last sunday i had Compiz enabled with no problems.

The strange is that i can run other 3D games like Regnum Online ect ect problem free.

What am i doing rong here?

^^ Out of curiosity, when it was working did you have sound?

I installed GW under CrossoverLinux just a couple of days before moving to openSUSE, then tried 4 different flavors of openSUSE over the course of a few days (including GW/Crossover installs) and at some point lost my sound. I can’t remember for sure whether I had sound working under openSUSE or not, so haven’t been sure where to start for troubleshooting.

I can tell you for certain that GW is working minus sound under CrossoverLinux with openSUSE though. I realize that’s not much help for you, but it’s all I’ve got. :slight_smile:

Yeah i moved to openSUSE from Ubuntu. I used that distro alot.

I had sound in Guild Wars when i ran it through Wine yes.
That was no problem at all;)
CrossoverLinux is a commercial pay software which you must pay a
licence for to use and i live in the thought that everything should be free lol!
Same thing with Cedega also commercial :frowning:

But no, i dont know what rong i have with Wine 1.1.8 and GW???

^^ I got it during their giveaway a couple of weeks ago, so it is free unless I want support/updates after more than a year. :slight_smile: In any case they claim that all their Wine improvements trickle down to the FOSS Wine project, so that’s a good thing at least.

I guess I’ll have to fiddle around with it a bit…

Good luck and sorry that I couldn’t help with your problem! :slight_smile:

Ok thanks :slight_smile:
But i have got it working now. I re-installed openSUSE from the DVD. My old installation was from the live cd, so i did a clean install from the DVD and installed the nvidia drivers again and not enable Compiz and it worked.
So now i can play Guild Wars.