GUI wont load

I installed Suse 11.1 and when I tried to load from the normal boot path it only loaded a text log-in and wont load the the GUI interface. I tried running startx and go an error message. I then loaded the Fail safe boot option and the GUI loaded and worked fine. I tried reinstalling and the same thing happened.

Does anyone know what going on?

What’s the error message?

Also, you might want to specify your video info (graphics card, monitor type, etc.). It may be a driver issue.

You can try the following:

Step 1.
Use the Fail-Safe to boot to gui

Step 2.
Start Yast–>System–>BootLoader

Step 3.
Select the Section Management tab and click on the Edit button
Choose the top line highlighting openSUSE 11.1

Step 4.
Under Kernel Image, type in:

Under Intitial RAM disk, type in:

Under Vga Mode, type in:

Step 5.
Click on the OK button and reboot your computer

Let me know how it turns out.

I have a ATI Radeon X1650 card and a Xerox XL-370b monitor

when load i get an error saying:

failed services in runlevel 5: kbd
skipped services in runlevel 5: nfs splash

When i type startx i get a error saying:

Fatal server error:
no screens found

Assuming you have already installed the ATI drivers from the openSUSE website…

When you are in console mode, try the following steps

Step 1.
Type in su followed by your password

Step 2.
Type in init3

Step 3.
Type in
sax2 -r -m 0=radeon

Step 4.
Type in init5; exit

This should take you to the gui.

Does this help?

If this fails use the DVD and select Repair Installed System.

That fixed the problem. Thanks

Hi Roman,

would that sequence work with sax2 -r -m 0=nvidia ?

I have an asus 8800GT gpu and very much the same symptoms.

sax2 -r -m 0=nv

That should work.

“nv” is the open source nvidia driver for Nvidia cards, analogous to the open source “radeon” driver for ATI cards.

Many thanks foresthill; I’ll try that and let you know how it goes.

rocking :slight_smile: it loads the GUI from the normal SuSE choice; I notice it does so with the vga=0x31a preset in the boot options but since it works I’ll leave that in. Thanks again.