GUI Login screen - gone

I’ve been using SUSE 10.3 with KDE3 for some months now, but as I started my PC today SUSE loaded normally until the moment of the log-in screen, X blinked the screen several times and I ended up in command mode without giving any error message :confused:
Typing startx did start the X server.

I wanted to check the settings in YAST but it wouldn’t open (the first window opens, but not when I select some section). I tried evoking it from command line (yast, yast2), but it got nothing… and I’m not expert enough to know which files to change manually.

I found several with a similar problems, but non of them worked for me. One was mentioning that YAST opens after ~20 min from staring it :eek:. By me it didn’t at all, but for example the Performance Monitor program opens very slow and needs minutes to refresh (other programs work just fine).

My guess is that some update modified a setting (probably of kdm) which I still haven’t discovered.

I tried booting to runlevel 3 and then manually running xdm or kdm. In the first case I got the gray-login window, but after entering username and password I just got the window again and again. Running kdm had no effect.

I’ll appreciate any ideas and suggestions!