GUI does not load after first restart, card Intel 82915G

Hello, need help making the Intel video card work with SUSE GUI. The installation went beautifully, everything worked until the PC was shut down and restarted. Now the GUI does not load, I see the gray version of the interface with xconsole.

Card: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04)
xconsole output: drm:i915_getparam ERROR Unknown parameter 5.

Please help with ideas! I’m a new user, so please be patient.

Try this, read carefully:

Pause the boot by moving the down arrow, then back up to the default boot. But now press backspace, it should delete any text where you can see VGA=.

Remove all text and now type just the number:
and hit enter

at the login type your user name and then password
now type:
then the root password

now type this:

sax2 -r -m 0=vesa

(N.B. the 0 is a zero not a letter)
now reboot

if you don’t get a gui login
login as user and try this at the cli

Thank you for replying. I tried both commands exactly as described, but the problem did not go away. The output of the xconsole has changed though: the line with the i915 error is no longer there. Maybe the problem is not the GUI but the Intel driver?

Follow the boot process I gave earlier to login at level3 as root and once logged in type:


You have to navigate yast with the keyboard, but go to Security and Users - User and Group Management
Then look for Login Settings under the Expert Options button.

Disable auto-login
accept and finish here.



Now try a normal boot, see if you get a login screen.

The only two options I have under the “Expert Options” are:

  • Password Encryption
  • Write Changes Now

Tried both for Local Users and System Users, same result.

This is it](

Expert Options

Yikes, I don’t have that in the Expert options. Seriously, no Display Manager Login Settings, only the two I described above (Pwd Encryption and Write Changes).
On the other hand, when I again tried to load the normal GUI, what’s loaded is called “Ice WM” and is the same gray interface I alluded to earlier.
Should I reinstall Gnome or switch to KDE altogether? Thanks.

Very odd. What version of openSUSE?

Very odd indeed. It’s the 11.1, the latest and greatest.
I sense it’s about the video card. I had a problem with the latest Ubuntu where screen just went black after the first reboot, a problem that many had. Tried the SUSE, here it’s at least booting, but not into the full GUI. Can I maybe install the latest driver for the video card that does not go crazy due to all of the 3D effects (which, by the way, I’ve now disabled)? :yawn:

You know, considering the time you have used so far on this and the fact that you only just installed. I would be inclined to run the installer again. This time make sure you uncheck the autologin box in the install settings.

There are many issues with Intel, maybe not the same as yours but have a look anyway

X Won’t start after YOU update on my Dell 700m With 855GM - openSUSE Forums