Guest additions in VirtualBox 4.12 not unstalling as in previous releases

Normally *devices -> install guest additions *works but in 4.12 it appears to do nothing

In 4.10 I saw the same but since everything worked I just kept using the 4.8 version

this time I did some convulting and extracted /usr/share/virtualbox/VBoxGuestAdditions.iso and manually ran VBoxWindowsAdditions.exe (which ran thru the install setup fine)

thanks,

notes: WindowsXP guest

So I installed VirtualBox 4.1.12 yesterday after announced. That then seems to clear out the old extension pack and so then I installed the extension pack 4.1.12 as well. When I ran Wiundows 7, selecting install guest additions did not cause any pop up, but the additions were mapped and usable. It seems like perhaps in Windows that the Auto-run function did not occur, but the pack was none the less there and usable as normal. I did have silly Windows claim it was not a real copy and I had to use the phone to re-register my purchased copy of Windows. Its perhaps the number one reason I switched over to Linux was such nonsense.

Thank You,