GTX 1080 Ti vs Leap 42.2

I can’t figure this out:

  • Running 42.2 and Windows 10 on same machine with 2 GTX 560 Ti in SLI and everything is perfect

  • Replaced the 560 Ti’s with a 1080 Ti

  • 42.2 gets to just before login and hangs with black screen, but will respond to ctrl-alt-delete

  • Windows 10 still works perfectly - but much faster.

  • 42.2 install disk boot fails just like old installed system

  • 42.2 recovery mode fails the same way

  • nvidia.modeset=0 and nouveau.modeset=0 both failed the same way

  • Replaced the 1080 Ti with the 560 Ti’s

  • Successfully booted into 42.2

  • Updated the nvidia drivers, kernel, etc. to 378.13

  • Hesitated, but rebooted 42.2 anyway

  • 42.2 with 560 Ti’s now fails same as above

  • Replaced the 560 Ti’s with the 1080 Ti

  • All linux systems now fail to boot same as above

  • Replaced the 1080 Ti with the 560 Ti’s

  • Successfully booted an old 13.2 partition and it is where I am now (as I write this)

I don’t know where to go from here. Any help would be greatly appreciated.


Tested with only> nomodeset

Tried nomodeset - still fails…

I am wondering:

Why 42.2 responds to ctrl-alt-delete. Doesn’t this mean linux is up?
Has anyone seen a problem like this?
Is there any possibility that the 42.2 system can be recovered?
As a last resort, might 42.3 fix it?


Also tried entering password into the black screen - nothing…

Enter the console

1080Ti absolutely requires the nVidia proprietary binary drivers, Nouveau is a no-go, even my 1070 - it’s DoA on boot for 42.2.

Install the binary drivers before you switch the cards.

V_idocq: ctrl+alt+F1 has no effect - I guess the drivers are hosed…

Miuku: Since nouveau is a no-no, it would seem to be impossible to install 42.2 on a machine with a 1080 Ti installed. Right?

Does anyone know of a way to force a text logon that doesn’t use either nouveau or nvidia drivers (this question may be nonsense, but I am at the end of my rope)?

Thanks for any help.


You might try the latest drvers from NVIDIA, IIRC 381.22 and installt that manually, the so called ‘hard way’.

You can still use the old “3” trick which boots straight into text mode by adding 3 to the linux line in your bootloader (you can edit it when starting the machine by pressing E as I recall, or was it ESC first and then E. Either way.) Find the line that says linux, has your kernel and showopts - then add 3 at the end.

Bottom of the screen then says what to press to boot with these new parameters.

Once you get to text mode, you could try the nVidia repository (yast -> software -> software repositories -> add -> community repositories -> checkmark nVidia -> OK -> OK -> Quit). From the Software Management, search for nVidia and install the nvidia-GFX04-kmp-default, it’ll pull the necessary dependencies. Reboot. Hope for the best. :slight_smile:

Don’t be afraid, it is possible to install Open Suse 42.2 on a machine with a 1080 ti.

I have just successfully installed the NVidia driver and I have my card properly working.

From the raw distribution, just follow these steps:

  1. Install Cuda 7 or Cuda 8 without installing the driver. Maybe, you will have to install devel versions of the following libraries: GLU, X11, Xi, Xmu and GL

  2. Install gcc

  3. Download driver 384.59, released on 07/24/2017

  4. Install everything related to linux kernel sources asked by the driver (it would take you two or three failed installation attempts)

  5. There is an issue with drm option that gets fixed with NVIDIA-Linux-x86_64.384.59.rpm --no-drm

This time it only took me one day and three failed operative system installations to have everything working. Not bad. :slight_smile:

P.S. By the way, I also tried to install Ubuntu 16.04 and I got a black screen at reboot >:(

mhg77…Thanks for the steps. I am out of town working now, but I will try your method this weekend…J:)

mhg77…Voila! Worked like a dream. 42.2 AND 42.3 both up and fully running. Thanks for your clear guidance…:slight_smile: