GTK module error

I’m using leap 15.3 and have installed Vectr via snap. When trying to launch however I get the errors

(vectr:4045): GModule-CRITICAL **: g_module_symbol: assertion ‘module != NULL’ failed

(vectr:4045): GModule-CRITICAL **: g_module_close: assertion ‘module != NULL’ failed
Gtk-Message: Failed to load module “unity-gtk-module”
Gtk-Message: Failed to load module “canberra-gtk-module”
No protocol specified

running

zypper se -i gtk-module

returns

S | Name | Summary | Type
—±------------------------------±------------------------------------------------------------±-------
i | libcanberra-gtk-module-common | Portable sound event library – Common Files for GTK+ Mod-> | package
i+ | unity-gtk-module-common | GTK+ module for exporting old-style menus as GMenuModels → | package

So I have both gtk modules installed, have already reinstalled both packages to no effect. Any ideas what the issue could be?
Thanks in advance

snap does not use system libraries. They must either come as part of snap package or snap package needs to depend on other snaps that provide needed functionality.