GTK default apps in KDE

Seems like this should be simple, but this one has me stumped.

I am using a GTK app (Vuescan) on 12.2 and kde 4.9.4. If I scan to pdf, Vuescan wants to open GIMP instead of Okular. I have Okluar set as my default app in File Association - System Settings.

Where should I be looking to change this?

Thanks,
Mike

Not entirely sure - two places that might play a part in this:
~/.local/share/applications/mimeapps.list
/usr/share/applications/defaults.list (which points to /var/cache/gio-2.0/gnome-defaults.list)

As Vuescan can output to PDF JPEG and TIFF, it may call one application which can read all these or, not being a KDE app, it may not be aware of Okular as an option or by-pass KDE, so never allowing KDE to make the choice. Is there a preferences option within Vuescan?

On Wed, 09 Jan 2013 20:56:02 +0000, msharnden wrote:

> I have Okluar set as my
> default app in File Association - System Settings

That would be a KDE setting - there’s a GNOME (or GTK) setting that you
probably need to set for GTK apps. Easiest way would probably be to
bring up a GNOME desktop and set the app there.

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Bingo! A little embarrassed to admit I never clicked on the more options button on the Prefs tab within Vuescan. It only allows one “External Viewer”, and that is set to GIMP.

Thanks for all of the suggestions/tips.

Mike

Great! I was looking for these config files since a long time!
Thanks :slight_smile: