I’m trying to install a newer gtk version 2.12.11 and am receiving the following error while I configure:
checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.13.5 atk >= 1.9.0 pango >= 1.17.3 cairo >= 1.2.0) were not met: No package 'atk' found No package 'pango' found No package 'cairo' found Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details.
rpm -q atk atk-1.22.0-23.1 rpm -q pango pango-1.20.1-20.1 rpm -q cairo cairo-1.4.14-32.1
and just installed glib-2.16.4
So I meet all of these requirements mentioned. I looked at some other posts with people having a problem with setting PKG_CONFIG_PATH, and tried just setting it to wherever glib, atk, cairo and pango are (and maybe another place just in case)…
PKG_CONFIG_PATH=/usr/lib64:/usr/share:/opt/gtk:/usr/lib ./configure --prefix=/opt/gtk
I receive the same error.
When I looked at another thread, it was mentioned that OpenSuSE11.0 should have 2.12.9GTK+, although I have gtk-1.2.10-1049.1 and don’t see any newer versions through yast.
- How do I properly go through adjusting the PKG_CONFIG_PATH if I have done this wrong?
2)I looked at man pages for pkg-config and am confused how or if it is necessary to set environment variables BASE_DEPENDENCIES_CLAGS and BASE_DEPENDENCIES_LIBS
Anyone been through this before? Thanks in advance.