gtk-2.12.11, adjusting PKG_CONFIG_PATH

I’m trying to install a newer gtk version 2.12.11 and am receiving the following error while I configure:

checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.13.5    atk >= 1.9.0    pango >= 1.17.3    cairo >= 1.2.0) were not met:

No package 'atk' found
No package 'pango' found
No package 'cairo' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


rpm -q atk
rpm -q pango
rpm -q cairo

and just installed glib-2.16.4

So I meet all of these requirements mentioned. I looked at some other posts with people having a problem with setting PKG_CONFIG_PATH, and tried just setting it to wherever glib, atk, cairo and pango are (and maybe another place just in case)…

./configure --prefix=/opt/gtk

I receive the same error.

When I looked at another thread, it was mentioned that OpenSuSE11.0 should have 2.12.9GTK+, although I have gtk-1.2.10-1049.1 and don’t see any newer versions through yast.

  1. How do I properly go through adjusting the PKG_CONFIG_PATH if I have done this wrong?
    2)I looked at man pages for pkg-config and am confused how or if it is necessary to set environment variables BASE_DEPENDENCIES_CLAGS and BASE_DEPENDENCIES_LIBS

Anyone been through this before? Thanks in advance.

Thread moved to Applications

All resolved with the help of the gtk mailing list (gtk-list Digest, Vol 51, Issue 6) and tips from various forums.

Basically, I didn’t have the development version (atk-devel, etc) of these packages installed.

One tipoff that this was the problem:
I could find glib-2.0.pc

find /usr/local -name "glib-2.0.pc" -print

but not atk.pc, pango.pc, and cairo.pc … which must be in the $PKG_CONFIG_PATH

installing the development versions fixed this.

Seems it might be helpful to mention that there were 2 glib versions present, and the older one was being accessed during configure, producing errors.

on, I found

It could be that you need to change some symlinks in /usr/lib to point to the new libs, but if that’s not it then there are 2 options. The first, is to completely uninstall the older glib, though that could possibly break some things. Then install the new one again. The second option is to install to another place besides /usr (or wherever the older glib is). Say you install it to /usr/local, make sure /usr/local/lib/pkgconfig comes before /usr/lib/pkg-config in $PKG_CONFIG_PATH, or completely remove /usr/lib/pkgconfig from it if nessecary, then try installing again.

I just changed the order of directories in $PKG_CONFIG_PATH so it came across the newer version first, and this worked fine.
for me this ended up looking:


(Also needed to install TIFF libs, libjpeg-devel, and cups-devel)