gstreamer & wma OR xine for both amarok and firefox

Hi everyone.

First of all, I’m not that new to Linux: I used Mandriva for a few years and then Sabayon and Debian for a few months each. Now I’m obviously running openSUSE (11.1 with KDE3, in fact). I had a few problems at first, but I figured all but one out. It has to do with multimedia playback.

I use Amarok for music and Firefox for surfing. At the moment I use xine for both, but there is a problem: Only the app I launch first is able to play media. So if I have Amarok running and hop on my Firefox, there is no audio or video at all. On the other hand, if I’m surfing and feel like some music, I have to close Firefox first. You get the point.

Now, having carefully followed RedDwarf’s “Check your multimedia problem in ten steps” thread, I got my gstreamer running almost perfectly. You see, using gstreamer on Amarok would solve my xine problem. However there is no wma playback on gstreamer, and currently I have too much wma files to just convert them. So I’m asking for help, not knowing what to do.

I googled around for a week or so, trying all kind of things out (and at some point losing my gstreamer, now fixed). Either solution would do, be it gstreamer or xine.

I wonder what information you need. Here’s something:

# rpm --query --all 'libav*' 'libpostproc*' 'libswscale*' '*xine*' '*gst*' MPlayer '*vlc*' | grep -v avahi | sort
gstreamer-0_10-0.10.28-999.pm.1000.1
gstreamer-0_10-ffmpeg-0.10.10-999.pm.999.1
gstreamer-0_10-ffmpeg-debuginfo-0.10.10-999.pm.999.1
gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.42.5
gstreamer-0_10-fluendo-mpegdemux-0.10.23-42.pm.42.5
gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.42.3
gstreamer-0_10-java-1.3-42.pm.42.5
gstreamer-0_10-lang-0.10.28-999.pm.1000.1
gstreamer-0_10-libnice-0.0.10-0.pm.1.5
gstreamer-0_10-plugins-bad-0.10.8-6.6.1
gstreamer-0_10-plugins-bad-lang-0.10.8-6.6.1
gstreamer-0_10-plugins-base-0.10.28-999.pm.999.3
gstreamer-0_10-plugins-base-lang-0.10.28-999.pm.999.3
gstreamer-0_10-plugins-farsight-0.12.11-0.pm.1.4
gstreamer-0_10-plugins-good-0.10.10-3.22.1
gstreamer-0_10-plugins-good-extra-0.10.10-3.22.1
gstreamer-0_10-plugins-ugly-0.10.9-2.18
gstreamer-0_10-plugins-ugly-lang-0.10.9-2.18
gstreamer-0_10-schroedinger-1.0.5-2.19
gstreamer-0_10-utils-0.10.21-3.11
gstreamer-utils-0.10.21-3.11
kde3-amarok-xine-1.4.10-40.16
libavc1394-0-0.5.3-129.3
libavcodec52-0.5.22648svn-0.pm.1.1
libavdevice52-0.5.22648svn-0.pm.1.1
libavformat52-0.5.22648svn-0.pm.1.1
libavutil50-0.5.22648svn-0.pm.1.1
libgstapp-0_10-0-0.10.8-6.6.1
libgstinterfaces-0_10-0-0.10.28-999.pm.999.3
libgstreamer-0_10-0-0.10.28-999.pm.1000.1
libpostproc51-0.5.22648svn-0.pm.1.1
libswscale0-0.5.22648svn-0.pm.1.1
libvlc2-1.0.5-1.pm.3.27
libvlccore2-1.0.5-1.pm.3.27
libxine1-1.1.18.1-1.pm.37.2
libxine1-codecs-1.1.18.1-1.pm.37.2
MPlayer-1.0rc2_r30099-2.pm.6.2
phonon-backend-gstreamer-0_10-4.2.0-40.18
vlc-1.0.5-1.pm.3.27
vlc-noX-1.0.5-1.pm.3.27
vlc-qt-1.0.5-1.pm.3.27
xine-browser-plugin-1.0.2-1.pm.1.2
xinetd-2.3.14-129.28
xine-ui-0.99.5cvs20091115-0.pm.1.3

If anyone can help, thanks a lot.

Multi-media and Restricted Format Installation Guide - openSUSE Forums

Done that, did nothing.

Are you saying that your guide covers installation of multimedia on Gnome with the same results as on KDE?

Interested because I am in the middle of setting up a Gnome partition for multimedia using gstreamer.

I have installed Gnome 3 times over the last 2 weeks and have used my own guide as a quick ref. Yes it works. But -
I temporarily un-installed transmission for the sake of my sanity. And Cario will give you the run around on dependency too, but with the radio button and a switch to QT UI, I figured my way thru.

One trick is keep adding each package in my list, as soon as it complains, stop, cancel that package and apply all the others. Then start again where it complained, if it still does, move on to the next and so on. If you still have a error or two try working thru with the radio button. Test you audio and video, it may work fine anyway.

@caf4926, thanks for those tips, i’m sure they will help in the next phase. I’m still at the stage of seeing how far I get (or if I like it) with multimedia on default 11.2 Gnome 64bit and gstreamer, without switching backends or adding any KDE apps. Only used basic bits of the guide so far, and have some missing codec support including (WM), but don’t want to hijack this thread further. :slight_smile:

@consused
No worries. I’ll do another install if necessary to help anyone:)
With tips and the like.

The tut doesn’t cover gstreamer bits to be fair the op has it pretty well covered with everything. i.e bad ugly and ffmpeg.

I think ffmpeg should give you wma playback but I get the impression it is far from smooth sailing. You can take the player out of it if you need to see if the backend can deal with it by

gst-launch-0.10 playbin uri=file:/path/to/file

But in all honestly I found the gstreamer mess a pain and if I needed it for more than exaile and mp3 I’d of given up.

@The op not sure what to say you should be able to play both. Strange xine is blocking I suspect pulse-audio, alsa dmix should handle this fine. My only suggestion would be to swap them find a non-xine browser plugin. I presume it is a desktop wide setting that is enforcing it, but if the plugin can’t be enforced i.e doesn’t have the choice gecko media player, vlc then it can’t be forced to use it.

I’m a little surprised that xine is playing it but gstreamer isn’t you could try the above command to see if it is the player or the backend. Also check the phonon backends got a feeling they can be buggy(actually you don’t have the xine one perhaps that is the difference)

[rant] thank goodness for no KDE(Phonon) or Pulse audio just dmix and alsa, and what is a codec mplayer plays everything I throw at it[/rant]

For gnome and gstreamer, install the gstreamer plugins and codecs from the Packman Repo and accept the vendor change.
You can also install the moonlight plugin for wma/wmv.
BTW, gnome uses totem and not kaffeine as the default media player.

@whych gave good advice for gstreamer. I just completed switching all gstreamer rpm’s over to packman and all my music files now work including .mp3 and.m4a. The m4a files weren’t playable in Banshee until I completed that. I had added new gstreamer plugins from packman but hadn’t switched the originally installed packages (oss repo), which probably explained why mp3 files played but not m4a files.

@tapksa, I note that you haven’t switched all your gstreamer packages to packman. Here is my list so far:

gstreamer-0_10-0.10.28-999.pm.1000.1.x86_64
gstreamer-0_10-ffmpeg-0.10.10-999.pm.999.1.x86_64
gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.42.5.x86_64
gstreamer-0_10-fluendo-mpegdemux-0.10.23-42.pm.42.4.x86_64
gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.42.2.x86_64
gstreamer-0_10-lang-0.10.28-999.pm.1000.1.noarch
gstreamer-0_10-libnice-0.0.10-0.pm.1.6.x86_64
gstreamer-0_10-plugins-bad-0.10.18-999.pm.1000.6.x86_64
gstreamer-0_10-plugins-bad-lang-0.10.18-999.pm.1000.6.noarch
gstreamer-0_10-plugins-base-0.10.28-999.pm.999.3.x86_64
gstreamer-0_10-plugins-base-lang-0.10.28-999.pm.999.3.noarch
gstreamer-0_10-plugins-good-0.10.21-999.pm.999.4.x86_64
gstreamer-0_10-plugins-good-extra-0.10.21-999.pm.999.4.x86_64
gstreamer-0_10-plugins-good-lang-0.10.21-999.pm.999.4.noarch
gstreamer-0_10-plugins-ugly-0.10.14-999.pm.999.4.x86_64
gstreamer-0_10-plugins-ugly-lang-0.10.14-999.pm.999.4.noarch
gstreamer-0_10-schroedinger-1.0.7-4.3.x86_64
gstreamer-0_10-utils-0.10.28-999.pm.1000.1.x86_64
gstreamer-utils-0.10.28-999.pm.1000.1.x86_64

I had already switched ffmpeg, libxine1, and libxine1-codecs over to packman before adding any extra gstreamer rpm’s.

  1. Tried this:

tapksa@antarktis:~/Desktop/wmatest> gst-launch-0.10 playbin uri=file:/home/tapksa/Desktop/wmatest/wmafile.wma
Setting pipeline to PAUSED …
** Message: don’t know how to handle video/x-ms-asf
Pipeline is PREROLLING …
ERROR: from element /GstPlayBin:playbin0/GstDecodeBin:decodebin0: A Advanced Streaming Format (ASF) demuxer plugin is required to play this stream, but not installed.
Additional debug info:
gstdecodebin.c(986): close_pad_link (): /GstPlayBin:playbin0/GstDecodeBin:decodebin0:
No decoder to handle media type ‘video/x-ms-asf’
ERROR: pipeline doesn’t want to preroll.
Setting pipeline to NULL …
FREEING pipeline …

I also believe my gstreamer packages are from Packman now. Can you see it from this?


rpm --query --all '*gst*' | grep -v avahi | sort
gstreamer-0_10-0.10.28-999.pm.1000.1
gstreamer-0_10-bml-0.3.0-42.pm.1
gstreamer-0_10-buzztard-0.5.0-42.pm.42.31
gstreamer-0_10-doc-0.10.28-999.pm.1000.1
gstreamer-0_10-ffmpeg-0.10.10-999.pm.999.1
gstreamer-0_10-ffmpeg-debuginfo-0.10.10-999.pm.999.1
gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.42.5
gstreamer-0_10-fluendo-mpegdemux-0.10.23-42.pm.42.5
gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.42.3
gstreamer-0_10-java-1.3-42.pm.42.5
gstreamer-0_10-lang-0.10.28-999.pm.1000.1
gstreamer-0_10-libnice-0.0.10-0.pm.1.5
gstreamer-0_10-plugins-bad-0.10.8-6.6.1
gstreamer-0_10-plugins-bad-doc-0.10.8-6.6.1
gstreamer-0_10-plugins-bad-lang-0.10.8-6.6.1
gstreamer-0_10-plugins-base-0.10.28-999.pm.999.3
gstreamer-0_10-plugins-base-lang-0.10.28-999.pm.999.3
gstreamer-0_10-plugins-farsight-0.12.11-0.pm.1.4
gstreamer-0_10-plugins-farsight-debuginfo-0.12.11-0.pm.1.4
gstreamer-0_10-plugins-good-0.10.10-3.22.1
gstreamer-0_10-plugins-good-extra-0.10.10-3.22.1
gstreamer-0_10-plugins-ugly-0.10.9-2.18
gstreamer-0_10-plugins-ugly-lang-0.10.9-2.18
gstreamer-0_10-schroedinger-1.0.5-2.19
gstreamer-0_10-utils-0.10.21-3.11
gstreamer-utils-0.10.21-3.11
libgstapp-0_10-0-0.10.8-6.6.1
libgstinterfaces-0_10-0-0.10.28-999.pm.999.3
libgstreamer-0_10-0-0.10.28-999.pm.1000.1
Performous-plugin-gstreamer010-0.4.0-0.pm.2.14
phonon-backend-gstreamer-0_10-4.2.0-40.18
python-gstreamer-0_10-0.10.18-999.pm.999.9

  1. About the xine engine: Don’t know what to do to it. FeatherMonkey, could you please clarify what I am to do? I’m sorry for the all trouble.

Thanks for the tips, though.

@tapksa, I can see that they are NOT all from packman, because those without “pm” in the rpm name are not from packman. Take a careful look through your list** e.g. gstreamer-0_10-plugins-bad-0.10.8-6.6.1** :wink:

Oh I see. Is there any way to replace those packages without deleting everything that depends on them?

If you use gnome, get yast working with the QT interface.
ImageBam - Fast, Free Image Hosting and Photo Sharing

Then work through all the packages in Packman, like this shows:
ImageBam - Fast, Free Image Hosting and Photo Sharing

As I said in my first post, I’m using KDE3.

I could of course just delete everything gstreamer-related and what depends on it. But if there’s an easier way, I wouldn’t mind learning it.

You don’t need to delete anything. Just select each packman package and select upgrade (or update, whatever), or if QT (as in KDE3) select as @caf4926 showed you and Yast automatically selects upgrade for you. If requested to resolve a dependency issue, select “install with vendor change” or words similar, and agree to install any additional packages required, e.g one of them requires Jack to be installed.

I still have 11.1 KDE3 partition. I will take look and come back to correct anything. I don’t recall any problems, but I think I avoided gstreamer on that system in favour of xine based apps. In any case, I would have followed caf’s multimedia guide for 11.1.

Looking at 11.1/KDE3/Yast, it worked slightly differently. Select Repositories in the “Filter” drop menu. Select @System as the repository name. That’s the easier way, as all installed packages are listed first in alphabetical order. Scroll to the gstreamer grouping and the updates to packman’s version should be shown in blue. Right-click on the tick icon at start of each blue line and select “update”, when done click “accept” to finish.

Apologies for previously showing you a list of gstreamer rpm’s from 11.2 as it seems there are not packman versions for all gstreamer rpm’s on 11.1.

I did have gstreamer packages installed, but cannot remember why as I haven’t used 11.1 for multimedia in many months. Here is my list having just applied some packman updates:

gstreamer-0_10-0.10.28-999.pm.1000.1
gstreamer-0_10-ffmpeg-0.10.10-999.pm.999.1
gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.42.5
gstreamer-0_10-fluendo-mpegdemux-0.10.23-42.pm.42.5
gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.42.3
gstreamer-0_10-lang-0.10.28-999.pm.1000.1
gstreamer-0_10-plugins-base-0.10.21-2.21.2
gstreamer-0_10-plugins-good-0.10.10-3.22.1
gstreamer-0_10-plugins-good-extra-0.10.10-3.22.1
gstreamer-0_10-schroedinger-1.0.5-42.pm.4
gstreamer-0_10-utils-0.10.28-999.pm.1000.1
gstreamer-utils-0.10.28-999.pm.1000.1
libgstinterfaces-0_10-0-0.10.21-2.21.2
libgstreamer-0_10-0-0.10.28-999.pm.1000.1
phonon-backend-gstreamer-0_10-4.2.0-40.18

Note those with no packman version. Hope that clears things up somewhat, even if it doesn’t solve your problem. IIRC, I mostly used a xine backend especially for amarok. I will have a look round my 11.1 to see if I can establish what was working/not. :wink:

Using Amarok (amarok-xine) and Firefox simultaneously, I was able to play full media (streaming video with audio) in Firefox and audio in Amarok, at the same time (not that anyone would want to). It didn’t matter which one started first, and switching one off and restarting again also worked.

“nothing provides libmysqlclient.so.15 needed by gstreamer-0_10-plugin-bad-0.10.18-999-pm.1000.6.i586”

Also I seem to be unable to change my schroedinger package to the packman version. Other than these two things, they’re okay now.

But guess what! gstreamer now plays wma! Not sure if there are still some problems with it, but if not, I won’t need xine for Amarok. Dunno what happens with SMplayer, etc.

I’d just like to be able to keep several apps running without one excluding functions of the rest.

Thanks a lot, consused. Still, may I inquire if you’d happen to know what prevents xine from being shared by two or more apps?

… Oh, there’s this. If I change the volume from amarok, the sound gets terribly distorted. I checked KMix, PCM looks good. Being able to change the volume from Amarok isn’t that important to me, but any tips are still welcome.