GStreamer broken after update

Hello All!
I’m using KDE and after some update GStreamer seems to be broken. Firstly it was unable to play sound at all, and I’ve got around this by changing Phonon preferred engine to Xine. But Clementine is still unable to play with error message:

Clementine Error
GStreamer could not create the element: volume. Please make sure that you have installed all necessary GStreamer plugins (e.g. OGG and MP3)
I’ve already read this and this topic, but none of the things, proposed to try, worked for me.

Are you sure that you have installed all codecs??
Check it again
Could I see your repos??

# zypper lr -d

Also do you remember which update was
Maybe You’re missing the “volume” element - check you’ve installed it properly, try running “gst-inspect volume”. It should come from /usr/lib/gstreamer-0.10/

You can find out what that update was, by inspecting the text file at /var/log/zypp/history.

Yes, there seems to be problem with it. Just re-installed one more time, still no luck.

GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/': /usr/lib/gstreamer-0.10/ undefined symbol: orc_program_append_2

You have openSUSE 11.3 or 11.4?? x86 or x86_64??

openSUSE 11.3 x86, KDE 4.6.0

I find the Gstreamer’s Plugins go here RPM Search OpenSuSE gstreamer-0_10-plugins-base-32bit-0.10.21-10.43.x86_64.rpm

Stamos, why should he use an .rpm from pbone? I use Clementine as well and it still works here, so I suppose it’s not a general gstreamer-bug.

Maybe it is not a general gstreamer bug as you said, but i thing that he could fix his problem. Anyway because
as I can see

GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/': /usr/lib/gstreamer-0.10/ undefined symbol: orc_program_append_2

that too libraries undefined. I thought that it will be better to install all plugins.

stamostolias, thanks for pointing me into the right direction!
.rpm from pbone can’t be installed due to error, but switching gstreamer-0_10-plugins-base, gstreamer-0_10-plugins-bad, and gstreamer-0_10-plugins-good from Packman to OSS repository solved the problem for now. Nevertheless it seems like source of potential troubles in the future as now gstreamer is partly installed from Packman (no proprietary codecs in OSS repository) and partly from OSS (as gstreamer-0_10-plugins-base from Packman have some undefined symbol)

For me GStreamer (from Packman) and Clementine are working fine, but I am using a 32bit 11.4 here, so maybe you actually found a bug. You should report it to Packman.

Maybe it is a bug, the problem was in Clementine.

I recently updated my standard 64bit openSUSE 11.3 KDE system, with many upgrade/downgraded multimedia packages from Packman, including gstreamer. I have had no issues with any packages, e.g running Amarok. I also run Kaffeine, SMPlayer, and VLC. I make sure that all gstreamer [and other multimedia] package versions are switched to a Packman repo source. I generally DON’T now mix related-package sources, especially multimedia, although I have got away with it in the past for gstreamer mixed from OSS and Packman.

If one uses e.g. Packman’s Essentials repo for multimedia, you can switch all system packages to that repo using Yast > Software MAnagement (when viewing by repo).

I have had no issues with any packages, e.g running Amarok. I also run Kaffeine, SMPlayer, and VLC.

These apps do not use GStreamer (at least not per default, if I remember correctly). Do GStreamer-apps work for you?

So you’re not sure then! Let me know which “Gstreamer-apps” you have in mind and I’ll let you know. :wink:

Gnome uses gstreamer by default. My previous post referred to KDE system but its comment could equally apply to my Gnome system.

Yast is currently offering me ‘gstreamer-0_10-plugins-good’ as a recommended update. Could well be that this has caused the problem especially if multimedia has been installed with none repo software. I have already had a lot of trouble with gstreamer so wont be accepting it as none repo software fully sorted out my sound an multimedia. It was a mess from a straight install. Easily fixed on 32bit but not so easily on 64. This patch is for crashes on low end machines and for v412 webcams. A gstreamer update may generate a large number of dependencies and break all sorts of things - even the sound notifications in kmail.

I looked yesterday and from memory the gstreamer on offer then was slightly different to the one on offer now.

One point - can zypper role back and update? This may be the best way forwards for this problem.

I use two of them, namely →Clementine and →Miro.


Made some Packman gstreamer updates yesterday on 11.4 but some names had dropped the “pm”. Today those updated packages are flagged red (Yast) for downgrade with “pm” naming restored, although I haven’t done detailed comparison, plus many more blue upgrades. Looks to me like Packman have had some issues during the last 24 hours or so.

Certainly a “zypper dup” will take care of upgrades and downgrades (roll backs). It will also allow repo vendor changes (e.g. OSS to Packman), and repo priority settings will apply and affect the results.

Not used here [so far] on standard 64bit 11.3 or 11.4 or Tumbleweed.

Thanks consused (great name)

I’ve found packman and others a great source of chaos in the past so generally only enable them till I get things working. I even disable the nvidia repo once that has worked. YAST can be problematic. There’s no saying what it may change without a rather close study. I will take a look at the zypper dup but the problem will probably be that the particular file/patch that used to be installed may no longer exist at least in the repo that was used. I’ve always found it rather strange that linux lacks a system back up and restore utility that doesn’t involve bring the system down to the prompt. It should be possible to do it even from the desktop. Restoring no but that shouldn’t be needed very often with a little care. I have a look around for that sort of thing every now and again. Mondo has some interesting comments about backing up a pc. It just avoids 2 directories and is highly configurable. I strongly suspect that those 2 omitted directories don’t matter as far as updates are concerned but as software engineer wonder what can be in them that the os cares about when it reboots.

The only other solution really is to re install but that leads to the same problem what ever it was at some point probably a lot sooner too. Bit too circular for me especially after a release has been up and running for some time.