I have installed in my pc opensuse 11.1, and I have installed the gcc compiler and the library gsl. However when I try compile the file program.c appear this result in the konsole:

program.c:3:29: error: gsl/gsl_complex.h: No such file or directory
program.c:4:26: error: gsl/gsl_math.h: No such file or directory
program.c:5:34: error: gsl/gsl_complex_math.h: No such file or directory

Anyone know how solve this problem?


You need to install gsl-devel to get the headers.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 17:40, 2 users, load average: 0.08, 0.08, 0.04
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.29

problem solved!

thanks malcolmlewis for the help.

I seem to have the same problem - XaoS 3.4 does not configure and reports that GSL is not installed. This made me look up stuff… So I discovered that GSL-1.12 is actual, from 2008-12-15. Suse-11.1 contains GSL-1.11 which is from 2008-03-30… a little bit outdated if you ask me.
No update available, not even Factory/snapshot has the newer version, even though it is more than 5 months old now.
I guess there is no personal repository that takes care of it, or is there?
In any case: May I hereby suggest an update?:slight_smile:

So, what I’m gonna do in the mean time… Have yast deinstall GSL and compile&install it from source.

Have fun!

This output here begs to differ:

/tmp/XaoS-3.4> sh configure
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /usr/bin/grep

----------- snip ----------

checking X11/extensions/XShm.h... no
checking for XShmAttach in -lXext... yes
Available drivers:
Complex math parser:
try GSL: yes
checking for gsl-config... /usr/bin/gsl-config
checking for GSL... yes
using GSL for complex numbers
configure: creating ./config.status
config.status: creating src/i18n/
config.status: creating Makefile
config.status: WARNING: seems to ignore the --datarootdir setting
config.status: creating src/Makefile
config.status: creating src/i18n/Makefile
config.status: creating src/engine/Makefile
config.status: creating src/util/Makefile
config.status: creating src/ui/Makefile
config.status: creating src/filter/Makefile
config.status: creating src/ui-hlp/Makefile
config.status: creating src/ui/ui-drv/aa/Makefile
config.status: creating src/ui/ui-drv/ggi/Makefile
config.status: creating src/ui/ui-drv/svga/Makefile
config.status: creating src/ui/ui-drv/x11/Makefile
config.status: creating src/ui/ui-drv/dga/Makefile
config.status: creating src/ui/ui-drv/win32/Makefile
config.status: creating src/ui/ui-drv/BeOS/Makefile
config.status: creating doc/Makefile
config.status: creating help/Makefile
config.status: creating src/ui/ui-drv/gtk/Makefile
config.status: creating src/sffe/Makefile
config.status: creating src/include/aconfig.h
config.status: creating src/include/version.h
config.status: src/include/version.h is unchanged
config.status: executing po-directories commands
Compiler options:
 CC          : gcc
 CFLAGS      : -Wall -fstrength-reduce -ffast-math -pipe -fno-exceptions -Os -fstrict-aliasing -malign-double -mno-ieee-fp  -I/usr/include -fomit-frame-pointer -DSFFE_USING -DSFFE_CMPLX_GSL -I/tmp/XaoS-3.4/src/include
 CFLAGS1     : -O6 -Wall -fstrength-reduce -ffast-math -funroll-loops -pipe -frerun-loop-opt -fstrict-aliasing -malign-double -mno-ieee-fp  -I/usr/include -fomit-frame-pointer -DSFFE_USING -DSFFE_CMPLX_GSL -I/tmp/XaoS-3.4/src/include
 CXXFLAGS    :  -I/tmp/XaoS-3.4/src/include
 LDLAGS      :
 LIBS        : -lpng -lz -lm  -lXext   -L/usr/lib64 -lX11 -L/usr/lib64 -lgsl -lgslcblas -lm
 X_LIBS      :  -L/usr/lib64



In case you have troubles with compiling or running
XaoS please read doc/compilers.txt.
/tmp/XaoS-3.4> make
make[1]: Entering directory `/tmp/XaoS-3.4/src'
cp include/config/config.autoconf include/config.h
make[2]: Entering directory `/tmp/XaoS-3.4/src/sffe'
gcc -O6 -Wall -fstrength-reduce -ffast-math -funroll-loops -pipe -frerun-loop-opt -fstrict-aliasing -malign-double -mno-ieee-fp  -I/usr/include -fomit-frame-pointer -DSFFE_USING -DSFFE_CMPLX_GSL -I/tmp/XaoS-3.4/src/include   -c -o sffe.o sffe.c

-----snip ------

gcc -Wall -fstrength-reduce -ffast-math -pipe -fno-exceptions -Os -fstrict-aliasing -malign-double -mno-ieee-fp  -I/usr/include -fomit-frame-pointer -DSFFE_USING -DSFFE_CMPLX_GSL -I/tmp/XaoS-3.4/src/include  -o /tmp/XaoS-3.4/bin/xaos lib/libui.a lib/libui-hlp.a lib/libengine.a lib/libutil.a lib/libfilter.a lib/libuix11.a lib/libsffe.a  -lpng -lz -lm  -lXext   -L/usr/lib64 -lX11 -L/usr/lib64 -lgsl -lgslcblas -lm
if  "yes" = "yes" ]; then make -C i18n/ all; fi
make[2]: Entering directory `/tmp/XaoS-3.4/src/i18n'
/usr/bin/msgfmt -o -c -v --statistics cs.po
173 übersetzte Meldungen, 87 ungenaue Übersetzungen, 94 unübersetzte Meldungen.
/usr/bin/msgfmt -o -c -v --statistics es.po
168 übersetzte Meldungen, 82 ungenaue Übersetzungen, 104 unübersetzte Meldungen.
/usr/bin/msgfmt -o -c -v --statistics hu.po
336 übersetzte Meldungen, 2 ungenaue Übersetzungen, 16 unübersetzte Meldungen.
/usr/bin/msgfmt -o -c -v --statistics fr.po
321 übersetzte Meldungen, 22 ungenaue Übersetzungen, 11 unübersetzte Meldungen.
/usr/bin/msgfmt -o -c -v --statistics de.po
354 übersetzte Meldungen.
/usr/bin/msgfmt -o -c -v --statistics ro.po
328 übersetzte Meldungen, 15 ungenaue Übersetzungen, 11 unübersetzte Meldungen.
/usr/bin/msgfmt -o -c -v --statistics it.po
353 übersetzte Meldungen, 1 unübersetzte Meldung.
make[2]: Leaving directory `/tmp/XaoS-3.4/src/i18n'
make[1]: Leaving directory `/tmp/XaoS-3.4/src'


Woks for me™ on

cat /etc/SuSE-release
openSUSE 11.1 (x86_64)
VERSION = 11.1

Perhaps you should reread this thread carefully to get an idea what you need.

Well, at the time I tried I had GSL (but not gsl-devel that I assume to contain gsl-config) installed and that part looked different here:

Complex math parser:
try GSL: yes
checking for gsl-config... no
checking for GSL... no
checking for nasm... no
configure: error: Neither GSL, nor NASM is installed. XaoS is unable to compile.

and the version:

# cat /etc/SuSE-release
openSUSE 11.1 (i586)
VERSION = 11.1

Btw, nasm is also outdated, yast just claimed to install version 2.03.90-1.3-i586 (from Factory/snapshot), nasm itself thinks different:

# nasm -v
NASM version 2.04rc1 compiled on Sep 16 2008

So yast doesn’t know that the version it installed is a bit newer :stuck_out_tongue: - but still, version 2.04 (final) was released 2008-09-25, version 2.05 (final) was released 2008-10-23, the actual version is 2.06rc12, released 2008-05-06.

With nasm 2.04rc1 installed, it looks like this:

Complex math parser:
try GSL: yes
checking for gsl-config... no
checking for GSL... no
checking for nasm... yes
using NASM for complex numbers

Now I must find out what would be better: Using nasm or GSL.

Have fun

Wrong I’m afraid, the naming scheme of the rpm and the version of the binary are not automatically the same.

In this case the packager was clever, because he chose the often used way to give a version to a rc which is smaller than the number of the upcoming release, if you would name it “2.4rc1” it would be regarded as newer compared to a later released “2.4” and the update via zypper up would be blocked, because it would not be considered an update.

Look at the packages in KDE4-factory, which are KDE4.3 beta but are named “KDE-4.2.86” or something like that.

  • but still, version 2.04 (final) was released 2008-09-25, version 2.05 (final) was released 2008-10-23, the actual version is 2.06rc12, released 2008-05-06.
    So what?

You must learn to understand the packaging policy of openSUSE and many other distros (*Buntu, Debian to name only a few).

There are no official version updates during the life cycle of a released distribution, fixes/security updates are backported to the older versions, with only a few exceptions (Firefox, although I think this is only to keep people away from constantly asking why there is no update available because the version is not changing, although the fixes have been backported to the “older” version and you pretty much have the same Firefox just with another “number” behind it.)