GRUN Dominates, and is taking over everything!!!

I currently have opensuse 11.2 - gnome installed on my laptop ( Toshiba Satellite m45-s265). I am trying to boot oof of my opensuse 11.2 DVD (32-bit) and its just not happening. For this particular computer I have to hit f10 upon startup to chose where I boot from. I chose cd-rom, it goes to bootsplash. I even went as far to adjust my BIOS settings to boot directly from CD, grub - bootsplash screen.

When I initially installed 11.2 I never had this problem. I have never messed with grub, or BIOS on this cpu before.

Why is grub taking over my life !?!

-cheers

…and at this point, I would be happy to access the cd through nautilus, and do a fresh install from there…can anyone direct me to the file that I need to open?

thanks in advance for the help

-cheers

Might be a dud download. Test it in another computer, choose to test the DVD from the boot menu.

testing the DVD, or booting from the DVD is not on the boot menu. Also, I have been using the DVD a lot more than I would like to admit for installing and has always worked fine…

…sorry :slight_smile:

-cheers

Your not holding you mouth right. Stick you tung out like this when booting :stuck_out_tongue:
rotfl!

Seriously If you are getting to boot screen you are not booting to the CD. This is a BIOS setting. Are you sure you are saving the BIOS after setting the CD/DVD drive to boot?

yes I saved my settings, to be sure I did it again, same result

is there a way I can launch the 11.2 installer from inside the GUI(gnome)? via nautilus?

frustrated

-cheers

No

There’s one of three possible things happening
[LIST=a]
[li]The dvd is faulty[/li][li]The opticval drive in the computer is faulty (including wrong bios settings or other finger trouble from you)[/li][li]The DVD is misaligned for that optical DVD[/li][/LIST]

If you run these three tests you will be able to figure out which of the above three situations pertains:
[ol]
[li]boot a different CD/DVD in the Toshiba, e.g. some other live CD like openSUSE Live, Knoppix, windows xp install CD, vista install DVD. This CD/DVD will either boot or it won’t.[/li][li]boot that different CD/DVD in a windows computer and it will either boot or it won’t[/li][li]boot the openSUSE install DVD in the windows computer. It will either boot or it won’t[/li][/ol]

What happens in the 1,2, 3 run will tell you which of a,b,c pertains.

Isn’t there something I can type into boot options to get it to boot from CD-ROM?

I did all of those tests, and got nothing from it. The CD works. The CD-ROM is reading the CD when I put it when when the GUI is already popped up. Its just very adamant about loading up grub no matter what route I take…

-cheers

Did you check the boot sequence in the BIOS?

yes I did, I went and reset it ( and saved) to boot from CD-ROM, and right when I save/exit…text pops up and says " GRUB 1.5 loading" than almost instantly my boot menu ( bootsplash?) pops up…

-cheers

It sounds to me as though the DVD rather than the drive has degraded and is no longer completely readable and thus bootable. Swerdna has covered this in a previous post. It would be helpful if you were to try out those suggestions or at least give some indication of why you are unable to do so.

If the DVD is not bootable, then even if set to boot from that first in the bios, the computer will try the second best option, which presumable is to boot from the hard disk. That is why you keep seeing GRUB loading - it is bios option number 2 (probably).

CDs and DVDs degrade, especially if they are rewritable because they use a dye to retain the information and that fades with time. It may be temperature and illumination dependent so, if you store the DVD in a cool dark place, it may survive for longer.

Booting operating system #2 (your DVD) from operating system #1 (your OS on the hard drive) is probably not possible because operating system #1 will try and protect its survival. Thus you cannot boot from a console.

I would suggest you try and carry out a couple of simple tests on the DVD from inside the hard disk operating system. Stick the disk in the drive and then, if it mounts, dismount it. Then as root try (assuming your DVD device is /dev/sr0):

  1. ‘cfdisk /dev/sr0’. This will come up with warning message (if the DVD is interpretable) ‘Opened disk read-only - you have no permission to write’ Press Enter to acknowledge and then you should see the partition and boot flag information. If it looks OK press ‘q’ to quit and try test 2)

  2. ‘badblocks -sv /dev/sr0’. This is a bad blocks test which will check if all sectors are readable. Sometimes it goes wrong near the last block but if some of the early blocks are listed as bad then the DVD is useless.

If you don’t want to do that I should just re-burn the DVD.

Hope that helps.

Problem solved, it wasn’t hardare, not sure what it was, but I know I got past the hard part,

see Kernel v - openSUSE Forums

thanks everyone for the effort/assistance!!!

-cheers