grub2 without efi does not boot without its efi partition

I may have installed openSuse 13.2 in Efi-mode years ago, at least now it doesn’t uses it, proven by the output of “efibootmgr”:

Fatal: Couldn't open either sysfs or procfs directories for accessing EFI variables.

even after running modprobe efivars.
Now I want to disconnect the disk with the efi partition. After disconnectiong it, the grub2-Bootmanager starts but not Opensuse 13.2.
It runs into a ram disk where it writes an rdsosreport.txt.
This ends up with the lines:

1583   188.009869] linux1 dracut-initqueue[389]: Warning: Could not boot.
1584   188.015170] linux1 dracut-initqueue[389]: Warning: /dev/disk/by-uuid/3020-7F4C does not exist

The specified uuid belongs to the efi partition on the disconnected disk.
The error occurs irrespective of a new bootloader configuration in Yast by choosing grub2, not grub2-efi.
I grepped all directories named ‘grub*’ for a file containing “3020-7F4C” without result.
After reconnecting the disk, the error disappears.
I couldn’t google the same problem.
Can anyone help me?

P.S.: The uefi-partition was not claimed in /etc/fstab

Little confuse can you or can you not bot. If not how did you run Yast?

Also it seems you may have both EFI and legacy boot. On another disk?? mixing boot modes can cause confusion. All should be EFI or all legacy.

There was a recent update to grub and certain machine seem to have a problem with it. What does the EFI BIOS show you as boot options?

There must be a efi boot partition formatted as FAT to boot in EFI mode

This is unrelated to grub. Apparently your initrd attempts to mount this partition. Try to recreate initrd.

Thank You for Your fast replies!
@arvidjaar](https://forums.opensuse.org/member.php/69818-arvidjaar): This must be the solution! I’ll apply it on Wednesday because I must not boot the server earlier.
@gogalthorp](https://forums.opensuse.org/member.php/37208-gogalthorp): I can/could boot only in presence of the disk I want to discard. I fear I may not have EFI boot at all because of a suboptimal operating system installation.

Without a detail look at your partitioning it is impossible to tell. You may have the EFI partition on the drive you want to go. Also moving partition (depending how) can cause a change in the partition UUID and this cause problems for the /etc/fstab… so you should look there also to be sure that the table is mounting the correct UUID’s for the new situation

   188.009869] linux1 dracut-initqueue[389]: Warning: Could not boot. 1584   188.015170] linux1 dracut-initqueue[389]: Warning: /dev/disk/by-uuid/3020-7F4C does not exist

The specified uuid belongs to the efi partition on the disconnected disk. This is a dracut bug. It shouldn’t be dragging in the UUID of the EFI System partition for exactly the reason you’ve experienced. The EFI System partition shouldn’t be persistently mounted anyway (that’s a separate bug), in the meantime you can use /etc/fstab mount options for /boot/efi: x-systemd.automount,nofail and now it will only get mounted when something needs to update it. You can remove the old ESP UUID by rebuilding the initramfs, use dracut -f for that. P.S. can anyone tell me why the forum smashes all of my formatting into one big long line? Even when I use the word code in brackets, when I hit submit it reformats the code, deleting all returns. It’s pretty annoying for default behavior.

Is there any chance that you are still mounting “/boot/efi” via “/etc/fstab”?

And maybe you need to run “mkinitrd”.

You are probably not using “firefox”.

If you click the “A” icon near to left of edit box, it probably won’t do that.

I’m using “konqueror”. I’ve configured it to pretend that it is firefox when accessing the forums. That seemed to fix the problems with copy/paste.

Firefox 44.

If you click the “A” icon near to left of edit box, it probably won’t do that.

OK, so now it seems to be working and it doesn’t matter whether I’m in source mode or wysiwyg mode. Love non-deterministic behavior.