grub2 rescue:

Iv’e had a bit of trouble loging on ,but, managed to use PF 12 to get on. To give a little background… i only installed opensuse 12.3
to days ago. on a dell insperion 660 desktop running windows 8. last nite yast ran some updates ( about 4 hrs worth ) it then requested a reboot, now all get is a black screen that reads Grub rescue
i fond a lot of information on line. i used ls to find what my drive and partition were - (hd1,msdos1) all was going well untill i typed
insmod linux . message = no such directory. – DON’T KNOW WHAT TO DO –

You need a Live bootable DVD you can make from the download page, but you have to have some sort of burner software working: openSUSE Download , You can use these instructions to reload grub: https://forums.opensuse.org/content/128-re-install-grub2-dvd-rescue.html.
If you created an openSUSE boot disk to start with, just use that for the repair.

It sounds like grub 2 got messed up during the update some how. I have had that occur myself. It is most often occurs in a dual boot setup, with two or more hard drives setup as something in the grub update goes astray. The people that write this update stuff simply do not do enough testing often before the update gets pushed down the line to the rest of us. The best we can do is to try and recover from the mess and post a bug report if we have enough information later to do so.

Thank You,

Check whether this is the right drive. Use “ls (hd1,msdos1)/” to list top level directory; and make sure it has /boot/grub2 directory - “ls (hd1,msdos1)/boot/grub2”. What content is displayed and also what is displayed when you type “set”?

I am currently running 12.3 on a Dell Inspiron 660 that came with Windows 8 (and still has Windows 8). It is currently working pretty well, though I did have some periods of head-scatching.

You have not provided sufficient information for me to be able to help.

I’m pretty sure that your Dell came with UEFI firmware, and with secure-boot enabled.

It sounds to me as if you have disabled secure-boot, and installed opensuse in legacy MBR mode rather than UEFI mode. And, quite possibly, you don’t know what I am talking about here.

Can you provide a bit more information on how you installed, and on how grub2 was originally setup?

Did you install 64bit opensuse or 32bit opensuse?

And, for reference, my system is 64bit, installed in UEFI mode.

in responce to your questions i installed it in secure mode. i installed the same iso to a 128 memory stick that had some trouble, so
i partiioned my 1 t b hard drive and installed it on that. Everthing seemed ok untill i downloaded the updates last night. (( took over 4 hrs)) and when i tried to reboot … I got grub rescue … and i really don’t wish to go though another install.

That’s already a puzzle for me, since that should not happen with a UEFI install.

As long as you installed the 64bit version, a new-install should not be needed.

1: Is Windows 8 still working?
2: If you are able to boot the install media in rescue mode, can you provide the output from:


# df
# gdisk -l /dev/sda
# parted -l
# efibootmgr -v

If you boot the DVD, then the “gdisk” command probably won’t work. If you have live 12.3 media, then “gdisk” should work.

If you are able to get that output, please post using code tags. If you click on the “#” near the top of the edit box,
that will generate the code tags. Paste your output between those.

i ran rescue from my dvd and where it stoped and promped for id > ityped in root and much to my supprise it gave me a red '#" prompt, at this point i have no idea what i should type there ?

i ran all the commands you suggested and got lots of data back ,there wasn’t any way to cature it. no return on gdisk though.

You can save the output to a text file in “/tmp”. Then mount a USB, and copy the file to the USB.

You did not answer on whether Windows 8 is still working.

It sounds like grub is loading but doesn’t know what to do next. It sounds like you’re at the grub shell. If you hit <tab> twice, it should give you the list of possible commands (like boot). It’s possible grub wasn’t updated correctly.

i have a 500gig usb drive with ubuntu on it and i get to windows 8 from there. …no way to boot from C: drive. i stated a fresh install of opensuse last night, a box poped op and stated there was an error in grub , at that time i aborted the install. today i am downloading a fresh iso, hope to have better luck with it.

Brand new attempt to install this am downloaded a fresh iso 64 bit. that started all over again, the install looked like it was doing ok, but , when it came time to reboot – no luck – not only that i can’t boot windows 8 from that drive ether.
somehow i have to delete the boot record that’s on there. any ideas?

With the info given no idea.

Often the problem is with the video but You have not told use enough. It’s broke is not enough info

You should always check the check sums on the ISO and also run media check. I suspect you really did not need to download again

WHATS GOING ON HERE ? let me explain th comment i have installed opensuse 12.3 three times …and every time i have run the update patches with yast …the following reboot me machine fails…this i got booted up ok, but, no desktop !! ( and durimg the update a box popped up and informed me there was an error in KDE i tried retry a few times with no success and then i hit abort … the screen whent blank … now what ??

Can you remember what the error message was?

Because you aborted the update, presumably some packages got updated while others didn’t, and that’s why starting KDE now fails.

So, try to login in text mode (or choose a different session like IceWM on the login screen if that does appear), and run “sudo zypper up” to complete the update.