GRUB2 openSUSE Branding - Boot Error, Missing Files

I may have done a mistake and I would appreciate who may help me.

Before the issue occurred, I wanted to remove the branding by openSUSE applied to the GRUB menu, by uninstalling “grub2-branding-openSUSE”. But I didn’t realize to install* “grub2-branding-upstream”*.
Now when turning on my laptop this appears:

error: file'/boot/grub2/themes/openSUSE/DejaVuSans-Bold14.pf2 not found
error: file'/boot/grub2/themes/openSUSE/DejaVuSans10.pf2 not found
error: file'/boot/grub2/themes/openSUSE/DejaVuSans12.pf2 not found
error: file'/boot/grub2/themes/openSUSE/ascii.pf2 not found
alloc magic is broken at 0xd2c4fd00: 0
Aborted. Press any key to continue

How can I fix this?

I’m not sure what you were trying to do.

To fix this, you will need to get into your system. So let’s talk about doing that.

Method 1: try the supergrub disk (use a google search). That might be able to boot you into your system.
Method 2: use your install media, and boot it to rescue mode. That won’t get you fully into your system, but may be enough for repairs.

Once you have access to your system, you can try editing “/boot/grub2/grub.cfg”. Look for lines that reference the theme, and try commenting them out (just search for “theme”). I have not tried that, because I would have to cripple my own system to test it. But I think that will get you an unthemed boot menu.

If you manage to get fully into your system, then just use Yast Boot Loader. Look in the “kernel parameters” tab. Uncheck the box for “Graphical Console”. That should give you an unthemed boot menu for future boots.

I used SuperGrub2 and was able to access openSUSE and fix GRUB!
**
THANK YOU VERY MUCH!
lol!lol!lol!**

Irrespectively of what caused it it is a bug. If you have step by step instructions how to reproduce it, consider opening bug report.

FYI: When rebooting the machine anyway I first ran ‘zypper rm --clean-deps grub2-branding-openSUSE’. On reboot grub presented its menu (without the graphics background) and proceeded normally at it has done since ever. Thus I presume you made changes you aren’t aware of. :wink:

I’ll note that this has been reported as Bug 1186481.