Grub2 menu flashes a new screen everytime it updates the screen

I’ve had this problem since updating to 42.2 on my desktop computer and always on my small Aspire E 11 Acer laptop. The grub2 menu screen is like it doesn’t recognize the capabilities of the computer screen and video card, so when I go down to select the next thing in the menu, the screen flashes while updating the screen to highlight the next menu item. I’ve included a picture of the screen at boot menu. It should have the opensuse branding and be much better resolution but it’s is the picture link

You can change the resolution of the menu in /etc/default/grub.





Save your edit and run:

grub2-mkconfig -o /boot/grub2/grub.cfg

You can also start Yast2 Control Center and start up the Yast2 Boot Loader. Click on the Kernel Parameters tab.
Click on the dropdown arrow under Console resolution. Pick a higher resolution then click on the **OK **button.

The changes get written to the grub file. Reboot your system to see the changes.

Well, I thought I had tried all of that, but I gave it a whirl, both on my laptop and desktop. two things helped me:

vbetest and hwinfo --framebuffer.
to run vbetest I had to restart computer, in grub2 enter “c” and it will take you to grub console. In console type

grub> vbetest <resolution>

where is the resolution to test if it works on your computer/screen
for example

grub> vbetest 1280x1024

you can also try a color depth (1280x1024x24 for instance)
if the resolution works it will come up with a box with different colors in top left and a blue box with text centered in the middle
unfortunately you must reboot the computer to try another resolution. If it doesn’t work, you just get a black screen and you will need to reboot. It is fairly snappy so don’t think you have to wait very long if it doesn’t work.
The resolutions to try are found in the

sudo hwinfo --framebuffer

I have a 1600x1200 screen and a 1920x1080 screen on my desktop. Unfortunately only the 1280x1024 worked in grub for my desktop computer. But at least I don’t have that pathetic screen that refreshed with each keystroke.

Unfortunately my little aspire e11 can only do 640x480 in grub and so it still has the pathetic refreshing screen, which I will be changing to text mode. it has an uncommon max res of 1366x768, so I was pretty sure it wouldn’t work.

One may be lucky enough to get vbeinfo to work instead of vbetest, where it should output all available resolutions. It wouldn’t work for me (or videoinfo, videotest I am told for EFI).

Also, if you enter multiple resolutions in /etc/default/grub and try to open the bootloader options in Yast it complains about augeas-lenses and such. Just put a valid single resolution back in the file and it should open in Yast.

Thanks for forcing me to tackle this problem Romanator

I might as well add, I had so many problems with 42.2 on 4 different computers, but am running 42.3 on my aspire e11 and it seems to be a lot more stable, especially plasma 5. Can’t wait till it comes out and I can put it on all my computers.