Grub2 gives a command prompt instead of a graphic menu


I have been using OpenSuse 11.3 (Gnome) for a long time. I recently installed 12.2 (KDE) on a separate partition (a separate physical disk) and while installing opted for grub installation on the root partition (as opposed to whatever the default was). Basically I did not want to mess up with my 11.3 installation which had served me for years.

When the system rebooted, I saw the same old grub menu from 11.3 which makes sense as my BIOS had boot priority for the disk on which 11.3 was installed. I then changed the priority to the disk on which 12.2 was installed. On rebooting I was faced with a grub command prompt and had no clue how to proceed.

I switched back to the 11.3 disk in the BIOS boot priority and my 12.2 installation is lying unused now.

Any ideas how I can use my 12.2 installation normally?

Put the boot order as it was when you installed 12.2

Let 12.2 control booting. Here is what to do:

Thanks a lot. It works now!:slight_smile:


Last night I tried to move my oS11.4 box to 12.2. I am running the install from the DVD iso and am doing a complete new installtion but keeping my /home and other data partitions. Whilst going through the installation and configuring the boot, I chose to boot from the /boot partion which is on sda2. I didn’t choose to save to the MBR.

The install seemed to go well until the box rebooted and I ended up with the grub> prompt.
I tried following the instructions in the this post Re-install Grub2 from DVD Rescue but it doesn’t seem to be working for me. Below are screenshots of my process and errors.

The grub prompt](

What I did and the error message](

I then got tried running

grub2-mkconfig -o /boot/grub2/grub.cfg

to see if that would help but it didn’t.](

Any help would be appreciated.

Sorry, I just spotted I typo and missed the 10min cut-off. I meant to say I set grub2 to boot from the / partition not /boot.

Your first image (grub prompt is for grub legacy) not grub 2

Run the install again with these options:

Thanks caf. I tried as you said and set the boot parameters as shown in that screenshot but get the following errors when the installation gets towards the end of the process.

First this message (3 images so you can see the message fully scrolled)](](](

Then this after pressing OK.](

I am not sure I really understand what’s different with the way grub2 works but it seems a lot more complicated than legacy grub was.

EDIT: I did verify the installation media before I started and it to passed fine.

Run the installer and proceed to the summary
Show us the details of the summary and the click thru details of the Booting section

OK here is the summary](](

Here is the booting section](](

Hopefully you’ll spot something in there.

I’m starting to think maybe my installation media is not 100% even though it passed the media check. How good is that media check in the install menu? Does it check against a checksum?

OK, I sorted the problem - well actually eliminated it. Through frustration in trying to make it work I gave up and decided to open the box and swap the two HDD controller cables over. Re-did the installation and chose to boot from / which is now on sda instead of sdb and it all worked flawlessly.

Thanks for your help caf. I’m not sure, and probably will never understand, why it didn’t work before as I had no problem with that HDD set up before trying to install 12.2.

It can be complicated. I am just happy you managed to resolve it.
One other thing that can be worth checking is the order here:
Sometimes I have had it different here than in fdisk or the yast partitioner and needed to toggle the order to match the known order in the BIOS