Grub2 fix mbr

Hi all.I have installed opensuse 12.2 with grub2 installed in mbr.because of some testings I have lost my mbr.Nlonger I can to fix that with opensuse 12.2 dvd rescue system menu?

Have you tried using a utility disk like Supergrubdisk
Once in SUSE run: grub2-mkconfig -o /boot/grub2/grub.cfg

I have only access to my opensuse installation dvd. Is’nt anyway to repair with the dvd disk?

It’s all command line. Please proceed with caution. I’m not 100% sure about the detail. Re-installing your system might be safer…

You can chroot to the installed system (that’s your / partition) so,

Boot the rescue and at the login type: root

**fdisk -l **will display your partitions as a reminder

In this I will assume sda1 as / (you need to change to suit your setup) so at the # prompt:
mount /dev/sda1 /mnt

mount --bind /dev /mnt/dev

chroot /mnt

I think you should now be able to start yast with:

From here you can re-install grub or just re-install the kernel will do it to

That would be my recommendation.

Tnx all.
I Solved it by

mount /dev/sdYX /mnt

where Y is my hard letter in this example “a” and X is my root partition in this example 2

grub-install.unsupported --root-directory=/mnt/ /dev/sda
and get grub legacy back.
then boot to the system and installed the grub2 via yast.
all things are fine now