Grub2 doesn't boot in VIA C3 Samuel 2. Only Grub legacy

Grub2 doesn’t boot in VIA C3 Samuel 2 800Mhz. openSUSE is the main and only OS installed, and it has 512MB RAM.

My old computer kept rebooting right after the BIOS (no error messages, plain reboot)… I tried re-installing grub2, repartitioning the disk and installing OpenSuse 13.2 like 10 times, with no luck

I gave up on GRUB 2, booted Slitaz 5.0 RC2, and used it to install and configure grub legacy. My old PC is finally working again and it’s rock solid running openSUSE 13.2. Does anyone know if this is a known bug?

Details:
I installed openSUSE from the full DVD and I made sure GRUB2 got installed in the MBR
My current partitions:
sda1 -> ext2 -> /boot
sda2 -> ext4 -> /
sda3 -> swap

(I tried so many things that I don’t even care anymore that the swap partition is the last one)

The CPU is 10 years old, and it has a very reduced capabilities. Being the most important the lack of CMOV, but it’s still an i586 and not an i686, which makes me assume that openSuse i586 should work just fine.

I used these pages to restore grub2:
https://en.opensuse.org/SDB:Repair_MBR_after_Windows_install
https://en.opensuse.org/SDB:Partitioning

Thanks

I did not hear about it, but such problems require hardware to reproduce and fix. If you are willing to help fixing it, the first step would be to test latest upstream grub, it completely avoids using libgcc. As grub itself is built with -march=i386 I expect it to work.

When you say “upstream”, what do you mean? First time using openSUSE. Is it just a regular package update I can perform from Yast? or should I try a dev branch somehow?

Do a google search for “grub”. See if you can find a home page.

Opensuse gets is sources from there, so it is upstream relative to opensuse. You will get a version without any opensuse mods or adaptations.

Thanks, now I know what he meant with “upstream”. I’ll give it a try.

https://savannah.gnu.org/git/?group=grub

After this

./autogen.sh
./configure
make
pkgdatadir=$PWD ./grub-mkrescue -d grub-core -o grub.iso

Burn ISO (or dd onto USB, it is bootable as well).

You will need some extra development packages to build it, post (or ping privately) if you have questions. Also grub-mkrescue requires mtools and libburnia-tools, they are included in standard openSUSE repositories.

I downloaded the sources and compiled it in the same machine (just in case). I burned the .iso into a new cd, and restarted.

Sadly it didn’t work. The machine rebooted itself trying to boot from the grub2 CD. Same as before, no error message, no time to read anything. The machine restarts 1 second after the BIOS finishes.

Looks like I’ll have to keep using Grub legacy

Hmm … very similar one is https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=776098 and it says that older version worked. If you could open bug report for grub on https://savannah.gnu.org/bugs/?func=additem&group=grub and assist in debugging it it would be great.

No problem.
https://savannah.gnu.org/bugs/index.php?45149

I still have to test disabling the cache.

I don’t have the option to disable the entire CPU cache in my BIOS like the original bug, but I did disable L2 cache and it had no effect. It still reboots