Grub2 default boot

SuSe 13.1
I (rather my wife) would like grub to boot to my win7 partition by default after the 8 second countdown.

My fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes, 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0x07f2837e

Device Boot Start End Blocks Id System
/dev/sda1 63 208844 104391 de Dell Utility
/dev/sda2 212992 41172991 20480000 7 HPFS/NTFS/exFAT
/dev/sda3 41172992 731011119 344919064 7 HPFS/NTFS/exFAT
/dev/sda4 * 731015166 976771071 122877953 f W95 Ext’d (LBA)
/dev/sda5 731015168 812931071 40957952 7 HPFS/NTFS/exFAT
/dev/sda6 812933120 817145855 2106368 82 Linux swap / Solaris
/dev/sda7 817147904 881358847 32105472 83 Linux
/dev/sda8 881360896 976752639 47695872 83 Linux

Also, when I boot SuSe 13.1, I’d prefer to see all that text scrolling by than a background JPEG.

Thankin’ You!


OK’ Bootloader in YAST fixed my default OS.

I’d still like to see text flying by instead of the default SuSe JPEG.

Last time I messed with those bits, well, it wasn’t good.


You can press the escape key at boot time or shutdown. Now if you want to make it default you can adjust it using yast2 bootloader as well. You can call that module using your terminal.

yast2 bootloader

Click this button.


Edit the entry under this line.

Optional Kernel Command Line Parameter

Then change from


into this


Click the ok button and you should be good.

Uninstall “plymouth”. And then, run

# mkinitrd

That is also an option and this is another.

Replace silent with versbose in /etc/default/grub

ex -sc '%s/silent/verbose/ge|x' /etc/default/grub

Make the change.

grub2-mkconfig -o /boot/grub2/grub.cfg